summaryrefslogtreecommitdiff
path: root/packages/bluez
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-libs_3.36.bb2
-rw-r--r--packages/bluez/bluez-utils_3.36.bb2
-rw-r--r--packages/bluez/bluez4-utils_4.24.bb66
-rw-r--r--packages/bluez/bluez4/hid2hci_usb_init.patch33
-rw-r--r--packages/bluez/bluez4/sbc-thumb.patch11
-rw-r--r--packages/bluez/bluez4_4.27.bb53
-rw-r--r--packages/bluez/bluez4_4.7.bb11
7 files changed, 100 insertions, 78 deletions
diff --git a/packages/bluez/bluez-libs_3.36.bb b/packages/bluez/bluez-libs_3.36.bb
index 6ddf62a4fb..8e0e467bc9 100644
--- a/packages/bluez/bluez-libs_3.36.bb
+++ b/packages/bluez/bluez-libs_3.36.bb
@@ -1 +1,3 @@
require bluez-libs.inc
+
+PR = "r1"
diff --git a/packages/bluez/bluez-utils_3.36.bb b/packages/bluez/bluez-utils_3.36.bb
index 403e32b1e2..b66e601e92 100644
--- a/packages/bluez/bluez-utils_3.36.bb
+++ b/packages/bluez/bluez-utils_3.36.bb
@@ -1,6 +1,6 @@
require bluez-utils3.inc
-PR = "r1"
+PR = "r2"
# removed hciattach-ti-bts.patch (landed upstream)
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
diff --git a/packages/bluez/bluez4-utils_4.24.bb b/packages/bluez/bluez4-utils_4.24.bb
deleted file mode 100644
index 56fc039496..0000000000
--- a/packages/bluez/bluez4-utils_4.24.bb
+++ /dev/null
@@ -1,66 +0,0 @@
-require bluez.inc
-
-PR = "r0"
-
-SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
- file://hcid.conf \
- file://sbc-thumb.patch;patch=1 \
- file://hid2hci_usb_init.patch;patch=1 \
- "
-
-# see bluez.inc for the explanation of these option
-EXTRA_OECONF = " \
- --enable-bccmd \
- --enable-hid2hci \
- --enable-hidd \
- --enable-pand \
- --enable-dund \
- --disable-alsa \
- --disable-cups \
- --enable-glib \
- --disable-sdpd \
- --enable-network \
- --enable-serial \
- --enable-input \
- --enable-audio \
- --enable-echo \
- --enable-configfile \
- --enable-initscripts \
- --enable-test \
- "
-
-CONFFILES_${PN} = " \
- ${sysconfdir}/bluetooth/hcid.conf \
- ${sysconfdir}/default/bluetooth \
- "
-
-CONFFILES_${PN}-compat = " \
- ${sysconfdir}/bluetooth/rfcomm.conf \
- "
-
-PACKAGES =+ "bluez-audio"
-
-FILES_${PN} = " \
- ${base_sbindir}/hcid \
- ${libdir}/bluetooth/plugins/*.so \
- ${sysconfdir}/init.d/bluetooth \
- ${sysconfdir}/bluetooth/hcid.conf \
- ${sysconfdir}/default \
- ${sysconfdir}/dbus-1 \
- ${base_sbindir}/hciattach \
- "
-
-FILES_bluez-audio = " \
- ${libdir}/bluetooth/plugins/libaudio.so \
- ${libdir}/gstreamer-0.10/*.so \
- "
-
-FILES_${PN}-dbg += " \
- ${libdir}/bluetooth/plugins/.debug \
- ${libdir}/gstreamer-0.10/.debug \
- "
-
-FILES_${PN}-dev += " \
- ${libdir}/bluetooth/plugins/*.la \
- ${libdir}/gstreamer-0.10/*.la \
- "
diff --git a/packages/bluez/bluez4/hid2hci_usb_init.patch b/packages/bluez/bluez4/hid2hci_usb_init.patch
new file mode 100644
index 0000000000..ed15fd5a1b
--- /dev/null
+++ b/packages/bluez/bluez4/hid2hci_usb_init.patch
@@ -0,0 +1,33 @@
+# Signed-off-by: Khem Raj <raj.khem@gmail.com>
+#
+# Use the new usb1 API for usb_init() and check for fails from
+# usb_init (). Currently we see a crash on a system which does
+# not have USB because usb_init() fails and it cleans up all initialized
+# data (e.g. ctx) which is used in subsequent calls to libusb
+# We return immediately if usb_init() fails for some reason.
+
+Index: bluez-4.24/tools/hid2hci.c
+===================================================================
+--- bluez-4.24.orig/tools/hid2hci.c 2008-10-25 23:40:34.000000000 -0700
++++ bluez-4.24/tools/hid2hci.c 2008-12-29 22:06:04.000000000 -0800
+@@ -337,7 +337,7 @@
+ int main(int argc, char *argv[])
+ {
+ struct device_info dev[16];
+- int i, opt, num, quiet = 0, mode = HCI;
++ int i, ret, opt, num, quiet = 0, mode = HCI;
+
+ while ((opt = getopt_long(argc, argv, "+01qh", main_options, NULL)) != -1) {
+ switch (opt) {
+@@ -361,8 +361,9 @@
+ argc -= optind;
+ argv += optind;
+ optind = 0;
+-
+- usb_init();
++ ret = libusb_init();
++ if (ret < 0)
++ return ret;
+
+ num = find_devices(mode, dev, sizeof(dev) / sizeof(dev[0]));
+ if (num <= 0) {
diff --git a/packages/bluez/bluez4/sbc-thumb.patch b/packages/bluez/bluez4/sbc-thumb.patch
new file mode 100644
index 0000000000..3505426053
--- /dev/null
+++ b/packages/bluez/bluez4/sbc-thumb.patch
@@ -0,0 +1,11 @@
+--- bluez/sbc/sbc_math.h~ 2008-03-05 20:18:03.000000000 +0000
++++ bluez/sbc/sbc_math.h 2008-10-27 13:39:27.000000000 +0000
+@@ -59,7 +59,7 @@
+
+ #define SBC_FIXED_0(val) { val = 0; }
+ #define MUL(a, b) ((a) * (b))
+-#ifdef __arm__
++#if defined(__arm__) && !defined(__thumb__)
+ #define MULA(a, b, res) ({ \
+ int tmp = res; \
+ __asm__( \
diff --git a/packages/bluez/bluez4_4.27.bb b/packages/bluez/bluez4_4.27.bb
new file mode 100644
index 0000000000..c0d5c19c2e
--- /dev/null
+++ b/packages/bluez/bluez4_4.27.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-lib libusb1 dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://sbc-thumb.patch;patch=1 \
+ file://hid2hci_usb_init.patch;patch=1 \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools pkgconfig
+
+OE_LT_RPATH_ALLOW = "any"
+OE_LT_RPATH_ALLOW[export] = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --disable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/*/*.la \
+"
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"
diff --git a/packages/bluez/bluez4_4.7.bb b/packages/bluez/bluez4_4.7.bb
deleted file mode 100644
index ae579dd0ae..0000000000
--- a/packages/bluez/bluez4_4.7.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Linux Bluetooth Stack Userland."
-SECTION = "libs"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.bluez.org"
-LICENSE = "GPL"
-PR = "r0"
-
-SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz"
-S = "${WORKDIR}/bluez-${PV}"
-
-inherit autotools pkgconfig