summaryrefslogtreecommitdiff
path: root/packages/bluez
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bluez')
-rw-r--r--packages/bluez/bluez-gnome_0.6.bb3
-rw-r--r--packages/bluez/bluez-gnome_cvs.bb14
-rw-r--r--packages/bluez/bluez-libs_3.10.bb1
-rw-r--r--packages/bluez/bluez-utils.inc8
-rw-r--r--packages/bluez/bluez-utils/uclibc-fix.patch46
-rw-r--r--packages/bluez/bluez-utils_3.10.1.bb115
-rw-r--r--packages/bluez/bluez-utils_3.9.bb11
7 files changed, 192 insertions, 6 deletions
diff --git a/packages/bluez/bluez-gnome_0.6.bb b/packages/bluez/bluez-gnome_0.6.bb
index 481a383019..b8b7511cbf 100644
--- a/packages/bluez/bluez-gnome_0.6.bb
+++ b/packages/bluez/bluez-gnome_0.6.bb
@@ -5,6 +5,7 @@ DEPENDS = "bluez-libs dbus-glib gconf libnotify gtk+ openobex"
SRC_URI = "http://bluez.sourceforge.net/download/${P}.tar.gz"
-inherit autotools pkgconfig
+inherit autotools pkgconfig gconf
+FILES_${PN} += "${datadir}/gconf"
diff --git a/packages/bluez/bluez-gnome_cvs.bb b/packages/bluez/bluez-gnome_cvs.bb
new file mode 100644
index 0000000000..f30bbdd7ad
--- /dev/null
+++ b/packages/bluez/bluez-gnome_cvs.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "BLuetooth configuration applet"
+LICENSE = "GPL+LGPL"
+
+DEPENDS = "bluez-libs dbus-glib gconf libnotify gtk+ openobex"
+
+SRC_URI = "cvs://anonymous@cvs.bluez.org/cvsroot/bluez;module=gnome"
+
+PV = "0.6+cvs${SRCDATE}"
+S = "${WORKDIR}/gnome"
+
+inherit autotools pkgconfig gconf
+
+FILES_${PN} += "${datadir}/gconf"
+
diff --git a/packages/bluez/bluez-libs_3.10.bb b/packages/bluez/bluez-libs_3.10.bb
new file mode 100644
index 0000000000..6ddf62a4fb
--- /dev/null
+++ b/packages/bluez/bluez-libs_3.10.bb
@@ -0,0 +1 @@
+require bluez-libs.inc
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index 886a5a3d55..b6f9660fa7 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -48,10 +48,10 @@ do_install_append() {
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
${sysconfdir}/default/bluetooth"
-PACKAGES =+ "${PN}-ciptool bluez-cups-backend"
-FILES_${PN}-ciptool = "/bin/ciptool"
-RREPLACES_${PN}-ciptool = "bluez-utils-dbus-ciptool"
-RCONFLICTS_${PN}-ciptool = "bluez-utils-dbus-ciptool bluez-utils-nodbus"
+PACKAGES =+ " bluez-cups-backend"
+
+FILES_${PN} += " ${libdir}/alsa-lib/*.so "
+FILES_${PN}-dev += " ${libdir}/alsa-lib/*.la "
FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
RDEPENDS_bluez-cups-backend = "cups"
diff --git a/packages/bluez/bluez-utils/uclibc-fix.patch b/packages/bluez/bluez-utils/uclibc-fix.patch
new file mode 100644
index 0000000000..6d4753c2e5
--- /dev/null
+++ b/packages/bluez/bluez-utils/uclibc-fix.patch
@@ -0,0 +1,46 @@
+Uclibc doesn't define or support speeds above 115200. So check the existence
+of the defines before allowing them to actually be used.
+
+Index: bluez-utils-3.9/tools/hciattach.c
+===================================================================
+--- bluez-utils-3.9.orig/tools/hciattach.c 2007-05-17 12:34:28.000000000 +1000
++++ bluez-utils-3.9/tools/hciattach.c 2007-05-17 12:40:20.000000000 +1000
+@@ -105,22 +105,38 @@
+ return B57600;
+ case 115200:
+ return B115200;
++#ifdef B230400
+ case 230400:
+ return B230400;
++#endif
++#ifdef B460800
+ case 460800:
+ return B460800;
++#endif
++#ifdef B500000
+ case 500000:
+ return B500000;
++#endif
++#ifdef B576000
+ case 576000:
+ return B576000;
++#endif
++#ifdef B921600
+ case 921600:
+ return B921600;
++#endif
++#ifdef B1000000
+ case 1000000:
+ return B1000000;
++#endif
++#ifdef B1152000
+ case 1152000:
+ return B1152000;
++#endif
++#ifdef B1500000
+ case 1500000:
+ return B1500000;
++#endif
+ default:
+ return B57600;
+ }
diff --git a/packages/bluez/bluez-utils_3.10.1.bb b/packages/bluez/bluez-utils_3.10.1.bb
new file mode 100644
index 0000000000..44827dc2d0
--- /dev/null
+++ b/packages/bluez/bluez-utils_3.10.1.bb
@@ -0,0 +1,115 @@
+require bluez-utils.inc
+
+DEPENDS += "glib-2.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
+ file://hcid.conf \
+ file://02dtl1_cs.sh \
+ "
+PR = "r3"
+
+EXTRA_OECONF = " \
+ --enable-bccmd \
+ --disable-hid2hci \
+ --disable-alsa \
+ --enable-cups \
+ --enable-glib \
+ --disable-sdpd \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --enable-echo \
+ --enable-configfile \
+ --enable-initscripts \
+ --enable-test \
+ "
+
+# The config options are explained below:
+
+# --enable-obex enable OBEX support
+# --enable-alsa enable ALSA support, not needed for nokia770, nokia800 and fic-gtao1
+# --enable-cups install CUPS backend support
+# --enable-bccmd install BCCMD interface utility
+# --enable-avctrl install Audio/Video control utility
+# --enable-hid2hci install HID mode switching utility
+# --enable-dfutool install DFU firmware upgrade utility
+
+# --enable-glib For systems that use and install GLib anyway
+# --disable-sdpd The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server
+
+#Following services can be enabled so far:
+# --enable-network
+# --enable-serial
+# --enable-input
+# --enable-audio
+# --enable-echo
+
+#There is no need to modify any init script. They will be started
+#automatically or on demand. Only /etc/bluetooth/*.service files should
+#be patched to change name or the autostart value.
+# --enable-configfile
+# --enable-initscripts
+
+#For even smaller -doc packages
+# --disable-manpages
+# --disable-pcmciarules
+
+#I haven't seen any embedded device with HID proxy support. So simply
+#disable it:
+# --disable-hid2hci
+
+
+PACKAGES =+ "${PN}-compat"
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default/bluetooth \
+ "
+
+CONFFILES_${PN}-compat = " \
+ ${sysconfdir}/bluetooth/rfcomm.conf \
+ "
+
+FILES_${PN} = " \
+ ${base_sbindir}/hcid \
+ ${libdir}/bluetooth \
+ ${sysconfdir}/init.d/bluetooth \
+ ${sysconfdir}/bluetooth/*.service \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default \
+ ${sysconfdir}/dbus-1 \
+ ${base_sbindir}/hciattach \
+ "
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
+
+FILES_${PN}-dbg += " \
+ ${libdir}/bluetooth/.debug \
+ "
+
+FILES_${PN}-compat = " \
+ ${base_bindir}/sdptool \
+ ${base_bindir}/dund \
+ ${base_bindir}/rctest \
+ ${base_bindir}/ciptool \
+ ${base_bindir}/l2test \
+ ${base_bindir}/rfcomm \
+ ${base_bindir}/hcitool \
+ ${base_bindir}/pand \
+ ${base_bindir}/hidd \
+ ${base_bindir}/l2ping \
+ ${base_sbindir}/hciconfig \
+ ${base_sbindir}/bccmd \
+ ${base_sbindir}/hciemu \
+ ${base_bindir}/passkey-agent \
+ ${sysconfdir}/bluetooth/rfcomm.conf \
+ "
+
+FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
+RDEPENDS_bluez-cups-backend = "cups"
+
+
diff --git a/packages/bluez/bluez-utils_3.9.bb b/packages/bluez/bluez-utils_3.9.bb
index e710e8c8f6..60b5becd99 100644
--- a/packages/bluez/bluez-utils_3.9.bb
+++ b/packages/bluez/bluez-utils_3.9.bb
@@ -1,3 +1,12 @@
require bluez-utils.inc
-PR = "r4"
+PACKAGES =+ "${PN}-ciptool"
+
+SRC_URI += "file://uclibc-fix.patch;patch=1"
+
+FILES_${PN}-ciptool = "/bin/ciptool"
+RREPLACES_${PN}-ciptool = "bluez-utils-dbus-ciptool"
+RCONFLICTS_${PN}-ciptool = "bluez-utils-dbus-ciptool bluez-utils-nodbus"
+
+
+PR = "r5"