summaryrefslogtreecommitdiff
path: root/packages/bluez-utils
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bluez-utils')
-rw-r--r--packages/bluez-utils/bluez-utils-common_2.14.inc4
-rw-r--r--packages/bluez-utils/bluez-utils-dbus_2.14.bb1
-rw-r--r--packages/bluez-utils/bluez-utils-nodbus_2.14.bb1
-rw-r--r--packages/bluez-utils/files/openslug/bluetooth.default37
4 files changed, 40 insertions, 3 deletions
diff --git a/packages/bluez-utils/bluez-utils-common_2.14.inc b/packages/bluez-utils/bluez-utils-common_2.14.inc
index 3d8adf0e6a..bc92e28755 100644
--- a/packages/bluez-utils/bluez-utils-common_2.14.inc
+++ b/packages/bluez-utils/bluez-utils-common_2.14.inc
@@ -5,7 +5,7 @@ DEPENDS = "bluez-libs-2.14 pcmcia-cs"
RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils"
LICENSE = "GPL"
PACKAGES =+ "${PN}-ciptool ${PN}-bluepin"
-PR = "r2"
+PR = "r4"
FILES_${PN}-ciptool = "/bin/ciptool"
FILES_${PN}-bluepin = "/bin/bluepin"
@@ -34,3 +34,5 @@ inherit autotools update-rc.d
INITSCRIPT_NAME = "bluetooth"
INITSCRIPT_PARAMS = "defaults 23 19"
+CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
+ ${sysconfdir}/bluetooth/pin ${sysconfdir}/default/bluetooth"
diff --git a/packages/bluez-utils/bluez-utils-dbus_2.14.bb b/packages/bluez-utils/bluez-utils-dbus_2.14.bb
index 6cee31a3d3..f405cd5133 100644
--- a/packages/bluez-utils/bluez-utils-dbus_2.14.bb
+++ b/packages/bluez-utils/bluez-utils-dbus_2.14.bb
@@ -1,6 +1,5 @@
include bluez-utils-common_${PV}.inc
DEPENDS += "dbus"
SRC_URI += "file://dbus.patch;patch=1 file://smash.patch;patch=1"
-PR = "r1"
EXTRA_OECONF += "--with-dbus"
diff --git a/packages/bluez-utils/bluez-utils-nodbus_2.14.bb b/packages/bluez-utils/bluez-utils-nodbus_2.14.bb
index 9fa32d11ca..6334a4a499 100644
--- a/packages/bluez-utils/bluez-utils-nodbus_2.14.bb
+++ b/packages/bluez-utils/bluez-utils-nodbus_2.14.bb
@@ -1,5 +1,4 @@
include bluez-utils-common_${PV}.inc
-PR = "r1"
EXTRA_OECONF += "--without-dbus"
diff --git a/packages/bluez-utils/files/openslug/bluetooth.default b/packages/bluez-utils/files/openslug/bluetooth.default
index e69de29bb2..10f628e314 100644
--- a/packages/bluez-utils/files/openslug/bluetooth.default
+++ b/packages/bluez-utils/files/openslug/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=true
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=false
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=true
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=true
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"