summaryrefslogtreecommitdiff
path: root/packages/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bitbake')
-rw-r--r--packages/bitbake/bitbake.inc1
-rw-r--r--packages/bitbake/bitbake_1.0.bb11
-rw-r--r--packages/bitbake/bitbake_1.1.bb11
-rw-r--r--packages/bitbake/bitbake_1.6.0.bb (renamed from packages/bitbake/bitbake_1.4.2.bb)13
-rw-r--r--packages/bitbake/bitbake_svn.bb4
5 files changed, 8 insertions, 32 deletions
diff --git a/packages/bitbake/bitbake.inc b/packages/bitbake/bitbake.inc
index e454db2f40..1c5c7ad2a6 100644
--- a/packages/bitbake/bitbake.inc
+++ b/packages/bitbake/bitbake.inc
@@ -9,4 +9,3 @@ HOMEPAGE = "http://developer.berlios.de/projects/bitbake/"
LICENSE = "GPL MIT"
SECTION = "devel"
SUMMARY = "BitBake build tool"
-PACKAGE_ARCH = "all"
diff --git a/packages/bitbake/bitbake_1.0.bb b/packages/bitbake/bitbake_1.0.bb
deleted file mode 100644
index 9f8f054355..0000000000
--- a/packages/bitbake/bitbake_1.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-include bitbake.inc
-
-# We don't need a toolchain...
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "svn://svn.berlios.de/bitbake/tags;module=bitbake-${PV}"
-S = "${WORKDIR}/bitbake-${PV}"
-
-inherit distutils
-
-include bitbake-package.inc
diff --git a/packages/bitbake/bitbake_1.1.bb b/packages/bitbake/bitbake_1.1.bb
deleted file mode 100644
index 9f8f054355..0000000000
--- a/packages/bitbake/bitbake_1.1.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-include bitbake.inc
-
-# We don't need a toolchain...
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "svn://svn.berlios.de/bitbake/tags;module=bitbake-${PV}"
-S = "${WORKDIR}/bitbake-${PV}"
-
-inherit distutils
-
-include bitbake-package.inc
diff --git a/packages/bitbake/bitbake_1.4.2.bb b/packages/bitbake/bitbake_1.6.0.bb
index 0727eafd41..4289c49a04 100644
--- a/packages/bitbake/bitbake_1.4.2.bb
+++ b/packages/bitbake/bitbake_1.6.0.bb
@@ -1,17 +1,16 @@
-include bitbake.inc
+require bitbake.inc
+
+PR = "r1"
# We don't need a toolchain...
INHIBIT_DEFAULT_DEPS = "1"
-SRC_URI = "svn://svn.berlios.de/bitbake/tags;module=bitbake-${PV}"
+SRC_URI = "http://download.berlios.de/bitbake/bitbake-${PV}.tar.gz"
+
S = "${WORKDIR}/bitbake-${PV}"
inherit distutils
-include bitbake-package.inc
+require bitbake-package.inc
RDEPENDS += "python-shell python-lang python-textutils python-pickle"
-
-PR = "r1"
-
-
diff --git a/packages/bitbake/bitbake_svn.bb b/packages/bitbake/bitbake_svn.bb
index a4ff2ae540..1df6dacbed 100644
--- a/packages/bitbake/bitbake_svn.bb
+++ b/packages/bitbake/bitbake_svn.bb
@@ -1,4 +1,4 @@
-include bitbake.inc
+require bitbake.inc
# Don't use the tip of svn by default
DEFAULT_PREFERENCE = "-1"
@@ -13,4 +13,4 @@ S = "${WORKDIR}/bitbake"
inherit distutils
-include bitbake-package.inc
+require bitbake-package.inc