summaryrefslogtreecommitdiff
path: root/packages/avahi
diff options
context:
space:
mode:
Diffstat (limited to 'packages/avahi')
-rw-r--r--packages/avahi/avahi_0.6.10.bb10
-rw-r--r--packages/avahi/avahi_0.6.11.bb12
-rw-r--r--packages/avahi/avahi_0.6.12.bb11
-rw-r--r--packages/avahi/avahi_0.6.13.bb71
4 files changed, 99 insertions, 5 deletions
diff --git a/packages/avahi/avahi_0.6.10.bb b/packages/avahi/avahi_0.6.10.bb
index 2b12d91c8d..803266b6b3 100644
--- a/packages/avahi/avahi_0.6.10.bb
+++ b/packages/avahi/avahi_0.6.10.bb
@@ -5,6 +5,7 @@ AUTHOR = "Lennart Poettering <lennart@poettering.net>"
HOMEPAGE = "http://avahi.org"
MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
LICENSE= "GPL"
+PR = "r1"
DEPENDS = "expat libdaemon dbus"
RRECOMMENDS = "libnss-mdns"
@@ -42,6 +43,8 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
pkg_postinst_avahi-daemon () {
if [ "x$D" != "x" ]; then
exit 1
@@ -49,7 +52,12 @@ pkg_postinst_avahi-daemon () {
grep avahi /etc/group || addgroup avahi
grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
}
pkg_postrm_avahi-daemon () {
diff --git a/packages/avahi/avahi_0.6.11.bb b/packages/avahi/avahi_0.6.11.bb
index 2b12d91c8d..cc32ad883f 100644
--- a/packages/avahi/avahi_0.6.11.bb
+++ b/packages/avahi/avahi_0.6.11.bb
@@ -5,6 +5,7 @@ AUTHOR = "Lennart Poettering <lennart@poettering.net>"
HOMEPAGE = "http://avahi.org"
MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
LICENSE= "GPL"
+PR="r1"
DEPENDS = "expat libdaemon dbus"
RRECOMMENDS = "libnss-mdns"
@@ -42,6 +43,8 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
pkg_postinst_avahi-daemon () {
if [ "x$D" != "x" ]; then
exit 1
@@ -49,10 +52,15 @@ pkg_postinst_avahi-daemon () {
grep avahi /etc/group || addgroup avahi
grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
}
-pkg_postrm_avahi-daemon () {
+_postrm_avahi-daemon () {
deluser avahi || true
delgroup avahi || true
}
diff --git a/packages/avahi/avahi_0.6.12.bb b/packages/avahi/avahi_0.6.12.bb
index 2072c1f6bf..44e7c543ae 100644
--- a/packages/avahi/avahi_0.6.12.bb
+++ b/packages/avahi/avahi_0.6.12.bb
@@ -5,7 +5,7 @@ AUTHOR = "Lennart Poettering <lennart@poettering.net>"
HOMEPAGE = "http://avahi.org"
MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
LICENSE= "GPL"
-PR = "r1"
+PR = "r2"
DEPENDS = "expat libdaemon dbus"
RRECOMMENDS = "libnss-mdns"
@@ -48,10 +48,17 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
pkg_postinst_avahi-daemon () {
grep avahi /etc/group || addgroup avahi
grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
}
pkg_postrm_avahi-daemon () {
diff --git a/packages/avahi/avahi_0.6.13.bb b/packages/avahi/avahi_0.6.13.bb
new file mode 100644
index 0000000000..0898bf036c
--- /dev/null
+++ b/packages/avahi/avahi_0.6.13.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+SECTION = "network"
+PRIORITY = "optional"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
+HOMEPAGE = "http://avahi.org"
+MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
+LICENSE= "GPL"
+PR = "r1"
+
+DEPENDS = "expat libdaemon dbus"
+RRECOMMENDS = "libnss-mdns"
+
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
+
+PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/hosts \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd \
+ ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+inherit autotools pkgconfig update-rc.d
+
+
+do_stage() {
+ autotools_stage_all
+}
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
+pkg_postinst_avahi-daemon () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep avahi /etc/group || addgroup avahi
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+ delgroup avahi || true
+}