summaryrefslogtreecommitdiff
path: root/packages/asterisk/asterisk_1.2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/asterisk/asterisk_1.2.8.bb')
-rw-r--r--packages/asterisk/asterisk_1.2.8.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/asterisk/asterisk_1.2.8.bb b/packages/asterisk/asterisk_1.2.8.bb
new file mode 100644
index 0000000000..a9917c6e62
--- /dev/null
+++ b/packages/asterisk/asterisk_1.2.8.bb
@@ -0,0 +1,32 @@
+DESCRIPTION="The Astersisk open source software PBX"
+HOMEPAGE="www.asterisk.org"
+LICENSE="GPL"
+DEPENDS="ncurses zlib openssl curl"
+PR = "r0"
+
+SRC_URI="http://ftp.digium.com/pub/asterisk/releases/asterisk-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+
+# Doh - they use 'L'inux intead of linux
+# FIXME: Do the sed here
+
+export OSARCH="Linux"
+export PROC="${TARGET_ARCH}"
+
+# We will probably have to edit the CFLAG in the Makefile
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/asterisk
+ install -m 0644 ${S}/include/asterisk/*.h ${STAGING_INCDIR}/asterisk/
+}
+
+