summaryrefslogtreecommitdiff
path: root/packages/asterisk/asterisk-1.0.9/gsm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/asterisk/asterisk-1.0.9/gsm.patch')
-rw-r--r--packages/asterisk/asterisk-1.0.9/gsm.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/packages/asterisk/asterisk-1.0.9/gsm.patch b/packages/asterisk/asterisk-1.0.9/gsm.patch
new file mode 100644
index 0000000000..c59aa80bba
--- /dev/null
+++ b/packages/asterisk/asterisk-1.0.9/gsm.patch
@@ -0,0 +1,71 @@
+--- asterisk-1.0.9.org/codecs/gsm/Makefile 2005-06-21 16:27:28.000000000 +0200
++++ asterisk-1.0.9/codecs/gsm/Makefile 2005-08-14 21:47:10.000000000 +0200
+@@ -37,26 +37,6 @@
+ ######### ppro's, etc, as well as the AMD K6 and K7. The compile will
+ ######### probably require gcc.
+
+-ifneq (${OSARCH},Darwin)
+-ifneq (${PROC},x86_64)
+-ifneq (${PROC},ultrasparc)
+-ifneq ($(shell uname -m),ppc)
+-ifneq ($(shell uname -m),alpha)
+-ifneq ($(shell uname -m),armv4l)
+-ifneq (${PROC},sparc64)
+-ifneq (${PROC},ppc)
+-ifneq (${PROC},ppc64)
+-OPTIMIZE+=-march=$(PROC)
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+-
+ #The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
+ #This works for even old (2.96) versions of gcc and provides a small boost either way.
+ #A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesn't support it.
+@@ -218,19 +198,6 @@
+ $(SRC)/gsm_option.c \
+ $(SRC)/short_term.c \
+ $(SRC)/table.c
+-ifeq (${OSARCH},Linux)
+-ifneq ($(shell uname -m),x86_64)
+-ifneq ($(shell uname -m),ppc)
+-ifneq ($(shell uname -m),alpha)
+-ifneq ($(shell uname -m),armv4l)
+-ifneq ($(shell uname -m),sparc64)
+-GSM_SOURCES+= $(SRC)/k6opt.s
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+
+ TOAST_SOURCES = $(SRC)/toast.c \
+ $(SRC)/toast_lin.c \
+@@ -276,20 +243,6 @@
+ $(SRC)/short_term.o \
+ $(SRC)/table.o
+
+-ifeq (${OSARCH},Linux)
+-ifneq ($(shell uname -m), x86_64)
+-ifneq ($(shell uname -m), ppc)
+-ifneq ($(shell uname -m), alpha)
+-ifneq ($(shell uname -m), armv4l)
+-ifneq ($(shell uname -m), sparc64)
+-GSM_OBJECTS+= $(SRC)/k6opt.o
+-endif
+-endif
+-endif
+-endif
+-endif
+-endif
+-
+ TOAST_OBJECTS = $(SRC)/toast.o \
+ $(SRC)/toast_lin.o \
+ $(SRC)/toast_ulaw.o \
+