summaryrefslogtreecommitdiff
path: root/packages/aspell
diff options
context:
space:
mode:
Diffstat (limited to 'packages/aspell')
-rw-r--r--packages/aspell/aspell-0.50.5/.mtn2git_empty0
-rw-r--r--packages/aspell/aspell-0.50.5/makefile.patch20
-rwxr-xr-xpackages/aspell/aspell-0.50.5/mk-dirs_h.py20
-rw-r--r--packages/aspell/aspell-lang.inc15
-rw-r--r--packages/aspell/aspell-native_0.50.5.bb16
-rw-r--r--packages/aspell/aspell-native_0.60.5.bb6
-rw-r--r--packages/aspell/aspell6-en_6.0-0.bb (renamed from packages/aspell/aspell5-en_6.0-0.bb)2
-rw-r--r--packages/aspell/aspell_0.50.5.bb30
-rw-r--r--packages/aspell/aspell_0.60.5.bb18
9 files changed, 31 insertions, 96 deletions
diff --git a/packages/aspell/aspell-0.50.5/.mtn2git_empty b/packages/aspell/aspell-0.50.5/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/aspell/aspell-0.50.5/.mtn2git_empty
+++ /dev/null
diff --git a/packages/aspell/aspell-0.50.5/makefile.patch b/packages/aspell/aspell-0.50.5/makefile.patch
deleted file mode 100644
index c16a32e3b9..0000000000
--- a/packages/aspell/aspell-0.50.5/makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- aspell-0.50.5/common/Makefile.am~ 2002-11-05 00:24:14.000000000 +0000
-+++ aspell-0.50.5/common/Makefile.am 2004-06-27 14:33:37.000000000 +0100
-@@ -4,7 +4,7 @@
- pkgdatadir = @pkgdatadir@
- pkglibdir = @pkglibdir@
-
--noinst_PROGRAMS = mk-dirs_h
-+#noinst_PROGRAMS = mk-dirs_h
-
- dirs.h: mk-dirs_h
- echo '#define PREFIX "${prefix}"' > dirs.h
-@@ -12,7 +12,7 @@
- ./mk-dirs_h ${prefix} DATA_DIR ${pkgdatadir} >> dirs.h
- ./mk-dirs_h ${prefix} CONF_DIR ${sysconfdir} >> dirs.h
-
--mk_dirs_h_SOURCES = mk-dirs_h.cpp
-+#mk_dirs_h_SOURCES = mk-dirs_h.cpp
-
- config.cpp: dirs.h
-
diff --git a/packages/aspell/aspell-0.50.5/mk-dirs_h.py b/packages/aspell/aspell-0.50.5/mk-dirs_h.py
deleted file mode 100755
index a487751e81..0000000000
--- a/packages/aspell/aspell-0.50.5/mk-dirs_h.py
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/usr/bin/env python
-
-import sys
-
-prefix=sys.argv[1]
-key=sys.argv[2]
-value=sys.argv[3]
-
-while prefix[-1] == '/':
- prefix = prefix[:-2]
-
-plen = len(prefix)
-
-if value[:plen] == prefix:
- value = value[plen:]
- while value[0] == '/':
- value = value[1:]
- print "#define " + key + " \"<prefix:" + value + ">\"\n"
-else:
- print "#define " + key + " \"" + value + "\"\n"
diff --git a/packages/aspell/aspell-lang.inc b/packages/aspell/aspell-lang.inc
index 709183b428..8c58136f0e 100644
--- a/packages/aspell/aspell-lang.inc
+++ b/packages/aspell/aspell-lang.inc
@@ -1,23 +1,20 @@
-FILES_${PN} = "/usr/lib/aspell/* /usr/share/aspell/*"
+FILES_${PN} = "/usr/lib/aspell* /usr/share/aspell*"
DEPENDS = "aspell-native"
do_configure() {
cd ${S}
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- DESTDIR=${D} ./configure
+ DESTDIR=${D} ./configure --vars ASPELL=${STAGING_BINDIR_NATIVE}/aspell
}
do_compile() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- dictdir=/usr/lib/aspell oe_runmake
+ sed -i -e "s|dictdir.*lib|dictdir = ${libdir}|" Makefile
+ sed -i -e "s|datadir.*lib|datadir = ${libdir}|" Makefile
+ oe_runmake
}
do_install() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
+ unset datadir
oe_runmake install
}
diff --git a/packages/aspell/aspell-native_0.50.5.bb b/packages/aspell/aspell-native_0.50.5.bb
deleted file mode 100644
index e87c6c6fd5..0000000000
--- a/packages/aspell/aspell-native_0.50.5.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz \
- file://mk-dirs_h.py \
- file://makefile.patch;patch=1"
-DESCRIPTION = "GNU Aspell spell-checker"
-SECTION = "console/utils"
-LICENSE="LGPL"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/aspell-${PV}"
-
-inherit autotools native
-
-S = "${WORKDIR}/aspell-${PV}"
-
-do_compile_prepend() {
- install ${WORKDIR}/mk-dirs_h.py ${S}/common/mk-dirs_h
-}
-
diff --git a/packages/aspell/aspell-native_0.60.5.bb b/packages/aspell/aspell-native_0.60.5.bb
new file mode 100644
index 0000000000..174821ce46
--- /dev/null
+++ b/packages/aspell/aspell-native_0.60.5.bb
@@ -0,0 +1,6 @@
+require aspell_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/aspell-${PV}"
+
diff --git a/packages/aspell/aspell5-en_6.0-0.bb b/packages/aspell/aspell6-en_6.0-0.bb
index 568e692ab9..6c013eb546 100644
--- a/packages/aspell/aspell5-en_6.0-0.bb
+++ b/packages/aspell/aspell6-en_6.0-0.bb
@@ -1,5 +1,5 @@
LICENSE = "Copyright file"
-SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell5-en-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-${PV}.tar.bz2"
PR="r1"
require aspell-lang.inc
diff --git a/packages/aspell/aspell_0.50.5.bb b/packages/aspell/aspell_0.50.5.bb
deleted file mode 100644
index f685133121..0000000000
--- a/packages/aspell/aspell_0.50.5.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz \
- file://mk-dirs_h.py \
- file://makefile.patch;patch=1"
-DESCRIPTION = "GNU Aspell spell-checker"
-SECTION = "console/utils"
-LICENSE="LGPL"
-
-PACKAGES =+ "libaspell libpspell libpspell-dev aspell-utils"
-
-FILES_libaspell = "${libdir}/libaspell.so.* ${datadir}/aspell"
-FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell"
-FILES_${PN} = "${bindir}/aspell"
-FILES_libpspell = "${libdir}/libpspell.so.*"
-FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
-
-inherit autotools
-
-export CXXFLAGS += "-lstdc++"
-
-do_compile_prepend() {
- install ${WORKDIR}/mk-dirs_h.py ${S}/common/mk-dirs_h
-}
-
-do_stage() {
- oe_libinstall -C lib -so libaspell ${STAGING_LIBDIR}
- install -m 0644 interfaces/cc/aspell.h ${STAGING_INCDIR}
- oe_libinstall -C lib -so libpspell ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/pspell
- install -m 0644 interfaces/cc/pspell.h ${STAGING_INCDIR}/pspell
-}
diff --git a/packages/aspell/aspell_0.60.5.bb b/packages/aspell/aspell_0.60.5.bb
new file mode 100644
index 0000000000..6b6c867226
--- /dev/null
+++ b/packages/aspell/aspell_0.60.5.bb
@@ -0,0 +1,18 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES =+ "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}