summaryrefslogtreecommitdiff
path: root/packages/apr/apr/configure_fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/apr/apr/configure_fixes.patch')
-rw-r--r--packages/apr/apr/configure_fixes.patch112
1 files changed, 62 insertions, 50 deletions
diff --git a/packages/apr/apr/configure_fixes.patch b/packages/apr/apr/configure_fixes.patch
index 88e1e2163a..86ceb8cf08 100644
--- a/packages/apr/apr/configure_fixes.patch
+++ b/packages/apr/apr/configure_fixes.patch
@@ -1,54 +1,66 @@
---- /tmp/configure.in 2009-02-02 17:50:51.000000000 +0100
-+++ apr-1.2.12/configure.in 2009-02-02 17:54:55.000000000 +0100
-@@ -13,12 +13,11 @@
- dnl
- dnl Include our own M4 macros along with those for libtool
- dnl
--sinclude(build/apr_common.m4)
--sinclude(build/apr_network.m4)
--sinclude(build/apr_threads.m4)
--sinclude(build/apr_hints.m4)
--sinclude(build/libtool.m4)
--sinclude(build/ltsugar.m4)
-+#sinclude(build/apr_common.m4)
-+#sinclude(build/apr_network.m4)
-+#sinclude(build/apr_threads.m4)
-+#sinclude(build/apr_hints.m4)
-+#sinclude(build/libtool.m4)
+Index: apr-1.3.3/configure.in
+===================================================================
+--- apr-1.3.3.orig/configure.in
++++ apr-1.3.3/configure.in
+@@ -794,39 +794,6 @@ AC_CHECK_FUNCS([mmap munmap shm_open shm
+ create_area])
- dnl Hard-coded inclusion at the tail end of apr_private.h:
- AH_BOTTOM([
-@@ -197,8 +196,8 @@
+ APR_CHECK_DEFINE(MAP_ANON, sys/mman.h)
+-AC_CHECK_FILE(/dev/zero)
+-
+-# Not all systems can mmap /dev/zero (such as HP-UX). Check for that.
+-if test "$ac_cv_func_mmap" = "yes" &&
+- test "$ac_cv_file__dev_zero" = "yes"; then
+- AC_MSG_CHECKING(for mmap that can map /dev/zero)
+- AC_TRY_RUN([
+-#include <sys/types.h>
+-#include <sys/stat.h>
+-#include <fcntl.h>
+-#ifdef HAVE_SYS_MMAN_H
+-#include <sys/mman.h>
+-#endif
+- int main()
+- {
+- int fd;
+- void *m;
+- fd = open("/dev/zero", O_RDWR);
+- if (fd < 0) {
+- return 1;
+- }
+- m = mmap(0, sizeof(void*), PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0);
+- if (m == (void *)-1) { /* aka MAP_FAILED */
+- return 2;
+- }
+- if (munmap(m, sizeof(void*)) < 0) {
+- return 3;
+- }
+- return 0;
+- }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no])
+-
+- AC_MSG_RESULT($ac_cv_file__dev_zero)
+-fi
- if test "x$use_libtool" = "xyes"; then
- lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
-- LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
-- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
-+ LV_VERSION="-version-info `$get_version libtool $version_hdr APR`"
-+ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LV_LDFLAGS) \$(COMPILE) ${LV_VERSION} \$(ALL_LDFLAGS) -o \$@"
- so_ext='lo'
- lib_target='-rpath $(libdir) $(OBJECTS)'
- export_lib_target='-rpath \$(libdir) \$(OBJECTS)'
-@@ -225,7 +224,7 @@
- AC_SUBST(export_lib_target)
- AC_SUBST(shlibpath_var)
- AC_SUBST(LTFLAGS)
--AC_SUBST(LT_LDFLAGS)
-+AC_SUBST(LV_LDFLAGS)
+ # Now we determine which one is our anonymous shmem preference.
+ haveshmgetanon="0"
+@@ -1518,13 +1485,14 @@ else
+ bigendian=0
+ fi
- dnl ----------------------------- Checks for compiler flags
- nl='
-@@ -2132,10 +2131,10 @@
- # against installed versions of libapr instead of those just
- # built.
- case $host in
--*-apple-darwin*) LT_NO_INSTALL="" ;;
--*) LT_NO_INSTALL="-no-install" ;;
-+*-apple-darwin*) LV_NO_INSTALL="" ;;
-+*) LV_NO_INSTALL="-no-install" ;;
- esac
--AC_SUBST(LT_NO_INSTALL)
-+AC_SUBST(LV_NO_INSTALL)
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
+-#include <sys/uio.h>],struct iovec,0)
+-if test "$ac_cv_sizeof_struct_iovec" = "0"; then
+- have_iovec=0
+-else
+- have_iovec=1
+-fi
++#APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
++##include <sys/uio.h>],struct iovec,0)
++#if test "$ac_cv_sizeof_struct_iovec" = "0"; then
++# have_iovec=0
++#else
++# have_iovec=1
++#fi
++have_iovec=1
- #
- # BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
+ AC_SUBST(voidp_size)
+ AC_SUBST(short_value)