summaryrefslogtreecommitdiff
path: root/packages/apr/apr-util_1.2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/apr/apr-util_1.2.12.bb')
-rw-r--r--packages/apr/apr-util_1.2.12.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/packages/apr/apr-util_1.2.12.bb b/packages/apr/apr-util_1.2.12.bb
index 64f6bcbcf8..6613ab99a8 100644
--- a/packages/apr/apr-util_1.2.12.bb
+++ b/packages/apr/apr-util_1.2.12.bb
@@ -3,7 +3,9 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r2"
+PR = "r3"
+
+inherit autotools lib_package binconfig
# apache mirrors?
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
@@ -16,12 +18,16 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
--with-expat=${STAGING_DIR_HOST}${layout_prefix}"
-inherit autotools lib_package binconfig
-
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
do_configure_prepend() {
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+ libtoolize --force
}
do_stage() {