summaryrefslogtreecommitdiff
path: root/packages/apr/apr-util_1.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/apr/apr-util_1.1.2.bb')
-rw-r--r--packages/apr/apr-util_1.1.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/apr/apr-util_1.1.2.bb b/packages/apr/apr-util_1.1.2.bb
new file mode 100644
index 0000000000..e9f9587420
--- /dev/null
+++ b/packages/apr/apr-util_1.1.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.gz"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
+}