summaryrefslogtreecommitdiff
path: root/packages/alsa
diff options
context:
space:
mode:
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-lib/fix_libmath.patch17
-rw-r--r--packages/alsa/alsa-lib_1.0.15.bb14
-rw-r--r--packages/alsa/alsa-oss_1.0.15.bb5
-rw-r--r--packages/alsa/alsa-versym.inc21
-rw-r--r--packages/alsa/files/libio.patch43
5 files changed, 97 insertions, 3 deletions
diff --git a/packages/alsa/alsa-lib/fix_libmath.patch b/packages/alsa/alsa-lib/fix_libmath.patch
new file mode 100644
index 0000000000..23309ce381
--- /dev/null
+++ b/packages/alsa/alsa-lib/fix_libmath.patch
@@ -0,0 +1,17 @@
+Index: alsa-lib-1.0.15/configure.in
+===================================================================
+--- alsa-lib-1.0.15.orig/configure.in 2007-10-15 10:45:26.000000000 +0200
++++ alsa-lib-1.0.15/configure.in 2008-07-19 15:51:34.177119589 +0200
+@@ -191,9 +191,9 @@
+ AC_MSG_RESULT(no)
+ fi
+
+-ALSA_DEPLIBS=""
+-if test "$softfloat" != "yes"; then
+- ALSA_DEPLIBS="-lm"
++ALSA_DEPLIBS="-lm"
++if test "$softfloat" = "yes"; then
++ AC_CHECK_LIB([m], [floor], , [ALSA_DEPLIBS=""])
+ fi
+
+ dnl Check for libdl
diff --git a/packages/alsa/alsa-lib_1.0.15.bb b/packages/alsa/alsa-lib_1.0.15.bb
index 60b44dbc8e..399352f299 100644
--- a/packages/alsa/alsa-lib_1.0.15.bb
+++ b/packages/alsa/alsa-lib_1.0.15.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Alsa sound library"
HOMEPAGE = "http://www.alsa-project.org"
SECTION = "libs/multimedia"
LICENSE = "GPL"
+PR = "1"
# configure.in sets -D__arm__ on the command line for any arm system
# (not just those with the ARM instruction set), this should be removed,
@@ -10,14 +11,23 @@ LICENSE = "GPL"
ARM_INSTRUCTION_SET = "arm"
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
- file://fix-tstamp-declaration.patch;patch=1"
+ file://fix-tstamp-declaration.patch;patch=1 \
+ file://fix_libmath.patch;patch=1 \
+ "
inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
+
+
require alsa-fpu.inc
EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
-EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
+
+require alsa-versym.inc
+EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
+
do_stage () {
oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
diff --git a/packages/alsa/alsa-oss_1.0.15.bb b/packages/alsa/alsa-oss_1.0.15.bb
index b11947e86a..3cfe886d61 100644
--- a/packages/alsa/alsa-oss_1.0.15.bb
+++ b/packages/alsa/alsa-oss_1.0.15.bb
@@ -2,8 +2,11 @@ DESCRIPTION = "Alsa OSS Compatibility Package"
SECTION = "libs/multimedia"
LICENSE = "GPL"
DEPENDS = "alsa-lib"
+PR = "1"
-SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \
+ file://libio.patch;patch=1 \
+ "
inherit autotools
diff --git a/packages/alsa/alsa-versym.inc b/packages/alsa/alsa-versym.inc
new file mode 100644
index 0000000000..6d585ecf4a
--- /dev/null
+++ b/packages/alsa/alsa-versym.inc
@@ -0,0 +1,21 @@
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+
diff --git a/packages/alsa/files/libio.patch b/packages/alsa/files/libio.patch
new file mode 100644
index 0000000000..83345a98d3
--- /dev/null
+++ b/packages/alsa/files/libio.patch
@@ -0,0 +1,43 @@
+Index: alsa-oss-1.0.15/alsa/stdioemu.c
+===================================================================
+--- alsa-oss-1.0.15.orig/alsa/stdioemu.c 2007-10-15 10:50:40.000000000 +0200
++++ alsa-oss-1.0.15/alsa/stdioemu.c 2008-07-20 22:29:46.767474560 +0200
+@@ -37,7 +37,9 @@
+ #endif
+
+ #include <stdio.h>
++#ifdef HAVE_LIBIO_H
+ #include <libio.h>
++#endif
+
+ struct fd_cookie {
+ int fd;
+@@ -99,7 +101,11 @@
+
+ if (open_mode && fdc->fd > 0) {
+ result = fopencookie (fdc,"w", fns);
++#ifdef HAVE_FILENO
+ result->_fileno = fdc->fd; /* ugly patchy slimy kludgy hack */
++else
++ result->_filedes = fdc->fd;
++#endif
+ }
+ return result;
+ }
+Index: alsa-oss-1.0.15/configure.in
+===================================================================
+--- alsa-oss-1.0.15.orig/configure.in 2007-10-15 10:50:40.000000000 +0200
++++ alsa-oss-1.0.15/configure.in 2008-07-20 22:49:45.455837502 +0200
+@@ -33,6 +33,12 @@
+ LIBS="$OLD_LIBS"
+ fi
+
++AC_CHECK_HEADERS_ONCE([libio.h])
++
++AC_CHECK_MEMBER([struct _IO_FILE._fileno],
++ [AC_DEFINE([HAVE_FILENO], [1],[Define if _fileno exists.])],
++ [],[])
++
+ AC_OUTPUT(Makefile alsa/Makefile alsa/aoss alsa/aoss.old \
+ oss-redir/Makefile test/Makefile \
+ alsa/testaoss test/testaoss)