summaryrefslogtreecommitdiff
path: root/packages/alsa/alsa-state.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/alsa/alsa-state.bb')
-rw-r--r--packages/alsa/alsa-state.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
new file mode 100644
index 0000000000..d49aa3231b
--- /dev/null
+++ b/packages/alsa/alsa-state.bb
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: alsa-state.bb
+# Date: 20070308 (YMD)
+
+DESCRIPTION = "Default ALSA configuration"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "<homepage>"
+LICENSE = "GPL"
+
+######################################################################################
+
+PV = "0.0.1"
+PR = "r0"
+
+######################################################################################
+
+SRC_URI = "file://asound.state"
+
+FILES_${PN} = "/etc/*"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}${sysconfdir}
+
+ install -m 0644 ${WORKDIR}/asound.state ${D}${sysconfdir}
+}
+
+
+pkg_postinst_${PN}() {
+ if test -x /usr/sbin/alsactl
+ then
+ /usr/sbin/alsactl -f ${sysconfdir}/asound.state restore
+ fi
+}