summaryrefslogtreecommitdiff
path: root/packages/abiword
diff options
context:
space:
mode:
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-embedded_2.4.6.bb12
-rw-r--r--packages/abiword/abiword-plugins_2.4.6.bb27
-rw-r--r--packages/abiword/abiword.inc43
-rw-r--r--packages/abiword/abiword_2.4.6.bb4
4 files changed, 68 insertions, 18 deletions
diff --git a/packages/abiword/abiword-embedded_2.4.6.bb b/packages/abiword/abiword-embedded_2.4.6.bb
new file mode 100644
index 0000000000..9381bbd8a7
--- /dev/null
+++ b/packages/abiword/abiword-embedded_2.4.6.bb
@@ -0,0 +1,12 @@
+require abiword.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+do_compile_prepend() {
+ cp ${S}/src/af/xap/unix/hildon/xap_EmbeddedFeatures.h ${S}/src/af/xap/unix/
+ cp ${S}/src/wp/ap/unix/hildon/ap_EmbeddedFeatures.h ${S}/src/wp/ap/unix/
+}
+
diff --git a/packages/abiword/abiword-plugins_2.4.6.bb b/packages/abiword/abiword-plugins_2.4.6.bb
new file mode 100644
index 0000000000..28d076aaa4
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.4.6.bb
@@ -0,0 +1,27 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+SECTION = "gnome/office"
+HOMEPAGE="http://www.abiword.org""
+LICENSE="GPLv2"
+
+DEPENDS = "libwpd librsvg goffice poppler"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+RDEPENDS='abiword'
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+
diff --git a/packages/abiword/abiword.inc b/packages/abiword/abiword.inc
index ac9a39515a..c8f3243b9c 100644
--- a/packages/abiword/abiword.inc
+++ b/packages/abiword/abiword.inc
@@ -6,31 +6,32 @@ LICENSE = "GPLv2"
DEPENDS = "perl-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng libxml2"
RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
-PR="r1"
+PR = "r2"
SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
S = "${WORKDIR}/abiword-${PV}/abi"
-FILES_${PN} += " ${datadir}/icons/* \
-${datadir}/AbiSuite-2.4/AbiWord/glade \
-${datadir}/AbiSuite-2.4/AbiWord/scripts \
-${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
-${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
-#${datadir}/AbiSuite-2.4/templates/A4.awt \
-#${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
-${datadir}/AbiSuite-2.4/templates/normal.awt \
-${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
-${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
-${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
-${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
-${datadir}/AbiSuite-2.4/templates/Resume.awt \
-${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
-${datadir}/AbiSuite-2.4/templates/Memo.awt \
-${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/AbiSuite-2.4/AbiWord/glade \
+ ${datadir}/AbiSuite-2.4/AbiWord/scripts \
+ ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+ ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+# ${datadir}/AbiSuite-2.4/templates/A4.awt \
+# ${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+ ${datadir}/AbiSuite-2.4/templates/normal.awt \
+ ${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+ ${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+ ${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+ ${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+ ${datadir}/AbiSuite-2.4/templates/Resume.awt \
+ ${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+ ${datadir}/AbiSuite-2.4/templates/Memo.awt \
+ ${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
inherit autotools
-PARALLEL_MAKE=""
+PARALLEL_MAKE = ""
EXTRA_OECONF = "--disable-pspell --enable-enchant"
@@ -39,4 +40,10 @@ do_install_append() {
mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
}
+PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
+FILES_abiword-clipart += "${datadir}/AbiSuite-2.4/clipart"
+FILES_abiword-icons += "${datadir}/AbiSuite-2.4/icons"
+FILES_abiword-strings += "${datadir}/AbiSuite-2.4/AbiWord/strings"
+FILES_abiword-systemprofiles += "${datadir}/AbiSuite-2.4/AbiWord/system.profile*"
+FILES_abiword-templates += "${datadir}/AbiSuite-2.4/templates"
diff --git a/packages/abiword/abiword_2.4.6.bb b/packages/abiword/abiword_2.4.6.bb
new file mode 100644
index 0000000000..b97556b735
--- /dev/null
+++ b/packages/abiword/abiword_2.4.6.bb
@@ -0,0 +1,4 @@
+require abiword.inc
+
+RCONFLICTS = "abiword-embedded"
+