summaryrefslogtreecommitdiff
path: root/packages/abiword/abiword_2.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/abiword/abiword_2.2.7.bb')
-rw-r--r--packages/abiword/abiword_2.2.7.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/packages/abiword/abiword_2.2.7.bb b/packages/abiword/abiword_2.2.7.bb
index e69de29bb2..ff182033ab 100644
--- a/packages/abiword/abiword_2.2.7.bb
+++ b/packages/abiword/abiword_2.2.7.bb
@@ -0,0 +1,50 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@handhelds.org>"
+LICENSE="GPLv2"
+
+DEPENDS = "cdump-native libglade libfribidi enchant jpeg libpng perl glibc"
+RDEPENDS = "libglade enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " ${datadir}/icons/* \
+${datadir}/AbiSuite-2.0/AbiWord/glade \
+${datadir}/AbiSuite-2.0/AbiWord/scripts \
+${datadir}/AbiSuite-2.0/AbiWord/system.profile-en \
+${datadir}/AbiSuite-2.0/AbiWord/system.profile-en_GB \
+#${datadir}/AbiSuite-2.0/templates/A4.awt \
+#${datadir}/AbiSuite-2.0/templates/US-Letter.awt \
+${datadir}/AbiSuite-2.0/templates/normal.awt \
+${datadir}/AbiSuite-2.0/templates/normal.awt-en_GB \
+${datadir}/AbiSuite-2.0/templates/Employee-Directory.awt \
+${datadir}/AbiSuite-2.0/templates/Business-Report.awt \
+${datadir}/AbiSuite-2.0/templates/Fax-Coversheet.awt \
+${datadir}/AbiSuite-2.0/templates/Resume.awt \
+${datadir}/AbiSuite-2.0/templates/Two-Columns.awt \
+${datadir}/AbiSuite-2.0/templates/Memo.awt \
+${datadir}/AbiSuite-2.0/templates/Press-Release.awt"
+
+inherit autotools
+
+#abiword needs this native tool
+export BUILD_CDUMPTOOL=${STAGING_BINDIR}/cdump
+
+PARALLEL_MAKE=""
+
+do_configure () {
+ cd ${S}
+ ./autogen.sh
+ ./configure --prefix=/usr --host=${TARGET_SYS} --disable-pspell --enable-enchant
+# --enable-debug
+ cp -f ${STAGING_BINDIR}/cdump src/tools/cdump/xp/
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+