summaryrefslogtreecommitdiff
path: root/packages/abiword/abiword-plugins_2.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/abiword/abiword-plugins_2.4.4.bb')
-rw-r--r--packages/abiword/abiword-plugins_2.4.4.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/packages/abiword/abiword-plugins_2.4.4.bb b/packages/abiword/abiword-plugins_2.4.4.bb
index 89f50d0495..645db1c96b 100644
--- a/packages/abiword/abiword-plugins_2.4.4.bb
+++ b/packages/abiword/abiword-plugins_2.4.4.bb
@@ -4,21 +4,23 @@ MAINTAINER="Koen Kooi <koen@dominion.kabel.utwente.nl>"
LICENSE="GPLv2"
DEPENDS = "abiword libwpd librsvg goffice poppler"
-PR="r0"
+PR="r1"
-SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
-FILES_${PN} += " ${datadir}/icons/* \
-${datadir}/AbiSuite-2.4/ \
-${libdir}/AbiWord-2.4/plugins/*.so \
-"
-
inherit autotools
PARALLEL_MAKE=""
EXTRA_OECONF = ""
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s')
+}