summaryrefslogtreecommitdiff
path: root/meta/openslug-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/openslug-image.bb')
-rw-r--r--meta/openslug-image.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/openslug-image.bb b/meta/openslug-image.bb
index e69de29bb2..94f91963da 100644
--- a/meta/openslug-image.bb
+++ b/meta/openslug-image.bb
@@ -0,0 +1,33 @@
+PR = "r1"
+
+IMAGE_BASENAME = "openslug"
+
+IMAGE_LINGUAS = ""
+USE_DEVFS = "1"
+
+OPENSLUG_HIDDEN_PACKAGES = "ipkg-native ipkg-utils-native fakeroot-native patcher-native virtual/armeb-linux-uclibc-gcc \
+ virtual/libc makedevs-native mtd-native slugimage-native nslu2-linksys-firmware nslu2-switchbox-firmware "
+
+DEPENDS = "base-files base-passwd-3.5.7 \
+ busybox dropbear hotplug initscripts netbase \
+ sysvinit tinylogin lrzsz portmap \
+ ixp4xx-csr ixp425-eth \
+ ipkg-collateral ipkg ipkg-link \
+ ${OPENSLUG_EXTRA_DEPENDS}"
+
+IPKG_INSTALL = "base-files base-passwd \
+ busybox dropbear hotplug initscripts netbase \
+ update-modules sysvinit tinylogin lrzsz portmap \
+ ixp4xx-csr ixp425-eth \
+ ipkg-collateral ipkg ipkg-link \
+ ${OPENSLUG_EXTRA_INSTALL}"
+
+inherit image_ipk
+
+python () {
+ # Don't build openslug images unless we're targeting an nslu2
+ mach = oe.data.getVar("MACHINE", d, 1)
+ dist = oe.data.getVar("DISTRO", d, 1)
+ if mach != 'nslu2' or dist != 'openslug':
+ raise oe.parse.SkipPackage("OpenSlug only builds for the Linksys NSLU2")
+}