summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/bitbake.conf9
-rw-r--r--conf/distro/angstrom-2007.1-oabi.conf17
-rw-r--r--conf/distro/angstrom-2007.1.conf9
-rw-r--r--conf/distro/debianslug.conf7
-rw-r--r--conf/distro/openomap.conf3
-rw-r--r--conf/distro/openslug.conf7
-rw-r--r--conf/machine/a780.conf3
-rw-r--r--conf/machine/collie.conf22
-rw-r--r--conf/machine/h1940.conf20
-rw-r--r--conf/machine/htcblueangel.conf (renamed from conf/machine/blueangel.conf)49
-rw-r--r--conf/machine/include/collie-2.4.conf17
-rw-r--r--conf/machine/include/collie-2.6.conf4
-rw-r--r--conf/machine/include/qemu.conf3
-rw-r--r--conf/machine/include/tosa-2.6.conf6
-rw-r--r--conf/machine/include/tune-thumb.conf4
-rw-r--r--conf/machine/ixp4xxle.conf4
-rw-r--r--conf/machine/omap5912osk.conf2
-rw-r--r--conf/machine/palmld.conf2
-rw-r--r--conf/machine/palmtx.conf23
-rw-r--r--conf/machine/qemuarm.conf2
-rw-r--r--conf/machine/qemux86.conf17
21 files changed, 163 insertions, 67 deletions
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index dcdc18c322..6ddf8ecaf4 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -153,10 +153,9 @@ S = "${WORKDIR}/${P}"
B = "${S}"
STAGING_DIR = "${TMPDIR}/staging"
-STAGING_BINDIR = "${STAGING_DIR}/${BUILD_SYS}/bin"
-# Set these to the same a STAGING_BINDIR for now
+STAGING_BINDIR = "${STAGING_DIR}/${HOST_SYS}/bin"
+STAGING_BINDIR_CROSS = "${STAGING_DIR}/${BUILD_SYS}/bin/${HOST_SYS}"
STAGING_BINDIR_NATIVE = "${STAGING_DIR}/${BUILD_SYS}/bin"
-STAGING_BINDIR_CROSS = "${STAGING_DIR}/${BUILD_SYS}/bin"
STAGING_LIBDIR = "${STAGING_DIR}/${HOST_SYS}/lib"
STAGING_INCDIR = "${STAGING_DIR}/${HOST_SYS}/include"
STAGING_DATADIR = "${STAGING_DIR}/${HOST_SYS}/share"
@@ -217,7 +216,7 @@ EXTRA_IMAGEDEPENDS = ""
CROSS_DIR = "${TMPDIR}/cross"
CROSS_DATADIR = "${CROSS_DIR}/share"
-export PATH_prepend = "${STAGING_BINDIR}/${HOST_SYS}:${STAGING_BINDIR}:${CROSS_DIR}/bin:"
+export PATH_prepend = "${STAGING_BINDIR_CROSS}:${STAGING_BINDIR_NATIVE}:${CROSS_DIR}/bin:"
##################################################################
# Build utility info.
@@ -422,7 +421,7 @@ require conf/sanity.conf
IMAGE_FSTYPES ?= "jffs2"
PCMCIA_MANAGER ?= "pcmcia-cs"
-MACHINE_TASK_PROVIDER ?= "task-bootstrap"
+MACHINE_TASK_PROVIDER ?= "task-base"
IMAGE_ROOTFS_SIZE_ext2 ?= "65536"
IMAGE_ROOTFS_SIZE_ext2.gz ?= "65536"
diff --git a/conf/distro/angstrom-2007.1-oabi.conf b/conf/distro/angstrom-2007.1-oabi.conf
new file mode 100644
index 0000000000..d1541509c5
--- /dev/null
+++ b/conf/distro/angstrom-2007.1-oabi.conf
@@ -0,0 +1,17 @@
+require conf/distro/angstrom-2007.1.conf
+
+#this is a special version of angstrom for armv4 based machines that can't do EABI
+#see http://wiki.debian.org/ArmEabiPort for details on that
+
+#only glibc based builds are supported ATM
+TARGET_OS = "linux"
+
+FEED_ARCH_collie = "arm"
+FEED_ARCH_h3600 = "arm"
+FEED_ARCH_h3800 = "arm"
+FEED_ARCH_simpad = "arm"
+
+
+
+
+
diff --git a/conf/distro/angstrom-2007.1.conf b/conf/distro/angstrom-2007.1.conf
index 59ef9d3f4e..5b46a59640 100644
--- a/conf/distro/angstrom-2007.1.conf
+++ b/conf/distro/angstrom-2007.1.conf
@@ -8,7 +8,7 @@
#DISTRO_VERSION = "2007.3"
DISTRO_VERSION = "test-${DATE}"
-DISTRO_REVISION = "26"
+DISTRO_REVISION = "28"
require conf/distro/include/angstrom.inc
require conf/distro/include/sane-srcdates.inc
@@ -67,9 +67,10 @@ FEED_URIS += " \
# We will lock down a SRCDATE when we go into release mode
-#SRCDATE = "20061029"
+#SRCDATE = "20070303"
PREFERRED_VERSION_linux-handhelds-2.6 = "2.6.16-hh8"
+PREFERRED_VERSION_linux-handhelds-2.6_h3900 = "2.6.19-hh7"
PREFERRED_VERSION_linux-handhelds-2.6_htcuniversal = "2.6.18-hh1"
@@ -94,6 +95,10 @@ PREFERRED_VERSION_freetype = "2.2.1"
#fix screen corruption issues
PREFERRED_VERSION_cairo = "1.3.10"
+#work around a segfault in gcc for armv4t
+PREFERRED_VERSION_glib-2.0_ep93xx = "2.12.3"
+PREFERRED_VERSION_glib-2.0_h6300 = "2.12.3"
+
#Small machines prefer kdrive, but we might ship full Xorg in other images
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-kdrive"
PREFERRED_PROVIDER_xserver ?= "xserver-kdrive"
diff --git a/conf/distro/debianslug.conf b/conf/distro/debianslug.conf
index 0bcdac1db5..d33ae96c68 100644
--- a/conf/distro/debianslug.conf
+++ b/conf/distro/debianslug.conf
@@ -13,7 +13,7 @@ SLUGOS_IMAGENAME = "debianslug"
SLUGOS_IMAGESEX = "little-endian"
# debianslug builds a complete image (not just the parts)
-SLUGOS_FLASH_IMAGE = "nslu2"
+SLUGOS_FLASH_IMAGE = "1"
# NOTE: to build new packages set DEBIANSLUG_EXTRA_BBFILES to the full path name to
# the .bb files for the packages to build - see debianslug-packages.conf in this
@@ -103,6 +103,11 @@ kernel-module-libata \
kernel-module-pata-artop \
"
+# Add modules required for Network support
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-via-velocity \
+"
+
# This documents other file systems which are built but not installed
# by default in the flash image.
#
diff --git a/conf/distro/openomap.conf b/conf/distro/openomap.conf
index f73a980c52..5819b5ad59 100644
--- a/conf/distro/openomap.conf
+++ b/conf/distro/openomap.conf
@@ -23,8 +23,7 @@ PREFERRED_PROVIDER_virtual/arm-linux-gnueabi-libc-for-gcc = "glibc-intermediate"
PREFERRED_PROVIDER_virtual/arm-linux-libc-for-gcc = "glibc-intermediate"
# use latest booting kernel but allow to override it in local.conf
-PREFERRED_VERSION_linux-omap1_omap5912osk ?= "2.6.18-omap1"
-#PREFERRED_VERSION_linux-omap1_omap5912osk ?= "2.6.18+git"
+#PREFERRED_VERSION_linux-omap1_omap5912osk ?= "2.6.19-omap1"
#use EABI toolchain
diff --git a/conf/distro/openslug.conf b/conf/distro/openslug.conf
index dec16d8cd7..1091aa2e98 100644
--- a/conf/distro/openslug.conf
+++ b/conf/distro/openslug.conf
@@ -13,7 +13,7 @@ SLUGOS_IMAGENAME = "openslug"
SLUGOS_IMAGESEX = "big-endian"
# openslug builds a complete image (not just the parts)
-SLUGOS_FLASH_IMAGE = "nslu2"
+SLUGOS_FLASH_IMAGE = "1"
# NOTE: to build new packages set OPENSLUG_EXTRA_BBFILES to the full path name to
# the .bb files for the packages to build - see ucslugc-packages.conf in this
@@ -103,6 +103,11 @@ kernel-module-libata \
kernel-module-pata-artop \
"
+# Add modules required for Network support
+OPENSLUG_STANDARD_RDEPENDS += "\
+kernel-module-via-velocity \
+"
+
# This documents other file systems which are built but not installed
# by default in the flash image.
#
diff --git a/conf/machine/a780.conf b/conf/machine/a780.conf
index fe3cdbc481..1c3ae63025 100644
--- a/conf/machine/a780.conf
+++ b/conf/machine/a780.conf
@@ -20,6 +20,9 @@ EXTRA_IMAGECMD_jffs2 = "--pad=14680064 --little-endian --eraseblock=0x20000 -n"
MACHINE_FEATURES = "kernel26 touchscreen apm alsa bluetooth usbgadget usbhost keyboard screen"
+#the a780 needs a userspace daemon to stop the BP from shutting down the phone
+MACHINE_EXTRA_RDEPENDS += "opentapi"
+
ROOT_FLASH_SIZE = "24"
EXTRA_IMAGEDEPENDS += "ezx-boot-usb-native"
diff --git a/conf/machine/collie.conf b/conf/machine/collie.conf
index deefa1b698..e7e867e539 100644
--- a/conf/machine/collie.conf
+++ b/conf/machine/collie.conf
@@ -3,19 +3,11 @@
#@DESCRIPTION: Machine configuration for the SA1100 based Sharp Zaurus SL-5000 and SL-5500 devices
TARGET_ARCH = "arm"
-PREFERRED_PROVIDER_xserver ?= "xserver-kdrive"
-PREFERRED_PROVIDER_virtual/kernel ?= "collie-kernels-2.4-embedix"
-#
-# no keyboard feature because 2.4 kernel keymap works ok and we have limited flash
-# no usbgadget feature because 2.4 kernel handle it in own way on each machine
-#
-MACHINE_FEATURES = "kernel24 apm pcmcia screen irda"
+MACHINE_KERNEL_VERSION ?= "2.4"
+include conf/machine/include/collie-${MACHINE_KERNEL_VERSION}.conf
-MACHINE_EXTRA_RRECOMMENDS = "kernel-module-net-fd kernel-module-sa1100-bi \
-kernel-module-usbdcore kernel-module-usbdmonitor sharp-sdmmc-support"
-
-# kernel-module-collie-ssp kernel-module-collie-tc35143af if buzzer.patch applied
+PREFERRED_PROVIDER_xserver = "xserver-kdrive"
# This is needed for the ramdisk script to work
MACHINE_EXTRA_RDEPENDS += "e2fsprogs-mke2fs"
@@ -24,14 +16,12 @@ EXTRA_IMAGECMD_jffs2 = "--pad=14680064 --little-endian --eraseblock=0x20000 -n"
IMAGE_LINGUAS = ""
-include conf/machine/include/tune-strongarm.conf
+IMAGE_FSTYPES ?= "jffs2 tar.gz"
-SERIAL_CONSOLE = "115200 ttyS0"
+include conf/machine/include/tune-strongarm.conf
ROOT_FLASH_SIZE = "14"
# actually 14680064, see EXTRA_IMAGECMD above
-# Later versions are broken on kernel 2.4
-PREFERRED_VERSION_orinoco-modules = "0.13e"
-
MACHINE_TASK_PROVIDER = "task-base"
+GUI_MACHINE_CLASS_poodle = "smallscreen"
diff --git a/conf/machine/h1940.conf b/conf/machine/h1940.conf
index 08104624ca..37f61433c7 100644
--- a/conf/machine/h1940.conf
+++ b/conf/machine/h1940.conf
@@ -4,17 +4,21 @@
PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
TARGET_ARCH = "arm"
-PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
-PREFERRED_PROVIDER_virtual/kernel = "linux-h1940"
-PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
-BOOTSTRAP_EXTRA_RDEPENDS = "udev kernel kernel-modules modutils-collateral module-init-tools"
-HANDHELD_MODULES = ""
+# Set preferred providers
+PREFERRED_PROVIDER_xserver = "xserver-kdrive"
+PREFERRED_PROVIDER_virtual/kernel = "linux-h1940"
-BOOTSTRAP_EXTRA_RDEPENDS += "apm apmd network-suspend-scripts"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz scap ${@linux_module_packages('${HANDHELD_MODULES}', d)}"
+# Set features for task-base
+MACHINE_FEATURES = "kernel26 touchscreen apm bluetooth irda usbgadget screen"
-INHERIT += "linux-kernel-base"
+# Empty modules list for now
+HANDHELD_MODULES = ""
+# Some extra configuration
+VOLATILE_STORAGE_SIZE = "64"
+ROOT_FLASH_SIZE = "32"
GUI_MACHINE_CLASS = "smallscreen"
+SERIAL_CONSOLE = "115200 ttySAC2 vt100"
+USE_VT = "0"
diff --git a/conf/machine/blueangel.conf b/conf/machine/htcblueangel.conf
index dd079c244b..a61656ab5c 100644
--- a/conf/machine/blueangel.conf
+++ b/conf/machine/htcblueangel.conf
@@ -2,23 +2,39 @@
#@NAME: HTC Blueangel
#@DESCRIPTION: Machine configuration for the HTC Blueangel device
-KERNEL ?= "kernel26"
-
-OVERRIDES =. "${KERNEL}:"
-
+#
+# Hardware-based properties
+#
TARGET_ARCH = "arm"
PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
-PREFERRED_PROVIDER_xserver = "xserver-kdrive"
-PREFERRED_PROVIDER_virtual/kernel_kernel26 = "xanadux-ba-2.6"
-PREFERRED_PROVIDER_virtual/kernel = "xanadux-ba-2.6"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel ipaq-boot-params ${@linux_module_packages('${BA_MODULES}', d)}"
-BOOTSTRAP_EXTRA_RDEPENDS_append_kernel26 = " udev module-init-tools"
+require conf/machine/include/tune-xscale.conf
+
+ROOT_FLASH_SIZE = "32"
+VOLATILE_STORAGE_SIZE = "128"
+GUI_MACHINE_CLASS = "smallscreen"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda bluetooth wifi usbgadget screen"
-BA_MODULES_kernel26 = " evdev tsdev himalaya_tsc2200 himalaya_ts3 asic3_mmc mmc_core g_ether blueangel_battery \
- pcmcia-core hci_uart blueangel_pcmcia snd-mixer-oss blueangel_audio blueangel_rom blueangel_kp"
-# pxa2xx_udc is built in to the kernel
+#
+# Software/packages selection
+#
+PREFERRED_PROVIDER_virtual/kernel = "linux-handhelds-2.6"
+PCMCIA_MANAGER = "pcmciautils"
+PREFERRED_PROVIDER_xserver = "xserver-kdrive"
+MACHINE_EXTRA_RDEPENDS = "acx-firmware"
+MACHINE_EXTRA_RRECOMMENDS = "blueangel_pcmcia \
+ blueangel_audio \
+ blueangel_rom \
+ blueangel_kp
+ blueangel_battery \
+ blueangel_leds \
+ "
+#
+# Modules autoload and other boot properties
+#
+module_autoload_snd-pcm-oss = "snd-pcm-oss"
+module_autoload_g_ether = "g_ether"
module_autoload_evdev = "evdev"
module_autoload_himalaya_tsc2200 = "himalaya_tsc2200"
module_autoload_himalaya_ts3 = "himalaya_ts3"
@@ -30,14 +46,9 @@ module_autoload_blueangel_audio = "blueangel_audio"
module_autoload_bluenagel_leds = "bleangel_leds"
module_autoload_hci_uart = "hci_uart"
module_autoload_snd-mixer-oss = "snd-mixer-oss"
-module_autoload_snd-pcm-oss = "snd-pcm-oss"
-SERIAL_CONSOLE = "115200 tts/2 vt100"
+SERIAL_CONSOLE = "115200 ttyS0 vt100"
USE_VT = "0"
-GUI_MACHINE_CLASS = "smallscreen"
-ROOT_FLASH_SIZE = "32"
-
-# optimize images, but build feeds without using tune-xscale so as to retain backwards compatibility
-include conf/machine/include/tune-xscale.conf
+require conf/machine/include/LAB-settings.conf
diff --git a/conf/machine/include/collie-2.4.conf b/conf/machine/include/collie-2.4.conf
new file mode 100644
index 0000000000..0412ea359a
--- /dev/null
+++ b/conf/machine/include/collie-2.4.conf
@@ -0,0 +1,17 @@
+PREFERRED_PROVIDER_virtual/kernel = "collie-kernels-2.4-embedix"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+#
+# no keyboard feature because 2.4 kernel keymap works ok and we have limited flash
+# no usbgadget feature because 2.4 kernel handle it in own way on each machine
+#
+MACHINE_FEATURES = "kernel24 apm pcmcia screen irda"
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-net-fd kernel-module-sa1100-bi \
+ kernel-module-usbdcore kernel-module-usbdmonitor \
+ sharp-sdmmc-support"
+
+# kernel-module-collie-ssp kernel-module-collie-tc35143af if buzzer.patch applied
+
+# Later versions are broken on kernel 2.4
+PREFERRED_VERSION_orinoco-modules = "0.13e"
diff --git a/conf/machine/include/collie-2.6.conf b/conf/machine/include/collie-2.6.conf
new file mode 100644
index 0000000000..eab879368c
--- /dev/null
+++ b/conf/machine/include/collie-2.6.conf
@@ -0,0 +1,4 @@
+PREFERRED_PROVIDER_virtual/kernel = "linux-rp"
+
+SERIAL_CONSOLE = "115200 ttySA0"
+MACHINE_FEATURES = "kernel26 apm pcmcia screen irda usbgadget keyboard touchscreen"
diff --git a/conf/machine/include/qemu.conf b/conf/machine/include/qemu.conf
index b314fa9bea..26b78a6a9d 100644
--- a/conf/machine/include/qemu.conf
+++ b/conf/machine/include/qemu.conf
@@ -7,4 +7,5 @@ MACHINE_FEATURES = "kernel26 apm alsa pcmcia bluetooth irda usbgadget screen"
IMAGE_FSTYPES ?= "tar.bz2 ext2"
-ROOT_FLASH_SIZE = "100"
+ROOT_FLASH_SIZE = "200"
+IMAGE_ROOTFS_SIZE_ext2 = "200000"
diff --git a/conf/machine/include/tosa-2.6.conf b/conf/machine/include/tosa-2.6.conf
deleted file mode 100644
index f3591b4b75..0000000000
--- a/conf/machine/include/tosa-2.6.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-include conf/machine/include/zaurus-2.6.conf
-# wlan-ng Modules
-MACHINE_EXTRA_RDEPENDS += "wlan-ng-modules-usb"
-
-# WM97xx Modules
-#MACHINE_EXTRA_RRECOMMENDS += "kernel-module-wm97xx-core kernel-module-wm9705 kernel-module-pxa-wm97xx"
diff --git a/conf/machine/include/tune-thumb.conf b/conf/machine/include/tune-thumb.conf
index 2a12443b3d..48003571f1 100644
--- a/conf/machine/include/tune-thumb.conf
+++ b/conf/machine/include/tune-thumb.conf
@@ -23,8 +23,8 @@ OVERRIDES += "${OVERRIDE_THUMB}${OVERRIDE_INTERWORK}"
# Compiler and linker options for application code and kernel code. These
# options ensure that the compiler has the correct settings for the selected
# instruction set and interworking.
-ARM_INTERWORK_M_OPT = "${@['-mno-thumb-interwork', '-mthumb-interwork'][bb.data.getVar('THUMB_INTERWORK', d, 1) == 'yes']}"
-ARM_THUMB_M_OPT = "${@['-mno-thumb', '-mthumb'][bb.data.getVar('ARM_INSTRUCTION_SET', d, 1) == 'thumb']}"
+ARM_INTERWORK_M_OPT = "${@['', '-mthumb-interwork'][bb.data.getVar('THUMB_INTERWORK', d, 1) == 'yes']}"
+ARM_THUMB_M_OPT = "${@['', '-mthumb'][bb.data.getVar('ARM_INSTRUCTION_SET', d, 1) == 'thumb']}"
#
TARGET_CC_ARCH += "${ARM_INTERWORK_M_OPT} ${ARM_THUMB_M_OPT}"
diff --git a/conf/machine/ixp4xxle.conf b/conf/machine/ixp4xxle.conf
index 347c7ba3fb..d3fcd2b017 100644
--- a/conf/machine/ixp4xxle.conf
+++ b/conf/machine/ixp4xxle.conf
@@ -5,7 +5,9 @@
MACHINE_FEATURES = "kernel26 usbhost ext2"
ARCH_BYTE_SEX = "le"
-include conf/machine/include/ixp4xx.conf
+require conf/machine/include/ixp4xx.conf
+require conf/machine/include/tune-xscale.conf
+
PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ixp4xxle"
diff --git a/conf/machine/omap5912osk.conf b/conf/machine/omap5912osk.conf
index f8a3472f78..6e704a1f4e 100644
--- a/conf/machine/omap5912osk.conf
+++ b/conf/machine/omap5912osk.conf
@@ -11,7 +11,7 @@ PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap1"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
-PREFERRED_VERSION_u-boot = "LABEL.2006.06.30.2020"
+# PREFERRED_VERSION_u-boot = "1.1.6"
SERIAL_CONSOLE ?= "115200 ttyS0"
EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x20000 -n"
diff --git a/conf/machine/palmld.conf b/conf/machine/palmld.conf
index ec7336fe06..ae858ef2f8 100644
--- a/conf/machine/palmld.conf
+++ b/conf/machine/palmld.conf
@@ -5,7 +5,7 @@
TARGET_ARCH = "arm"
PACKAGE_EXTRA_ARCHS = "arm armv4t armv5te"
-PREFERRED_PROVIDER_virtual/kernel = "hackndev-2.6trunk"
+PREFERRED_PROVIDER_virtual/kernel = "linux-hackndev-2.6"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
diff --git a/conf/machine/palmtx.conf b/conf/machine/palmtx.conf
new file mode 100644
index 0000000000..0c2b08ba9a
--- /dev/null
+++ b/conf/machine/palmtx.conf
@@ -0,0 +1,23 @@
+#@TYPE: Machine
+#@NAME: Palm TX
+#@DESCRIPTION: Machine configuration for the Palm TX
+
+TARGET_ARCH = "arm"
+PACKAGE_EXTRA_ARCHS = "armv4t armv5te"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-hackndev-2.6"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
+
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia irda bluetooth wifi ext2 usbgadget screen"
+
+ROOT_FLASH_SIZE = "100"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+GUI_MACHINE_CLASS = "bigscreen"
+
+# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
+include conf/machine/tune-xscale.conf
+
+module_autoload_sa1100-rtc = "sa1100-rtc"
diff --git a/conf/machine/qemuarm.conf b/conf/machine/qemuarm.conf
index 371ba927bb..2de34e42c9 100644
--- a/conf/machine/qemuarm.conf
+++ b/conf/machine/qemuarm.conf
@@ -12,4 +12,4 @@ SERIAL_CONSOLE = "115200 ttyAMA0"
PREFERRED_PROVIDER_virtual/kernel = "linux-rp"
-MACHINE_TASK_PROVIDER = "task-base" \ No newline at end of file
+MACHINE_TASK_PROVIDER = "task-base"
diff --git a/conf/machine/qemux86.conf b/conf/machine/qemux86.conf
new file mode 100644
index 0000000000..dfbd345ae8
--- /dev/null
+++ b/conf/machine/qemux86.conf
@@ -0,0 +1,17 @@
+#@TYPE: Machine
+#@NAME: qemu x86 Emulator setup
+#@DESCRIPTION: Machine configuration for running an x86 system under qemu emulation
+
+TARGET_ARCH = "i586"
+PACKAGE_EXTRA_ARCHS = "x86"
+
+require conf/machine/include/qemu.conf
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-rp"
+
+GLIBC_ADDONS = "nptl"
+GLIBC_EXTRA_OECONF = "--with-tls"
+
+MACHINE_TASK_PROVIDER = "task-base"