summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/mpfr/mpfr.inc6
-rw-r--r--packages/mpfr/mpfr_2.1.1.bb9
-rw-r--r--packages/mpfr/mpfr_2.3.0.bb12
-rw-r--r--packages/mpfr/mpfr_cvs.bb9
4 files changed, 16 insertions, 20 deletions
diff --git a/packages/mpfr/mpfr.inc b/packages/mpfr/mpfr.inc
new file mode 100644
index 0000000000..cf898b62b6
--- /dev/null
+++ b/packages/mpfr/mpfr.inc
@@ -0,0 +1,6 @@
+DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE = "http://www.mpfr.org/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+inherit autotools
diff --git a/packages/mpfr/mpfr_2.1.1.bb b/packages/mpfr/mpfr_2.1.1.bb
index 10383b1caa..a42498cfd4 100644
--- a/packages/mpfr/mpfr_2.1.1.bb
+++ b/packages/mpfr/mpfr_2.1.1.bb
@@ -1,14 +1,11 @@
-DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
-LICENSE = "LGPL"
-SECTION = "libs"
+require mpfr.inc
+
DEPENDS = "gmp"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
S = "${WORKDIR}/mpfr-${PV}"
-inherit autotools
-
do_stage() {
oe_runmake install prefix=${STAGING_DIR} \
bindir=${STAGING_BINDIR} \
diff --git a/packages/mpfr/mpfr_2.3.0.bb b/packages/mpfr/mpfr_2.3.0.bb
index 2acd7da3e4..92fbe7bd4b 100644
--- a/packages/mpfr/mpfr_2.3.0.bb
+++ b/packages/mpfr/mpfr_2.3.0.bb
@@ -1,19 +1,15 @@
-DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
-LICENSE = "LGPL"
-SECTION = "libs"
+require mpfr.inc
+
DEPENDS = "gmp"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
S = "${WORKDIR}/mpfr-${PV}"
-inherit autotools
-
do_stage() {
oe_runmake install prefix=${STAGING_DIR} \
bindir=${STAGING_BINDIR} \
includedir=${STAGING_INCDIR} \
libdir=${STAGING_LIBDIR} \
- datadir=${STAGING_DATADIR} \
- infodir=${STAGING_DIR}/${HOST_SYS}/info
+ datadir=${STAGING_DATADIR}
}
diff --git a/packages/mpfr/mpfr_cvs.bb b/packages/mpfr/mpfr_cvs.bb
index fcea24633a..679aaffcc6 100644
--- a/packages/mpfr/mpfr_cvs.bb
+++ b/packages/mpfr/mpfr_cvs.bb
@@ -1,15 +1,12 @@
-DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
-LICENSE = "LGPL"
-SECTION = "libs"
+require mpfr.inc
+
DEPENDS = "gmp"
PV = "0.0+cvs${SRCDATE}"
-PR = "r1"
+PR = "r2"
SRC_URI = "cvs://cvs:@cvs-sop.inria.fr/CVS/spaces;module=mpfr;method=pserver"
S = "${WORKDIR}/mpfr"
-inherit autotools
-
do_stage() {
oe_runmake install prefix=${STAGING_DIR} \
bindir=${STAGING_BINDIR} \