summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/pam/libpam_0.79.bb5
-rw-r--r--packages/pam/libpam_1.0.2.bb6
2 files changed, 8 insertions, 3 deletions
diff --git a/packages/pam/libpam_0.79.bb b/packages/pam/libpam_0.79.bb
index c695f4799b..7a5ff4bdc8 100644
--- a/packages/pam/libpam_0.79.bb
+++ b/packages/pam/libpam_0.79.bb
@@ -18,7 +18,7 @@ HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
# The project is actually called Linux-PAM but that gives
# a bad OE package name because of the upper case characters
@@ -36,6 +36,9 @@ SRC_URI += " file://libpam-make.patch;patch=1"
inherit autotools
+# maintain the pam default layout
+EXTRA_OECONF += " --includedir=${includedir}/security"
+
# EXTRA_OECONF += " --enable-static-libpam"
# Disable building of the documentation - it requires too many different
# programs installed on the build system and is a waste of time. This
diff --git a/packages/pam/libpam_1.0.2.bb b/packages/pam/libpam_1.0.2.bb
index 0b7eada2ab..b1ceb1bb04 100644
--- a/packages/pam/libpam_1.0.2.bb
+++ b/packages/pam/libpam_1.0.2.bb
@@ -12,7 +12,7 @@ LICENSE = "GPLv2"
DEPENDS = "flex flex-native"
-PR = "r1"
+PR = "r2"
# The project is actually called Linux-PAM but that gives
# a bad OE package name because of the upper case characters
@@ -27,6 +27,9 @@ inherit autotools
LEAD_SONAME = "libpam.so.*"
+# maintain the pam default layout
+EXTRA_OECONF += " --includedir=${includedir}/security"
+
python populate_packages_prepend () {
import os.path
@@ -44,4 +47,3 @@ python populate_packages_prepend () {
do_stage() {
autotools_stage_all
}
-