summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/perl/libdata-optlist-perl-native_0.101.bb5
-rw-r--r--packages/perl/libdata-optlist-perl_0.101.bb14
-rw-r--r--packages/perl/libparams-util-perl-native_0.20.bb5
-rw-r--r--packages/perl/libparams-util-perl_0.20.bb13
-rw-r--r--packages/perl/libsub-exporter-perl-native_0.970.bb5
-rw-r--r--packages/perl/libsub-exporter-perl_0.970.bb15
-rw-r--r--packages/perl/libsub-install-perl-native_0.922.bb5
-rw-r--r--packages/perl/libsub-install-perl_0.922.bb13
-rw-r--r--packages/perl/libsub-uplevel-perl-native_0.13.bb5
-rw-r--r--packages/perl/libsub-uplevel-perl_0.13.bb12
-rw-r--r--packages/perl/libtest-builder-tester-perl_1.01.bb13
-rw-r--r--packages/perl/libtest-differences-perl_0.47.bb14
-rw-r--r--packages/perl/libtest-exception-perl_0.22.bb15
-rw-r--r--packages/perl/libtest-mockmodule-perl_0.05.bb13
-rw-r--r--packages/perl/libtest-output-perl_0.10.bb13
15 files changed, 160 insertions, 0 deletions
diff --git a/packages/perl/libdata-optlist-perl-native_0.101.bb b/packages/perl/libdata-optlist-perl-native_0.101.bb
new file mode 100644
index 0000000000..cf7847d783
--- /dev/null
+++ b/packages/perl/libdata-optlist-perl-native_0.101.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require ${@bb.data.getVar('P', d , 1).replace('-native-', '_')}.bb
diff --git a/packages/perl/libdata-optlist-perl_0.101.bb b/packages/perl/libdata-optlist-perl_0.101.bb
new file mode 100644
index 0000000000..13d15290a8
--- /dev/null
+++ b/packages/perl/libdata-optlist-perl_0.101.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Data::OptList - parse and validate simple name/value option pairs"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+DEPENDS += "libsub-install-perl-native libparams-util-perl-native"
+RDEPENDS += "perl-module-list-util libparams-util-perl perl-module-strict \
+ libsub-install-perl perl-module-warnings "
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-OptList-${PV}.tar.gz"
+
+S = "${WORKDIR}/Data-OptList-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libparams-util-perl-native_0.20.bb b/packages/perl/libparams-util-perl-native_0.20.bb
new file mode 100644
index 0000000000..cf7847d783
--- /dev/null
+++ b/packages/perl/libparams-util-perl-native_0.20.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require ${@bb.data.getVar('P', d , 1).replace('-native-', '_')}.bb
diff --git a/packages/perl/libparams-util-perl_0.20.bb b/packages/perl/libparams-util-perl_0.20.bb
new file mode 100644
index 0000000000..31738c0016
--- /dev/null
+++ b/packages/perl/libparams-util-perl_0.20.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Params::Util - Simple, compact and correct param-checking functions"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+RDEPENDS += "perl-module-exporter perl-module-overload \
+ perl-module-scalar-util perl-module-strict perl-module-vars"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Params-Util-${PV}.tar.gz"
+
+S = "${WORKDIR}/Params-Util-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libsub-exporter-perl-native_0.970.bb b/packages/perl/libsub-exporter-perl-native_0.970.bb
new file mode 100644
index 0000000000..cf7847d783
--- /dev/null
+++ b/packages/perl/libsub-exporter-perl-native_0.970.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require ${@bb.data.getVar('P', d , 1).replace('-native-', '_')}.bb
diff --git a/packages/perl/libsub-exporter-perl_0.970.bb b/packages/perl/libsub-exporter-perl_0.970.bb
new file mode 100644
index 0000000000..1adf152a3c
--- /dev/null
+++ b/packages/perl/libsub-exporter-perl_0.970.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Sub::Exporter - a sophisticated exporter for custom-built routines"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+DEPENDS += "libdata-optlist-perl-native libsub-install-perl-native \
+ libparams-util-perl-native"
+RDEPENDS += "perl-module-carp libdata-optlist-perl libparams-util-perl \
+ perl-module-strict libsub-install-perl perl-module-warnings"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Sub-Exporter-${PV}.tar.gz"
+
+S = "${WORKDIR}/Sub-Exporter-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libsub-install-perl-native_0.922.bb b/packages/perl/libsub-install-perl-native_0.922.bb
new file mode 100644
index 0000000000..cf7847d783
--- /dev/null
+++ b/packages/perl/libsub-install-perl-native_0.922.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require ${@bb.data.getVar('P', d , 1).replace('-native-', '_')}.bb
diff --git a/packages/perl/libsub-install-perl_0.922.bb b/packages/perl/libsub-install-perl_0.922.bb
new file mode 100644
index 0000000000..f867886444
--- /dev/null
+++ b/packages/perl/libsub-install-perl_0.922.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Sub::Install - install subroutines into packages easily"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+RDEPENDS += "perl-module-carp perl-module-scalar-util perl-module-strict \
+ perl-module-warnings"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Sub-Install-${PV}.tar.gz"
+
+S = "${WORKDIR}/Sub-Install-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libsub-uplevel-perl-native_0.13.bb b/packages/perl/libsub-uplevel-perl-native_0.13.bb
new file mode 100644
index 0000000000..cf7847d783
--- /dev/null
+++ b/packages/perl/libsub-uplevel-perl-native_0.13.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require ${@bb.data.getVar('P', d , 1).replace('-native-', '_')}.bb
diff --git a/packages/perl/libsub-uplevel-perl_0.13.bb b/packages/perl/libsub-uplevel-perl_0.13.bb
new file mode 100644
index 0000000000..27aa70a778
--- /dev/null
+++ b/packages/perl/libsub-uplevel-perl_0.13.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Sub::Uplevel - apparently run a function in a higher stack frame"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+RDEPENDS += "perl-module-exporter perl-module-strict perl-module-vars"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Sub-Uplevel-0.13.tar.gz"
+
+S = "${WORKDIR}/Sub-Uplevel-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libtest-builder-tester-perl_1.01.bb b/packages/perl/libtest-builder-tester-perl_1.01.bb
new file mode 100644
index 0000000000..0c44fff883
--- /dev/null
+++ b/packages/perl/libtest-builder-tester-perl_1.01.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Test::Builder::Tester - test testsuites that have been built with Test::Builder"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+RDEPENDS += "perl-module-strict perl-module-carp perl-module-exporter \
+ perl-module-symbol perl-module-vars"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKF/Test-Builder-Tester-${PV}.tar.gz"
+
+S = "${WORKDIR}/Test-Builder-Tester-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libtest-differences-perl_0.47.bb b/packages/perl/libtest-differences-perl_0.47.bb
new file mode 100644
index 0000000000..7a1311b23e
--- /dev/null
+++ b/packages/perl/libtest-differences-perl_0.47.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Test::Differences - Test strings and data structures and show differences if not ok"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+DEPENDS += "libtext-diff-perl-native"
+RDEPENDS += "perl-module-carp perl-module-constant perl-module-exporter \
+ perl-module-strict libtext-diff-perl"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RB/RBS/Test-Differences-${PV}.tar.gz"
+
+S = "${WORKDIR}/Test-Differences-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libtest-exception-perl_0.22.bb b/packages/perl/libtest-exception-perl_0.22.bb
new file mode 100644
index 0000000000..9dffa1341e
--- /dev/null
+++ b/packages/perl/libtest-exception-perl_0.22.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Test::Exception - Test exception based code"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+DEPENDS += "libsub-uplevel-perl-native"
+RDEPENDS += "perl-module-base perl-module-carp perl-module-strict \
+ libsub-uplevel-perl perl-module-test-builder \
+ perl-module-warnings"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Exception-${PV}.tar.gz"
+
+S = "${WORKDIR}/Test-Exception-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libtest-mockmodule-perl_0.05.bb b/packages/perl/libtest-mockmodule-perl_0.05.bb
new file mode 100644
index 0000000000..f72665ba94
--- /dev/null
+++ b/packages/perl/libtest-mockmodule-perl_0.05.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Test::MockModule - Override subroutines in a module for unit testing"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+RDEPENDS += "perl-module-carp perl-module-scalar-util perl-module-strict \
+ perl-module-vars "
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SI/SIMONFLK/Test-MockModule-${PV}.tar.gz"
+
+S = "${WORKDIR}/Test-MockModule-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libtest-output-perl_0.10.bb b/packages/perl/libtest-output-perl_0.10.bb
new file mode 100644
index 0000000000..74ac8b11e9
--- /dev/null
+++ b/packages/perl/libtest-output-perl_0.10.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Test::Output - Utilities to test STDOUT and STDERR messages"
+SECTION = "libs"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "Artistic|GPL"
+DEPENDS += "libsub-exporter-perl-native"
+RDEPENDS += "libsub-exporter-perl"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SS/SSORICHE/Test-Output-${PV}.tar.gz"
+
+S = "${WORKDIR}/Test-Output-${PV}"
+
+inherit cpan