summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/moko-autorev.inc4
-rw-r--r--conf/distro/include/sane-srcdates.inc2
-rw-r--r--packages/classpath/classpath-initial_0.93.bb3
-rw-r--r--packages/classpath/classpath-native.inc6
-rw-r--r--packages/ecj/ecj-bootstrap-native_3.3.2.bb38
-rw-r--r--packages/ecj/ecj-bootstrap-native_3.4.bb38
-rw-r--r--packages/ecj/ecj-initial_3.3.2.bb84
-rw-r--r--packages/ecj/ecj-initial_3.4.bb84
-rw-r--r--packages/efl1/ecore_cvs.bb55
-rw-r--r--packages/openmoko-projects/illume/.mtn2git_empty0
-rw-r--r--packages/openmoko-projects/illume/configure-keyboard.patch39
-rw-r--r--packages/openmoko-projects/illume_svn.bb9
12 files changed, 327 insertions, 35 deletions
diff --git a/conf/distro/include/moko-autorev.inc b/conf/distro/include/moko-autorev.inc
index 66a7201cf0..a43f15eca9 100644
--- a/conf/distro/include/moko-autorev.inc
+++ b/conf/distro/include/moko-autorev.inc
@@ -3,8 +3,8 @@ SRCREV_pn-dfu-util ?= "${AUTOREV}"
SRCREV_pn-dfu-util-native ?= "${AUTOREV}"
SRCREV_pn-diversity-daemon ?= "${AUTOREV}"
SRCREV_pn-diversity-nav ?= "${AUTOREV}"
-#SRCREV_pn-illume ?= "${AUTOREV}"
-#SRCREV_pn-illume-theme ?= "${AUTOREV}"
+SRCREV_pn-illume ?= "${AUTOREV}"
+SRCREV_pn-illume-theme-asu ?= "${AUTOREV}"
SRCREV_pn-libgsmd ?= "${AUTOREV}"
SRCREV_pn-libjana ?= "${AUTOREV}"
SRCREV_pn-libmokogsmd2 ?= "${AUTOREV}"
diff --git a/conf/distro/include/sane-srcdates.inc b/conf/distro/include/sane-srcdates.inc
index f248a81bba..0e38beb83c 100644
--- a/conf/distro/include/sane-srcdates.inc
+++ b/conf/distro/include/sane-srcdates.inc
@@ -52,7 +52,7 @@ SRCDATE_gtkhtml2 ?= "20060323"
# Enlightenment Foundation Libraries
# Caution: This is not alphabetically, but (roughly) dependency-sorted.
# Please leave it like that.
-EFL_SRCDATE ?= "20080716"
+EFL_SRCDATE ?= "20080727"
SRCDATE_edb-native ?= "${EFL_SRCDATE}"
SRCDATE_edb ?= "${EFL_SRCDATE}"
SRCDATE_eet-native ?= "${EFL_SRCDATE}"
diff --git a/packages/classpath/classpath-initial_0.93.bb b/packages/classpath/classpath-initial_0.93.bb
index 9e303f6eba..7c1b91eb20 100644
--- a/packages/classpath/classpath-initial_0.93.bb
+++ b/packages/classpath/classpath-initial_0.93.bb
@@ -5,7 +5,7 @@ require classpath-native.inc
DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
-PR = "r0"
+PR = "r2"
DEPENDS = "zip-native fastjar-native jikes-native"
@@ -25,4 +25,3 @@ EXTRA_OECONF = "\
--with-native-libdir=${STAGING_LIBDIR}/classpath-initial \
--includedir=${STAGING_INCDIR}/classpath-initial \
"
-
diff --git a/packages/classpath/classpath-native.inc b/packages/classpath/classpath-native.inc
index bb5abaf178..94eac9633e 100644
--- a/packages/classpath/classpath-native.inc
+++ b/packages/classpath/classpath-native.inc
@@ -10,9 +10,13 @@ DEPENDS = "ecj-initial fastjar-native zip-native"
inherit autotools native
+export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
+
+# Note: the --with-ecj options seems redundant but is
+# for compatibility with older classpath versions.
EXTRA_OECONF = "\
- --with-glibj \
--with-ecj=${STAGING_BINDIR_NATIVE}/ecj-initial \
+ --with-glibj \
--with-fastjar=fastjar \
--enable-local-sockets \
--disable-alsa \
diff --git a/packages/ecj/ecj-bootstrap-native_3.3.2.bb b/packages/ecj/ecj-bootstrap-native_3.3.2.bb
new file mode 100644
index 0000000000..bd4347457c
--- /dev/null
+++ b/packages/ecj/ecj-bootstrap-native_3.3.2.bb
@@ -0,0 +1,38 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# Since the VM running the compiler has no effect on the produced bytecode this recipe
+# uses the jar created by ecj-initial and creates a start script that runs it with a different
+# VM.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "ecj-initial virtual/java-native"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+inherit native
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-bootstrap
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+ echo "RUNTIME=java" >> ecj-bootstrap
+ cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}
diff --git a/packages/ecj/ecj-bootstrap-native_3.4.bb b/packages/ecj/ecj-bootstrap-native_3.4.bb
new file mode 100644
index 0000000000..bd4347457c
--- /dev/null
+++ b/packages/ecj/ecj-bootstrap-native_3.4.bb
@@ -0,0 +1,38 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# Since the VM running the compiler has no effect on the produced bytecode this recipe
+# uses the jar created by ecj-initial and creates a start script that runs it with a different
+# VM.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "ecj-initial virtual/java-native"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+inherit native
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-bootstrap
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+ echo "RUNTIME=java" >> ecj-bootstrap
+ cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}
diff --git a/packages/ecj/ecj-initial_3.3.2.bb b/packages/ecj/ecj-initial_3.3.2.bb
new file mode 100644
index 0000000000..22cced959d
--- /dev/null
+++ b/packages/ecj/ecj-initial_3.3.2.bb
@@ -0,0 +1,84 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+
+# This variant runs on the initial (not Java5-compatible runtime).
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+
+SRC_URI = "\
+ http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3.2-200802211800/ecjsrc.zip \
+ file://ecj.in \
+ "
+
+S = "${WORKDIR}"
+
+inherit native
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+do_unpackpost() {
+ if [ ! -d source ]; then
+ mkdir source
+ fi
+
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+
+ # Remove crap.
+ rm about.html build.xml
+ rm -rf META-INF
+
+ # Move source into separate subdir.
+ mv org source/
+
+ # Remove stuff unneeded for the bootstrap compiler.
+ rm -rf source/org/eclipse/jdt/internal/compiler/apt
+ rm -rf source/org/eclipse/jdt/internal/compiler/tool
+ rm -rf source/org/eclipse/jdt/internal/antadapter
+ rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
+
+ # Make a copy of the remaining source to get the embedded
+ # resources.
+ cp -r source/org build/
+
+ # Remove source code and other stuff.
+ find build -name '*.java' -exec rm -f {} \;
+ find build -name '*.html' -exec rm -f {} \;
+}
+
+addtask unpackpost after do_unpack before do_patch
+
+do_compile() {
+ find source -name '*.java' > sourcefiles
+ split -l 25 sourcefiles ecj-sources.
+
+ # Compiling in place is done because the sources contain
+ # property files which need to be available at runtime.
+ for list in `find . -name 'ecj-sources.*'`; do
+ echo "building files in $list ...";
+ echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
+ jikes-initial \
+ -d build -source 1.4 -sourcepath source `cat $list`;
+ done
+
+ fastjar -c -C build . -f ${JAR}
+
+ # Create the start script
+ echo "#!/bin/sh" > ecj-initial
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
+ echo "RUNTIME=java-initial" >> ecj-initial
+ cat ecj.in >> ecj-initial
+}
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/java
+ install -m 755 ${S}/${JAR} ${STAGING_DATADIR}/java
+
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+}
diff --git a/packages/ecj/ecj-initial_3.4.bb b/packages/ecj/ecj-initial_3.4.bb
new file mode 100644
index 0000000000..a0cacffebb
--- /dev/null
+++ b/packages/ecj/ecj-initial_3.4.bb
@@ -0,0 +1,84 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+
+# This variant runs on the initial (not Java5-compatible runtime).
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+
+SRC_URI = "\
+ http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.4-200806172000/ecjsrc.zip \
+ file://ecj.in \
+ "
+
+S = "${WORKDIR}"
+
+inherit native
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+do_unpackpost() {
+ if [ ! -d source ]; then
+ mkdir source
+ fi
+
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+
+ # Remove crap.
+ rm about.html build.xml
+ rm -rf META-INF
+
+ # Move source into separate subdir.
+ mv org source/
+
+ # Remove stuff unneeded for the bootstrap compiler.
+ rm -rf source/org/eclipse/jdt/internal/compiler/apt
+ rm -rf source/org/eclipse/jdt/internal/compiler/tool
+ rm -rf source/org/eclipse/jdt/internal/antadapter
+ rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
+
+ # Make a copy of the remaining source to get the embedded
+ # resources.
+ cp -r source/org build/
+
+ # Remove source code and other stuff.
+ find build -name '*.java' -exec rm -f {} \;
+ find build -name '*.html' -exec rm -f {} \;
+}
+
+addtask unpackpost after do_unpack before do_patch
+
+do_compile() {
+ find source -name '*.java' > sourcefiles
+ split -l 25 sourcefiles ecj-sources.
+
+ # Compiling in place is done because the sources contain
+ # property files which need to be available at runtime.
+ for list in `find . -name 'ecj-sources.*'`; do
+ echo "building files in $list ...";
+ echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
+ jikes-initial \
+ -d build -source 1.4 -sourcepath source `cat $list`;
+ done
+
+ fastjar -c -C build . -f ${JAR}
+
+ # Create the start script
+ echo "#!/bin/sh" > ecj-initial
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
+ echo "RUNTIME=java-initial" >> ecj-initial
+ cat ecj.in >> ecj-initial
+}
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/java
+ install -m 755 ${S}/${JAR} ${STAGING_DATADIR}/java
+
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+}
diff --git a/packages/efl1/ecore_cvs.bb b/packages/efl1/ecore_cvs.bb
index e2ded16111..f36cc737bf 100644
--- a/packages/efl1/ecore_cvs.bb
+++ b/packages/efl1/ecore_cvs.bb
@@ -1,32 +1,33 @@
require ecore.inc
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = "\
- --x-includes=${STAGING_INCDIR}/X11 \
- --x-libraries=${STAGING_LIBDIR} \
- --enable-simple-x11 \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --enable-simple-x11 \
\
- --enable-ecore-txt \
- --enable-ecore-config \
- --disable-ecore-x-xcb \
- --enable-ecore-x \
- --enable-ecore-job \
- --disable-ecore-directfb \
- --disable-ecore-sdl \
- --enable-ecore-fb \
- --enable-ecore-evas \
- --enable-ecore-evas-x11-16 \
- --disable-ecore-evas-x11-gl \
- --enable-ecore-evas-xrender \
- --disable-ecore-evas-dfb \
- --disable-ecore-evas-sdl \
- --disable-openssl \
- --enable-abstract-sockets \
- --enable-ecore-con \
- --enable-ecore-ipc \
- --enable-ecore-file \
- --enable-inotify \
- --disable-poll \
- --enable-curl \
- --disable-ecore-desktop \
+ --enable-ecore-txt \
+ --enable-ecore-config \
+ --disable-ecore-x-xcb \
+ --enable-ecore-x \
+ --enable-ecore-job \
+ --disable-ecore-directfb \
+ --disable-ecore-sdl \
+ --enable-ecore-fb \
+ --enable-ecore-evas \
+ --enable-ecore-evas-x11-16 \
+ --enable-ecore-evas-16-x11 \
+ --disable-ecore-evas-x11-gl \
+ --enable-ecore-evas-xrender \
+ --disable-ecore-evas-dfb \
+ --disable-ecore-evas-sdl \
+ --disable-openssl \
+ --enable-abstract-sockets \
+ --enable-ecore-con \
+ --enable-ecore-ipc \
+ --enable-ecore-file \
+ --enable-inotify \
+ --disable-poll \
+ --enable-curl \
+ --disable-ecore-desktop \
"
diff --git a/packages/openmoko-projects/illume/.mtn2git_empty b/packages/openmoko-projects/illume/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openmoko-projects/illume/.mtn2git_empty
diff --git a/packages/openmoko-projects/illume/configure-keyboard.patch b/packages/openmoko-projects/illume/configure-keyboard.patch
new file mode 100644
index 0000000000..589fe53f38
--- /dev/null
+++ b/packages/openmoko-projects/illume/configure-keyboard.patch
@@ -0,0 +1,39 @@
+Index: configure.in
+===================================================================
+--- configure.in (Revision 170)
++++ configure.in (Arbeitskopie)
+@@ -95,6 +95,21 @@
+ AC_SUBST(e_libs)
+ AC_SUBST(e_modules)
+
++want_illume_virtual_keyboard=no
++AC_ARG_ENABLE(illume-keyboard,
++ AC_HELP_STRING(
++ [--enable-illume-keyboard],
++ [Enable the illume virtual keyboard.]
++ ),
++ [want_illume_virtual_keyboard=$enableval]
++ )
++AC_MSG_CHECKING(whether the illume virtual keyboard is to be built in)
++AC_MSG_RESULT($want_illume_virtual_keyboard)
++
++if test "x$want_illume_virtual_keyboard" = "xyes"; then
++ AC_DEFINE(BUILD_ILLUME_VIRTUAL_KEYBOARD, 1, [Build the virtual keyboard in])
++fi
++
+ AC_OUTPUT([
+ Makefile
+ src/Makefile
+Index: src/e_mod_win.c
+===================================================================
+--- src/e_mod_win.c (Revision 170)
++++ src/e_mod_win.c (Arbeitskopie)
+@@ -102,7 +102,7 @@
+ e_module_dir_get(m),
+ e_module_dir_get(m));
+ // FIXME: run kbd app or use internal
+-#if 0
++#ifdef BUILD_ILLUME_VIRTUAL_KEYBOARD
+ //enable for now to test internal kbd
+ vkbd_int = e_kbd_int_new(e_module_dir_get(m),
+ e_module_dir_get(m),
diff --git a/packages/openmoko-projects/illume_svn.bb b/packages/openmoko-projects/illume_svn.bb
index af101f1a01..52150a00dc 100644
--- a/packages/openmoko-projects/illume_svn.bb
+++ b/packages/openmoko-projects/illume_svn.bb
@@ -4,9 +4,12 @@ AUTHOR = "Rasterman"
LICENSE = "MIT/BSD"
DEPENDS = "e-wm eet evas ecore edje embryo efreet edbus edje-native embryo-native"
PV = "0.0+svnr${SRCREV}"
-PR = "r8"
+PR = "r10"
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=${PN};proto=http"
+SRC_URI = "\
+ svn://svn.projects.openmoko.org/svnroot/;module=${PN};proto=http \
+ file://configure-keyboard.patch;patch=1;pnum=0 \
+"
S = "${WORKDIR}/${PN}"
inherit autotools pkgconfig
@@ -16,6 +19,8 @@ EXTRA_OECONF = "\
--x-libraries=${STAGING_LIBDIR} \
--enable-simple-x11 \
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+\
+ --enable-illume-keyboard \
"
RRECOMMENDS_${PN} = "\