summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/update-rc.d.bbclass8
-rw-r--r--packages/ffmpeg/ffmpeg_git.bb6
-rw-r--r--packages/ffmpeg/omapfbplay_git.bb2
-rw-r--r--packages/linux/gumstix-kernel_2.6.21.bb4
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/defconfig5
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/no-cortex-deadlock.patch75
-rw-r--r--packages/linux/linux-omap2_git.bb5
-rw-r--r--packages/mozilla/firefox-3.0.1/.mtn2git_empty (renamed from packages/mozilla/firefox-3.0/.mtn2git_empty)0
-rw-r--r--packages/mozilla/firefox-3.0.1/0001-Remove-Werror-from-build.patch45
-rw-r--r--packages/mozilla/firefox-3.0.1/0002-Fix-security-cross-compile-cpu-detection-error.patch42
-rw-r--r--packages/mozilla/firefox-3.0.1/010_FPU_IS_ARM_FPA_xslt.diff (renamed from packages/mozilla/firefox-3.0/010_FPU_IS_ARM_FPA_xslt.diff)0
-rw-r--r--packages/mozilla/firefox-3.0.1/Bug339782.additional.fix.diff (renamed from packages/mozilla/firefox-3.0/Bug339782.additional.fix.diff)0
-rw-r--r--packages/mozilla/firefox-3.0.1/Bug385583.nspr.jmp_buf.eabi.diff (renamed from packages/mozilla/firefox-3.0/Bug385583.nspr.jmp_buf.eabi.diff)0
-rw-r--r--packages/mozilla/firefox-3.0.1/Bug405992.atomic.nspr.diff (renamed from packages/mozilla/firefox-3.0/Bug405992.atomic.nspr.diff)0
-rw-r--r--packages/mozilla/firefox-3.0.1/jemalloc-tls.patch (renamed from packages/mozilla/firefox-3.0/jemalloc-tls.patch)0
-rw-r--r--packages/mozilla/firefox-3.0.1/jsautocfg-dontoverwrite.patch (renamed from packages/mozilla/firefox-3.0/jsautocfg-dontoverwrite.patch)0
-rw-r--r--packages/mozilla/firefox-3.0.1/linkage-problem.patch (renamed from packages/mozilla/firefox-3.0/linkage-problem.patch)0
-rw-r--r--packages/mozilla/firefox-3.0.1/mozconfig (renamed from packages/mozilla/firefox-3.0/mozconfig)9
-rw-r--r--packages/mozilla/firefox-3.0.1/random_to_urandom.diff (renamed from packages/mozilla/firefox-3.0/random_to_urandom.diff)0
-rw-r--r--packages/mozilla/firefox-3.0.1/security-cross.patch (renamed from packages/mozilla/firefox-3.0/security-cross.patch)0
-rw-r--r--packages/mozilla/firefox.inc2
-rw-r--r--packages/mozilla/firefox_3.0.1.bb (renamed from packages/mozilla/firefox_3.0.bb)12
-rw-r--r--packages/mythtv/mythtv-0.21/no-cortex-deadlock.patch115
-rw-r--r--packages/mythtv/mythtv_0.21.bb3
24 files changed, 309 insertions, 24 deletions
diff --git a/classes/update-rc.d.bbclass b/classes/update-rc.d.bbclass
index 3051b7933f..9b832c0012 100644
--- a/classes/update-rc.d.bbclass
+++ b/classes/update-rc.d.bbclass
@@ -45,10 +45,12 @@ python populate_packages_prepend () {
bb.data.setVar("OVERRIDES", "%s:%s" % (pkg, overrides), localdata)
bb.data.update_data(localdata)
- postinst = bb.data.getVar('pkg_postinst', localdata, 1)
- if not postinst:
- postinst = '#!/bin/sh\n'
+ postinst = '#!/bin/sh\n'
postinst += bb.data.getVar('updatercd_postinst', localdata, 1)
+ try:
+ postinst += bb.data.getVar('pkg_postinst', localdata, 1)
+ except:
+ pass
bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
prerm = bb.data.getVar('pkg_prerm', localdata, 1)
if not prerm:
diff --git a/packages/ffmpeg/ffmpeg_git.bb b/packages/ffmpeg/ffmpeg_git.bb
index b0c57288a1..e45ea4b6e6 100644
--- a/packages/ffmpeg/ffmpeg_git.bb
+++ b/packages/ffmpeg/ffmpeg_git.bb
@@ -3,7 +3,7 @@ require ffmpeg.inc
DEPENDS += "libgsm"
PV = "0.4.9+${PR}+gitr${SRCREV}"
-PR = "r16"
+PR = "r18"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_armv7a = "1"
@@ -11,8 +11,8 @@ DEFAULT_PREFERENCE_armv7a = "1"
FFBRANCH_arm = "arm-neon"
FFBRANCH ?= "master"
-SRCREV = "dee1c2d60a67dc6411ed3fcbe26db5113cb1a371"
-SRCREV_arm = "699f491ee2d3c3216ef16ea30ec3956f4cb583db"
+SRCREV = "3692b8de9fae73860be636606cb6344f26e28b1a"
+SRCREV_arm = "c6bbb0c33f6f681b8265a43f8744735de5a9d45e"
SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
"
diff --git a/packages/ffmpeg/omapfbplay_git.bb b/packages/ffmpeg/omapfbplay_git.bb
index dd89b8eae8..1260c0ecc1 100644
--- a/packages/ffmpeg/omapfbplay_git.bb
+++ b/packages/ffmpeg/omapfbplay_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
DEPENDS = "bzip2 lame ffmpeg virtual/kernel"
LICENSE = "MIT"
-PR = "r6"
+PR = "r8"
inherit module-base
diff --git a/packages/linux/gumstix-kernel_2.6.21.bb b/packages/linux/gumstix-kernel_2.6.21.bb
index e71c972053..706a69efbb 100644
--- a/packages/linux/gumstix-kernel_2.6.21.bb
+++ b/packages/linux/gumstix-kernel_2.6.21.bb
@@ -1,4 +1,6 @@
-require gumstix-linux.inc
+require linux.inc
+
+S = "${WORKDIR}/linux-${PV}"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://defconfig \
diff --git a/packages/linux/linux-omap2-git/beagleboard/defconfig b/packages/linux/linux-omap2-git/beagleboard/defconfig
index 6381271cf9..9c41ce01cb 100644
--- a/packages/linux/linux-omap2-git/beagleboard/defconfig
+++ b/packages/linux/linux-omap2-git/beagleboard/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.26-rc9-omap1
-# Tue Jul 8 15:36:02 2008
+# Linux kernel version: 2.6.26-omap1
+# Wed Jul 30 10:34:59 2008
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -331,6 +331,7 @@ CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_VFP=y
CONFIG_VFPv3=y
CONFIG_NEON=y
+CONFIG_NEON_CACHE_BUG=y
#
# Userspace binary formats
diff --git a/packages/linux/linux-omap2-git/beagleboard/no-cortex-deadlock.patch b/packages/linux/linux-omap2-git/beagleboard/no-cortex-deadlock.patch
new file mode 100644
index 0000000000..32ec4c2d33
--- /dev/null
+++ b/packages/linux/linux-omap2-git/beagleboard/no-cortex-deadlock.patch
@@ -0,0 +1,75 @@
+From: Mans Rullgard <mans@mansr.com>
+Date: Wed, 30 Jul 2008 08:25:51 +0000 (+0100)
+Subject: ARM: NEON L1 cache bug workaround (erratum 451034)
+X-Git-Url: http://git.mansr.com/?p=linux-omap;a=commitdiff_plain;h=26023493baf13e0a67fd6cf08d87be5ff6f7c56d
+
+ARM: NEON L1 cache bug workaround (erratum 451034)
+
+On Cortex-A8 r1p0 and r1p1, executing a NEON store with an integer
+store in the store buffer, can cause a processor deadlock under
+certain conditions.
+
+Executing a DMB instruction before saving NEON/VFP registers and before
+return to userspace makes it safe to run code which includes similar
+counter-measures. Userspace code can still trigger the deadlock, so
+a different workaround is required to safely run untrusted code.
+
+See ARM Cortex-A8 Errata Notice (PR120-PRDC-008070) for full details.
+---
+
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 8c75840..1172e14 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -1071,6 +1071,22 @@ config NEON
+ Say Y to include support code for NEON, the ARMv7 Advanced SIMD
+ Extension.
+
++config NEON_CACHE_BUG
++ bool "NEON L1 cache bug workaround (erratum 451034)"
++ depends on VFPv3
++ help
++ On Cortex-A8 r1p0 and r1p1, executing a NEON store with an integer
++ store in the store buffer, can cause a processor deadlock under
++ certain conditions.
++
++ See ARM Cortex-A8 Errata Notice (PR120-PRDC-008070) for full details.
++
++ Say Y to include a workaround.
++
++ WARNING: Even with this option enabled, userspace code can trigger
++ the deadlock. To safely run untrusted code, a different fix is
++ required.
++
+ endmenu
+
+ menu "Userspace binary formats"
+diff --git a/arch/arm/kernel/entry-common.S b/arch/arm/kernel/entry-common.S
+index 597ed00..e50094e 100644
+--- a/arch/arm/kernel/entry-common.S
++++ b/arch/arm/kernel/entry-common.S
+@@ -68,6 +68,10 @@ no_work_pending:
+ /* perform architecture specific actions before user return */
+ arch_ret_to_user r1, lr
+
++#ifdef CONFIG_NEON_CACHE_BUG
++ dmb
++#endif
++
+ @ slow_restore_user_regs
+ ldr r1, [sp, #S_PSR] @ get calling cpsr
+ ldr lr, [sp, #S_PC]! @ get pc
+diff --git a/include/asm-arm/vfpmacros.h b/include/asm-arm/vfpmacros.h
+index cccb389..c9d2976 100644
+--- a/include/asm-arm/vfpmacros.h
++++ b/include/asm-arm/vfpmacros.h
+@@ -32,6 +32,9 @@
+
+ @ write all the working registers out of the VFP
+ .macro VFPFSTMIA, base, tmp
++#ifdef CONFIG_NEON_CACHE_BUG
++ dmb
++#endif
+ #if __LINUX_ARM_ARCH__ < 6
+ STC p11, cr0, [\base],#33*4 @ FSTMIAX \base!, {d0-d15}
+ #else
diff --git a/packages/linux/linux-omap2_git.bb b/packages/linux/linux-omap2_git.bb
index 2cba2fe537..e7d3b95a08 100644
--- a/packages/linux/linux-omap2_git.bb
+++ b/packages/linux/linux-omap2_git.bb
@@ -5,8 +5,8 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-omap2-git/${MA
SRCREV = "d3b3ae0fe6c71641da19c8de466ec366d39847e3"
PV = "2.6.26"
-#PV = "2.6.25+2.6.26-rc9+${PR}+git${SRCREV}"
-PR = "r48"
+#PV = "2.6.26+2.6.27-rc1+${PR}+git${SRCREV}"
+PR = "r49"
SRC_URI = "git://source.mvista.com/git/linux-omap-2.6.git;protocol=git \
file://defconfig"
@@ -45,6 +45,7 @@ SRC_URI_append_beagleboard = " file://no-harry-potter.diff;patch=1 \
file://mru-clocks3.diff;patch=1 \
file://4bitmmc.diff;patch=1 \
file://400khz-i2c.diff;patch=1 \
+ file://no-cortex-deadlock.patch;patch=1 \
"
SRC_URI_append_omap3evm = " file://no-harry-potter.diff;patch=1 \
diff --git a/packages/mozilla/firefox-3.0/.mtn2git_empty b/packages/mozilla/firefox-3.0.1/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/mozilla/firefox-3.0/.mtn2git_empty
+++ b/packages/mozilla/firefox-3.0.1/.mtn2git_empty
diff --git a/packages/mozilla/firefox-3.0.1/0001-Remove-Werror-from-build.patch b/packages/mozilla/firefox-3.0.1/0001-Remove-Werror-from-build.patch
new file mode 100644
index 0000000000..8fe1087b4d
--- /dev/null
+++ b/packages/mozilla/firefox-3.0.1/0001-Remove-Werror-from-build.patch
@@ -0,0 +1,45 @@
+From 48a378ae647cbd6f8466bd0e8dbb04400bb175a8 Mon Sep 17 00:00:00 2001
+From: Eduardo Valentin <eduardo.valentin@openpossa.org>
+Date: Thu, 24 Jul 2008 16:05:09 -0400
+Subject: [PATCH 1/1] Remove -Werror from build
+
+Remove -Werror from build
+
+Signed-off-by: Eduardo Valentin <eduardo.valentin@openpossa.org>
+---
+ configure | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure b/configure
+index a2d84ab..402e70a 100755
+--- a/configure
++++ b/configure
+@@ -5344,7 +5344,7 @@ if test "$GNU_CC"; then
+ # Don't allow undefined symbols in libraries
+ DSO_LDOPTS="$DSO_LDOPTS -Wl,-z,defs"
+ fi
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ DSO_CFLAGS=''
+ DSO_PIC_CFLAGS='-fPIC'
+ _MOZ_RTTI_FLAGS_ON=${_COMPILER_PREFIX}-frtti
+@@ -6811,7 +6811,7 @@ EOF
+ IMPLIB='emximp -o'
+ FILTER='emxexp -o'
+ LDFLAGS='-Zmap'
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ MOZ_DEBUG_FLAGS="-g -fno-inline"
+ MOZ_OPTIMIZE_FLAGS="-O2"
+ MOZ_OPTIMIZE_LDFLAGS="-s -Zlinker /EXEPACK:2 -Zlinker /PACKCODE -Zlinker /PACKDATA"
+@@ -7048,7 +7048,7 @@ else
+ fi
+ rm -f conftest*
+ fi
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ MOZ_OPTIMIZE_FLAGS="-xO4"
+ MKSHLIB='$(CXX) $(CXXFLAGS) $(DSO_PIC_FLAGS) $(DSO_LDOPTS) -h $@ -o $@'
+ MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_FLAGS) -G -z muldefs -h $@ -o $@'
+--
+1.5.4.3
diff --git a/packages/mozilla/firefox-3.0.1/0002-Fix-security-cross-compile-cpu-detection-error.patch b/packages/mozilla/firefox-3.0.1/0002-Fix-security-cross-compile-cpu-detection-error.patch
new file mode 100644
index 0000000000..ce8d4d9948
--- /dev/null
+++ b/packages/mozilla/firefox-3.0.1/0002-Fix-security-cross-compile-cpu-detection-error.patch
@@ -0,0 +1,42 @@
+From 599b26141d493ff19633796ce5e19b00315d3821 Mon Sep 17 00:00:00 2001
+From: Eduardo Valentin <eduardo.valentin@openpossa.org>
+Date: Fri, 25 Jul 2008 11:20:02 -0400
+Subject: [PATCH 1/1] Fix security cross compile cpu detection error
+
+Fix security cross compile cpu detection error.
+Reference to bug 376279.
+
+Signed-off-by: Eduardo Valentin <eduardo.valentin@openpossa.org>
+---
+ security/coreconf/arch.mk | 2 ++
+ security/manager/Makefile.in | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/security/coreconf/arch.mk b/security/coreconf/arch.mk
+index fba38ff..28da32e 100644
+--- a/security/coreconf/arch.mk
++++ b/security/coreconf/arch.mk
+@@ -66,7 +66,9 @@ OS_ARCH := $(subst /,_,$(shell uname -s))
+ # Attempt to differentiate between sparc and x86 Solaris
+ #
+
++ifndef OE_TEST
+ OS_TEST := $(shell uname -m)
++endif
+ ifeq ($(OS_TEST),i86pc)
+ OS_RELEASE := $(shell uname -r)_$(OS_TEST)
+ else
+diff --git a/security/manager/Makefile.in b/security/manager/Makefile.in
+index 86119f7..86c09ca 100644
+--- a/security/manager/Makefile.in
++++ b/security/manager/Makefile.in
+@@ -240,6 +240,7 @@ DEFAULT_GMAKE_FLAGS += \
+ RC="$(RC) $(RCFLAGS)" \
+ OS_ARCH="$(OS_ARCH)" \
+ CPU_ARCH="$(TARGET_CPU)" \
++ OS_TEST="$(TARGET_CPU)" \
+ $(NULL)
+ SKIP_CHK=1
+ endif
+--
+1.5.4.3
diff --git a/packages/mozilla/firefox-3.0/010_FPU_IS_ARM_FPA_xslt.diff b/packages/mozilla/firefox-3.0.1/010_FPU_IS_ARM_FPA_xslt.diff
index 854100c4c3..854100c4c3 100644
--- a/packages/mozilla/firefox-3.0/010_FPU_IS_ARM_FPA_xslt.diff
+++ b/packages/mozilla/firefox-3.0.1/010_FPU_IS_ARM_FPA_xslt.diff
diff --git a/packages/mozilla/firefox-3.0/Bug339782.additional.fix.diff b/packages/mozilla/firefox-3.0.1/Bug339782.additional.fix.diff
index 0848e730d3..0848e730d3 100644
--- a/packages/mozilla/firefox-3.0/Bug339782.additional.fix.diff
+++ b/packages/mozilla/firefox-3.0.1/Bug339782.additional.fix.diff
diff --git a/packages/mozilla/firefox-3.0/Bug385583.nspr.jmp_buf.eabi.diff b/packages/mozilla/firefox-3.0.1/Bug385583.nspr.jmp_buf.eabi.diff
index 486440c30e..486440c30e 100644
--- a/packages/mozilla/firefox-3.0/Bug385583.nspr.jmp_buf.eabi.diff
+++ b/packages/mozilla/firefox-3.0.1/Bug385583.nspr.jmp_buf.eabi.diff
diff --git a/packages/mozilla/firefox-3.0/Bug405992.atomic.nspr.diff b/packages/mozilla/firefox-3.0.1/Bug405992.atomic.nspr.diff
index f54f916a6a..f54f916a6a 100644
--- a/packages/mozilla/firefox-3.0/Bug405992.atomic.nspr.diff
+++ b/packages/mozilla/firefox-3.0.1/Bug405992.atomic.nspr.diff
diff --git a/packages/mozilla/firefox-3.0/jemalloc-tls.patch b/packages/mozilla/firefox-3.0.1/jemalloc-tls.patch
index d1d740989e..d1d740989e 100644
--- a/packages/mozilla/firefox-3.0/jemalloc-tls.patch
+++ b/packages/mozilla/firefox-3.0.1/jemalloc-tls.patch
diff --git a/packages/mozilla/firefox-3.0/jsautocfg-dontoverwrite.patch b/packages/mozilla/firefox-3.0.1/jsautocfg-dontoverwrite.patch
index 39978cfd11..39978cfd11 100644
--- a/packages/mozilla/firefox-3.0/jsautocfg-dontoverwrite.patch
+++ b/packages/mozilla/firefox-3.0.1/jsautocfg-dontoverwrite.patch
diff --git a/packages/mozilla/firefox-3.0/linkage-problem.patch b/packages/mozilla/firefox-3.0.1/linkage-problem.patch
index 28bffd1e22..28bffd1e22 100644
--- a/packages/mozilla/firefox-3.0/linkage-problem.patch
+++ b/packages/mozilla/firefox-3.0.1/linkage-problem.patch
diff --git a/packages/mozilla/firefox-3.0/mozconfig b/packages/mozilla/firefox-3.0.1/mozconfig
index 6e85c5eda2..5001e588e9 100644
--- a/packages/mozilla/firefox-3.0/mozconfig
+++ b/packages/mozilla/firefox-3.0.1/mozconfig
@@ -18,7 +18,7 @@ ac_add_options --disable-accessibility
ac_add_options --disable-composer
#ac_add_options --enable-plaintext-editor-only
ac_add_options --disable-mailnews
-ac_add_options --disable-ldap
+ac_add_options --disable-ldap
#ac_add_options --disable-postscript
ac_add_options --disable-mathml
ac_add_options --disable-jsd
@@ -43,7 +43,7 @@ ac_add_options --disable-gnomeui
ac_add_options --enable-crypto
# build minimal set of protocol handlers
-ac_add_options --enable-necko-protocols=http,file,res,jar,ftp,about,viewsource
+ac_add_options --enable-necko-protocols=http,file,res,ftp,about,viewsource
# build minimal set of image decoders
ac_add_options --enable-image-decoders=png,gif,jpeg
@@ -59,3 +59,8 @@ ac_add_options --enable-optimize=-O1
# Use cairo from system
ac_add_options --enable-system-cairo
+# Disable jemalloc
+ac_add_options --disable-jemalloc
+
+# enable libxul
+ac_add_options --enable-libxul
diff --git a/packages/mozilla/firefox-3.0/random_to_urandom.diff b/packages/mozilla/firefox-3.0.1/random_to_urandom.diff
index f969752381..f969752381 100644
--- a/packages/mozilla/firefox-3.0/random_to_urandom.diff
+++ b/packages/mozilla/firefox-3.0.1/random_to_urandom.diff
diff --git a/packages/mozilla/firefox-3.0/security-cross.patch b/packages/mozilla/firefox-3.0.1/security-cross.patch
index 56c8d04a9e..56c8d04a9e 100644
--- a/packages/mozilla/firefox-3.0/security-cross.patch
+++ b/packages/mozilla/firefox-3.0.1/security-cross.patch
diff --git a/packages/mozilla/firefox.inc b/packages/mozilla/firefox.inc
index cff49e9542..7ad0c28db7 100644
--- a/packages/mozilla/firefox.inc
+++ b/packages/mozilla/firefox.inc
@@ -1,7 +1,5 @@
SRC_URI += "file://mozilla-firefox.png file://mozilla-firefox.desktop"
-PARALLEL_MAKE = ""
-
PACKAGES =+ "firefox-inspector"
FILES_firefox-inspector = " ${libdir}/firefox-${PV}/chrome/inspector* \
diff --git a/packages/mozilla/firefox_3.0.bb b/packages/mozilla/firefox_3.0.1.bb
index 1198344888..7952247322 100644
--- a/packages/mozilla/firefox_3.0.bb
+++ b/packages/mozilla/firefox_3.0.1.bb
@@ -1,7 +1,7 @@
DEPENDS += "cairo"
-PR = "r0"
+PR = "r2"
-SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/source/firefox-${PV}-source.tar.bz2 \
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
file://jsautocfg.h \
file://security-cross.patch;patch=1 \
file://jsautocfg-dontoverwrite.patch;patch=1 \
@@ -10,8 +10,9 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/source/fi
file://Bug405992.atomic.nspr.diff;patch=1 \
file://random_to_urandom.diff;patch=1 \
file://jemalloc-tls.patch;patch=1 \
- http://ftp.mozilla.org/pub/mozilla.org/js/js-1.7.0.tar.gz \
http://ftp.debian.org/debian/pool/main/i/iceweasel/iceweasel_3.0~rc2-2.diff.gz;patch=1 \
+ file://0001-Remove-Werror-from-build.patch;patch=1 \
+ file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
"
S = "${WORKDIR}/mozilla"
@@ -21,9 +22,7 @@ S = "${WORKDIR}/mozilla"
inherit mozilla
require firefox.inc
-do_unpack2() {
- cp -pPr ${WORKDIR}/js/src* ${S}/js/
-}
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
do_compile_prepend() {
cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
@@ -43,4 +42,3 @@ do_stage() {
sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
}
-addtask unpack2 after do_unpack before do_patch
diff --git a/packages/mythtv/mythtv-0.21/no-cortex-deadlock.patch b/packages/mythtv/mythtv-0.21/no-cortex-deadlock.patch
new file mode 100644
index 0000000000..4e93af196a
--- /dev/null
+++ b/packages/mythtv/mythtv-0.21/no-cortex-deadlock.patch
@@ -0,0 +1,115 @@
+From: Mans Rullgard <mans@mansr.com>
+Date: Tue, 29 Jul 2008 21:13:14 +0000 (+0100)
+Subject: ARM: work around Cortex-A8 erratum 451034
+X-Git-Url: http://git.mansr.com/?p=ffmpeg.mru;a=commitdiff_plain;h=c6bbb0c33f6f681b8265a43f8744735de5a9d45e
+
+ARM: work around Cortex-A8 erratum 451034
+
+On Cortex-A8 r1p0 and r1p1, executing a NEON store with an integer
+store in the store buffer, can cause a processor deadlock under
+certain conditions.
+
+A DMB instruction at the start of every NEON function ensures that
+the integer store buffer is always empty before executing any NEON
+store, thus avoiding the deadlock condition.
+
+See ARM Cortex-A8 Errata Notice (PR120-PRDC-008070) for full details.
+---
+
+diff --git b/mythtv/libs/libavcodec/armv4l/dsputil_neon.c b/mythtv/libs/libavcodec/armv4l/dsputil_neon.c
+index fa0602d..4fbadfc 100644
+--- b/mythtv/libs/libavcodec/armv4l/dsputil_neon.c
++++ b/mythtv/libs/libavcodec/armv4l/dsputil_neon.c
+@@ -28,6 +28,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ int h, int x, int y);
+
+ #define PUT_PIXELS_16_X2(vhadd) \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "vld1.64 {d0,d1,d2}, [%[p]], %[line_size] \n\t" \
+ "vld1.64 {d4,d5,d6}, [%[p]], %[line_size] \n\t" \
+@@ -46,6 +47,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ "lsl %[l2], %[line_size], #1 \n\t" \
+ "vld1.64 {d0,d1}, [%[p0]], %[l2] \n\t" \
+ "vld1.64 {d2,d3}, [%[p1]], %[l2] \n\t" \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "subs %[h], %[h], #2 \n\t" \
+ vhadd".u8 q2, q0, q1 \n\t" \
+@@ -69,6 +71,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ "vaddl.u8 q10, d1, d3 \n\t" \
+ "vaddl.u8 q9, d4, d6 \n\t" \
+ "vaddl.u8 q11, d5, d7 \n\t" \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "subs %[h], %[h], #2 \n\t" \
+ "vld1.64 {d0,d1,d2}, [%[p0]], %[l2] \n\t" \
+@@ -98,6 +101,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ "bgt 1b \n\t"
+
+ #define PUT_PIXELS_8_X2(vhadd) \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "vld1.64 {d0,d1}, [%[p]], %[line_size] \n\t" \
+ "vld1.64 {d2,d3}, [%[p]], %[line_size] \n\t" \
+@@ -116,6 +120,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ "lsl %[l2], %[line_size], #1 \n\t" \
+ "vld1.64 {d0}, [%[p0]], %[l2] \n\t" \
+ "vld1.64 {d1}, [%[p1]], %[l2] \n\t" \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "subs %[h], %[h], #2 \n\t" \
+ vhadd".u8 d4, d0, d1 \n\t" \
+@@ -137,6 +142,7 @@ extern void ff_put_h264_chroma_mc8_neon(uint8_t *dst, uint8_t *src, int stride,
+ "vext.8 d6, d2, d3, #1 \n\t" \
+ "vaddl.u8 q8, d0, d4 \n\t" \
+ "vaddl.u8 q9, d2, d6 \n\t" \
++ "dmb \n\t" \
+ "1: \n\t" \
+ "subs %[h], %[h], #2 \n\t" \
+ "vld1.64 {d0,d1}, [%[p0]], %[l2] \n\t" \
+@@ -161,6 +167,7 @@ static void put_pixels16_neon(uint8_t *block, const uint8_t *pixels,
+ int line_size, int h)
+ {
+ asm volatile(
++ "dmb \n\t"
+ "1: \n\t"
+ "vld1.64 {d0,d1}, [%[pixels]], %[line_size] \n\t"
+ "vld1.64 {d2,d3}, [%[pixels]], %[line_size] \n\t"
+@@ -224,6 +231,7 @@ static void put_pixels8_neon(uint8_t *block, const uint8_t *pixels,
+ int line_size, int h)
+ {
+ asm volatile(
++ "dmb \n\t"
+ "1: \n\t"
+ "vld1.64 {d0}, [%[p]], %[line_size] \n\t"
+ "vld1.64 {d1}, [%[p]], %[line_size] \n\t"
+diff --git b/mythtv/libs/libavcodec/armv4l/h264dsp_neon.S b/mythtv/libs/libavcodec/armv4l/h264dsp_neon.S
+index a766867..8171ee2 100644
+--- b/mythtv/libs/libavcodec/armv4l/h264dsp_neon.S
++++ b/mythtv/libs/libavcodec/armv4l/h264dsp_neon.S
+@@ -40,6 +40,8 @@ ff_put_h264_chroma_mc8_neon:
+ sub r4, r4, r5, lsl #3
+ add r4, r4, #64
+
++ dmb
++
+ beq 2f
+
+ add r5, r1, r2
+diff --git b/mythtv/libs/libavcodec/armv4l/simple_idct_neon.S b/mythtv/libs/libavcodec/armv4l/simple_idct_neon.S
+index 943e04f..abda6b2 100644
+--- b/mythtv/libs/libavcodec/armv4l/simple_idct_neon.S
++++ b/mythtv/libs/libavcodec/armv4l/simple_idct_neon.S
+@@ -307,9 +307,10 @@ idct_col4_st8:
+ const: .short W1, W2, W3, W4, W5, W6, W7, W4c
+
+ .macro idct_start data
++ push {v1-v3, lr}
+ pld [\data]
+ pld [\data, #64]
+- push {v1-v3, lr}
++ dmb
+ vpush {d8-d15}
+ adr a4, const
+ vld1.64 {d0,d1}, [a4,:128]
diff --git a/packages/mythtv/mythtv_0.21.bb b/packages/mythtv/mythtv_0.21.bb
index eb9d98c674..fabe788ba6 100644
--- a/packages/mythtv/mythtv_0.21.bb
+++ b/packages/mythtv/mythtv_0.21.bb
@@ -2,7 +2,7 @@ require mythtv.inc
inherit qmake qt3x11
-PR = "${SRCREV}+r2"
+PR = "${SRCREV}+r3"
REALPV = "0.21"
SRCREV = "17789"
@@ -10,6 +10,7 @@ SRC_URI = "svn://svn.mythtv.org/svn/branches/release-0-21-fixes;module=mythtv;pr
SRC_URI += " \
file://ffmpeg-arm-update.diff;patch=1 \
+ file://no-cortex-deadlock.patch;patch=1;pnum=2 \
file://configure.patch;patch=1 \
file://configh \
file://configmak \