summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/bd-neon.conf2
-rw-r--r--packages/tea/.mtn2git_empty0
-rw-r--r--packages/tea/tea/.mtn2git_empty0
-rw-r--r--packages/tea/tea/move-endif.patch20
-rw-r--r--packages/tea/tea_17.3.5.bb11
5 files changed, 33 insertions, 0 deletions
diff --git a/conf/machine/bd-neon.conf b/conf/machine/bd-neon.conf
index fe7ff724fd..532193a567 100644
--- a/conf/machine/bd-neon.conf
+++ b/conf/machine/bd-neon.conf
@@ -24,6 +24,8 @@ MACHINE_FEATURES = "kernel26 touchscreen apm alsa usbgadget screen uboot"
#
PREFERRED_PROVIDER_virtual/kernel = "linux"
PERFERRED_VERSION_linux = "2.6.22"
+KERNEL_IMAGETYPE = "uImage"
+UBOOT_ENTRYPOINT = "a0008000"
MODUTILS = "26"
XSERVER = "xserver-kdrive-fbdev"
diff --git a/packages/tea/.mtn2git_empty b/packages/tea/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tea/.mtn2git_empty
diff --git a/packages/tea/tea/.mtn2git_empty b/packages/tea/tea/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tea/tea/.mtn2git_empty
diff --git a/packages/tea/tea/move-endif.patch b/packages/tea/tea/move-endif.patch
new file mode 100644
index 0000000000..0fabee887c
--- /dev/null
+++ b/packages/tea/tea/move-endif.patch
@@ -0,0 +1,20 @@
+--- src/callbacks.c~ 2007-10-23 18:43:04.000000000 +0200
++++ src/callbacks.c 2007-10-23 18:43:04.000000000 +0200
+@@ -5609,8 +5609,6 @@
+
+ #if defined (HAVE_LIBASPELL) || defined (ENCHANT_SUPPORTED)
+ GList *l = get_suggestions_list (p->prefix);
+-#endif
+-
+ if (l)
+ {
+ build_menu_wudata_from_glist (l, mni_suggestions, on_mni_suggestion_select, temp_text_part);
+@@ -5620,6 +5618,8 @@
+ }
+
+ glist_strings_free (l);
++#endif
++
+ }
+
+
diff --git a/packages/tea/tea_17.3.5.bb b/packages/tea/tea_17.3.5.bb
new file mode 100644
index 0000000000..7adf2a5136
--- /dev/null
+++ b/packages/tea/tea_17.3.5.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Tea - a GTK based text editor tith highlighting and a lot of processing features"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gtksourceview"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tea-editor/${P}.tar.bz2 \
+ file://move-endif.patch;patch=1;pnum=0"
+
+EXTRA_OECONF = "--enable-legacy"