summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/angstrom-2007.1.conf6
-rwxr-xr-xcontrib/angstrom/build-release.sh4
-rw-r--r--packages/apache2/apache2-native_2.2.3.bb4
-rw-r--r--packages/images/minimal-gpe-image.bb4
-rw-r--r--packages/qmake/qmake2-native_2.10a.bb4
-rw-r--r--packages/spandsp/spandsp_0.0.3.bb8
6 files changed, 14 insertions, 16 deletions
diff --git a/conf/distro/angstrom-2007.1.conf b/conf/distro/angstrom-2007.1.conf
index 2860f55854..954f4b5e9c 100644
--- a/conf/distro/angstrom-2007.1.conf
+++ b/conf/distro/angstrom-2007.1.conf
@@ -6,9 +6,9 @@
#@MAINTAINER: Michael 'Mickey' Lauer <mickey@Vanille.de>
#@--------------------------------------------------------------------
-#DISTRO_VERSION = "2007.9"
-DISTRO_VERSION = "2007.9-test-${DATE}"
-DISTRO_REVISION = "47"
+# The release will the 2007.12
+DISTRO_VERSION = "2007.11RC1"
+DISTRO_REVISION = "48"
require conf/distro/include/sane-srcdates.inc
require conf/distro/include/sane-srcrevs.inc
diff --git a/contrib/angstrom/build-release.sh b/contrib/angstrom/build-release.sh
index 79bb97e0de..57f854b145 100755
--- a/contrib/angstrom/build-release.sh
+++ b/contrib/angstrom/build-release.sh
@@ -69,7 +69,6 @@ for machine in spitz
do
BUILD_MACHINE=$machine
BUILD_TARGETS="x11-gpe-image x11-pimlico-image x11-office-image"
- BUILD_CLEAN="qmake2-native"
do_build
done
@@ -78,7 +77,6 @@ for machine in fic-gta01 a780
do
BUILD_MACHINE=$machine
BUILD_TARGETS="minimal-openmoko-image openmoko-image"
- BUILD_CLEAN="qmake2-native"
do_build
done
@@ -87,7 +85,7 @@ for machine in ep93xx a780 efika collie ixp4xxbe
do
BUILD_MACHINE=$machine
BUILD_TARGETS="meta-angstrom-2007"
- do_build
+ do_build
done
#cross toolchain
diff --git a/packages/apache2/apache2-native_2.2.3.bb b/packages/apache2/apache2-native_2.2.3.bb
index b58aa41756..d5fb0cff21 100644
--- a/packages/apache2/apache2-native_2.2.3.bb
+++ b/packages/apache2/apache2-native_2.2.3.bb
@@ -1,9 +1,9 @@
SECTION = "net"
DEPENDS = "expat pcre"
-inherit native
+inherit cross
-PR="r5"
+PR="r6"
SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2"
S = "${WORKDIR}/httpd-${PV}"
diff --git a/packages/images/minimal-gpe-image.bb b/packages/images/minimal-gpe-image.bb
index 356070f5f8..3f475567d2 100644
--- a/packages/images/minimal-gpe-image.bb
+++ b/packages/images/minimal-gpe-image.bb
@@ -6,11 +6,13 @@ XSERVER ?= "xserver-kdrive-fbdev"
export IMAGE_BASENAME = "minimalist-gpe-image"
+PR = "r1"
+
DEPENDS = "task-boot"
IMAGE_INSTALL = "\
${XSERVER} \
task-boot \
- gpe-session-scripts gpe-login \
+ gpe-dm gpe-session-scripts gpe-login \
matchbox-wm \
angstrom-feed-configs \
ipkg \
diff --git a/packages/qmake/qmake2-native_2.10a.bb b/packages/qmake/qmake2-native_2.10a.bb
index 84df0ef732..d9071193a9 100644
--- a/packages/qmake/qmake2-native_2.10a.bb
+++ b/packages/qmake/qmake2-native_2.10a.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
QTVER = "qtopia-core-opensource-src-4.3.2"
@@ -15,7 +15,7 @@ S = "${WORKDIR}/${QTVER}"
# we need the real target system here
CROSS_SYS := "${TARGET_SYS}"
-inherit autotools native
+inherit autotools cross
export QTDIR = "${S}"
EXTRA_OEMAKE = "-e"
diff --git a/packages/spandsp/spandsp_0.0.3.bb b/packages/spandsp/spandsp_0.0.3.bb
index 26702f998b..97a1428398 100644
--- a/packages/spandsp/spandsp_0.0.3.bb
+++ b/packages/spandsp/spandsp_0.0.3.bb
@@ -1,13 +1,11 @@
DESCRIPTION = "A library of many DSP functions for telephony."
HOMEPAGE = "http://www.soft-switch.org"
-DEPENDS = "tiff libxml2"
SECTION = "voip"
LICENSE = "GPL"
-PV = "0.0.3"
-PSUBV = "pre27"
-PR = "r0"
+DEPENDS = "tiff libxml2"
+PR = "r1"
-SRC_URI = "http://www.soft-switch.org/downloads/snapshots/spandsp/spandsp-20070123.tar.gz"
+SRC_URI = "http://www.soft-switch.org/downloads/spandsp/spandsp-${PV}.tgz"
inherit autotools