summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/base.bbclass2
-rw-r--r--classes/sanity.bbclass2
-rw-r--r--conf/checksums.ini10
-rw-r--r--conf/distro/include/sane-srcdates.inc1
-rw-r--r--packages/esound/esound_0.2.36.bb2
-rw-r--r--packages/gpe-conf/gpe-conf_0.2.5.bb2
-rw-r--r--packages/gpe-dm/files/Xserver-cxk.patch11
-rw-r--r--packages/gpe-dm/files/collie-suspend-hack.patch19
-rw-r--r--packages/gpe-dm/files/mnci.patch27
-rw-r--r--packages/gpe-dm/files/remove-X-scripts.patch14
-rw-r--r--packages/gpe-dm/files/source-xsession-scripts.patch27
-rw-r--r--packages/gpe-dm/gpe-dm_0.50.bb13
-rw-r--r--packages/gpe-edit/gpe-edit_0.40.bb8
-rw-r--r--packages/gpe-session-scripts/gpe-session-scripts_0.67.bb2
-rw-r--r--packages/gtk-webcore/files/build_silence.patch32
-rw-r--r--packages/gtk-webcore/osb-nrcore_svn.bb3
-rw-r--r--packages/libmimedir/libmimedir_svn.bb27
-rw-r--r--packages/libmrss/files/.mtn2git_empty0
-rw-r--r--packages/libmrss/files/atom-changes.patch17
-rw-r--r--packages/libmrss/files/bump-version.patch16
-rw-r--r--packages/libmrss/files/fix-memleaks.patch17
-rw-r--r--packages/libmrss/files/fix_atom_date_locale.patch121
-rw-r--r--packages/libmrss/libmrss_0.17.bb9
-rw-r--r--packages/libnxml/libnxml_0.16.bb4
-rw-r--r--packages/matchbox-common/matchbox_0.9.1.bb1
-rw-r--r--packages/matchbox-panel/matchbox-panel_0.9.3.bb2
-rw-r--r--packages/matchbox2/matchbox-panel-2_svn.bb9
-rw-r--r--packages/monotone/monotone-6_0.34.bb52
-rw-r--r--packages/openmoko-base/files/session2
-rw-r--r--packages/openmoko-base/openmoko-session_svn.bb2
-rw-r--r--packages/pulseaudio/pulseaudio_0.9.5.bb3
31 files changed, 340 insertions, 117 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 2ea5251609..6f8196cf80 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -54,7 +54,7 @@ def base_chk_file(parser, pn, pv, src_uri, localpath):
raise Exception("Executing md5sum failed")
try:
- shapipe = os.popen('shasum -a256 -p ' + localpath)
+ shapipe = os.popen('sha256sum -b ' + localpath)
shadata = (shapipe.readline().split() or [ "" ])[0]
shapipe.close()
except OSError:
diff --git a/classes/sanity.bbclass b/classes/sanity.bbclass
index 958ab91fa6..f38644b6cb 100644
--- a/classes/sanity.bbclass
+++ b/classes/sanity.bbclass
@@ -86,7 +86,7 @@ def check_sanity(e):
if not check_app_exists('${BUILD_PREFIX}g++', e.data):
missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
- required_utilities = "patch diffstat texi2html makeinfo cvs svn git bzip2 tar gzip gawk"
+ required_utilities = "patch diffstat texi2html makeinfo cvs svn git bzip2 tar gzip gawk sha256sum md5sum"
for util in required_utilities.split():
if not check_app_exists( util, e.data ):
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 81b92ad069..f73fc47571 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1,3 +1,11 @@
-[file-native-4.20-ftp://ftp.astron.com/pub/file/file-4.20.tar.gz]
+[ftp://ftp.astron.com/pub/file/file-4.20.tar.gz]
md5=402bdb26356791bd5d277099adacc006
sha256=c0810fb3ddb6cb73c9ff045965e542af6e3eaa7f2995b3037181766d26d5e6e7
+
+[http://www2.autistici.org/bakunin/libmrss/libmrss-0.17.tar.gz]
+md5=28d0e78d736748e67f25ad99456f10c3
+sha256=9bccf1240ce9317510eb860e7fcd387be2ddc73adc14451d679a6a7358383772
+
+[http://www2.autistici.org/bakunin/libnxml/libnxml-0.16.tar.gz]
+md5=85b6a42a9e17a23c01b2f2ed0ece0563
+sha256=6154872089834b0ffd34e92612d07e2d1ccec572698bd861da752eeeaab7ca78
diff --git a/conf/distro/include/sane-srcdates.inc b/conf/distro/include/sane-srcdates.inc
index eef4c4d06f..fdac29e398 100644
--- a/conf/distro/include/sane-srcdates.inc
+++ b/conf/distro/include/sane-srcdates.inc
@@ -43,7 +43,6 @@ SRCDATE_zaurusd ?= "20060628"
# GPE
SRCDATE_dasher-gpe ?= "20060814"
SRCDATE_rosetta ?= "20060804"
-SRCDATE_libmimedir ?= "20060804"
SRCDATE_gpesyncd ?= "20061128"
# GNOME
diff --git a/packages/esound/esound_0.2.36.bb b/packages/esound/esound_0.2.36.bb
index a260882bae..1cf99ac90a 100644
--- a/packages/esound/esound_0.2.36.bb
+++ b/packages/esound/esound_0.2.36.bb
@@ -3,6 +3,8 @@ SECTION = "gpe/base"
LICENSE = "GPL"
DEPENDS = "audiofile"
+PR = "r1"
+
inherit gnome binconfig
SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.36.tar.bz2"
diff --git a/packages/gpe-conf/gpe-conf_0.2.5.bb b/packages/gpe-conf/gpe-conf_0.2.5.bb
index 6cbddeedd0..6bd96204eb 100644
--- a/packages/gpe-conf/gpe-conf_0.2.5.bb
+++ b/packages/gpe-conf/gpe-conf_0.2.5.bb
@@ -10,7 +10,7 @@ RDEPENDS_gpe-conf-panel = "gpe-conf"
RPROVIDES_${PN} += " bl"
RCONFLICTS_${PN} = "bl"
-PR = "r2"
+PR = "r3"
GPE_TARBALL_SUFFIX = "bz2"
diff --git a/packages/gpe-dm/files/Xserver-cxk.patch b/packages/gpe-dm/files/Xserver-cxk.patch
deleted file mode 100644
index 89187a0e31..0000000000
--- a/packages/gpe-dm/files/Xserver-cxk.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gpe-dm-0.47/Xserver~ 2005-07-29 11:58:59.000000000 -0700
-+++ gpe-dm-0.47/Xserver 2005-08-01 11:20:42.000000000 -0700
-@@ -62,6 +62,8 @@
- ;;
- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi")
- ARGS="$ARGS -rgba rgb" ;;
-+ "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
-+ ARGS="$ARGS -rgba rgb -screen 640x480@270" ;;
- "Simpad")
- ARGS="$ARGS -rgba rgb" ;;
- "Generic OMAP1510/1610/1710")
diff --git a/packages/gpe-dm/files/collie-suspend-hack.patch b/packages/gpe-dm/files/collie-suspend-hack.patch
deleted file mode 100644
index 94fc287f4e..0000000000
--- a/packages/gpe-dm/files/collie-suspend-hack.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -urNd ../gpe-dm-0.44-r1/gpe-dm-0.44/Xserver gpe-dm-0.44/Xserver
---- ../gpe-dm-0.44-r1/gpe-dm-0.44/Xserver 2005-02-20 17:39:31 +00:00
-+++ gpe-dm-0.44/Xserver 2005-04-01 21:47:12 +01:00
-@@ -45,8 +45,14 @@
- "HP iPAQ H5400" | "HP iPAQ H2200")
- ARGS="$ARGS -rgba rgb" ;;
- # both 'Sharp-Collie' and just 'Collie' have been reported
-- *Collie | *Poodle)
-+ *Poodle)
- ARGS="$ARGS -screen 320x240@270 -rgba vrgb" ;;
-+ *Collie)
-+ ARGS="$ARGS -screen 320x240@270 -rgba vrgb"
-+ # Horrible hack required to enable resuming after suspend
-+ rm -f /dev/apm_bios
-+ killall -9 apmd
-+ ;;
- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi")
- ARGS="$ARGS -rgba rgb" ;;
- "Simpad")
diff --git a/packages/gpe-dm/files/mnci.patch b/packages/gpe-dm/files/mnci.patch
deleted file mode 100644
index 8cd7358f36..0000000000
--- a/packages/gpe-dm/files/mnci.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- gpe-dm-0.44/gpe-dm.init~ramses
-+++ gpe-dm-0.44/gpe-dm.init
-@@ -19,7 +19,7 @@
- stop)
- echo "Stopping GPE display manager: gpe-dm"
- killproc /usr/bin/gpe-dm
-- dd if=/dev/zero of=/dev/fb0 2>/dev/null
-+ dd if=/dev/zero of=/dev/fb0 2>/dev/null || dd if=/dev/zero of=/dev/fb/0 2>/dev/null
- ;;
-
- *)
---- gpe-dm-0.44/Xserver~ramses
-+++ gpe-dm-0.44/Xserver
-@@ -44,6 +44,8 @@
- ARGS="$ARGS -screen 320x240@270 -rgba vbgr" ;;
- "HP iPAQ H5400" | "HP iPAQ H2200")
- ARGS="$ARGS -rgba rgb" ;;
-+ "Ramses")
-+ ARGS="$ARGS -screen 320x240@90 -rgba vrgb vt2" ;;
- # both 'Sharp-Collie' and just 'Collie' have been reported
- *Poodle)
- ARGS="$ARGS -screen 320x240@270 -rgba vrgb" ;;
diff --git a/packages/gpe-dm/files/remove-X-scripts.patch b/packages/gpe-dm/files/remove-X-scripts.patch
deleted file mode 100644
index b3c85be788..0000000000
--- a/packages/gpe-dm/files/remove-X-scripts.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Nur gpe-dm-0.47~/Makefile gpe-dm-0.47/Makefile
---- gpe-dm-0.47~/Makefile 2005-08-19 18:27:54.000000000 -0700
-+++ gpe-dm-0.47/Makefile 2005-08-19 18:28:37.000000000 -0700
-@@ -31,10 +31,6 @@
- install -d $(DESTDIR)/etc/init.d
- install -d $(DESTDIR)/etc/rc2.d
- install gpe-dm.init $(DESTDIR)/etc/init.d/gpe-dm
-- install -d $(DESTDIR)/etc/X11
-- install Xsession $(DESTDIR)/etc/X11/Xsession
-- install Xinit $(DESTDIR)/etc/X11/Xinit
-- install Xserver $(DESTDIR)/etc/X11/Xserver
-
- clean: clean-po
- rm -f gpe-dm gpe-dm.o
diff --git a/packages/gpe-dm/files/source-xsession-scripts.patch b/packages/gpe-dm/files/source-xsession-scripts.patch
deleted file mode 100644
index c92f230618..0000000000
--- a/packages/gpe-dm/files/source-xsession-scripts.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- gpe-dm-0.43/Xsession.old 2005-02-23 11:39:23.000000000 +0000
-+++ gpe-dm-0.43/Xsession 2005-02-23 12:21:28.011314968 +0000
-@@ -25,4 +25,23 @@
- SYSSESSIONDIR=/etc/X11/Xsession.d
- fi
-
--exec run-parts $SYSSESSIONDIR
-+# Use run-parts to source every file in the session directory; we source
-+# instead of executing so that the variables and functions defined above
-+# are available to the scripts, and so that they can pass variables to each
-+# other.
-+
-+# Can't use run-parts like this, busybox doesn't support it. Use ls instead
-+#SESSIONFILES=$(run-parts --list $SYSSESSIONDIR)
-+
-+SESSIONFILES=`ls -X $SYSSESSIONDIR`
-+if [ -n "$SESSIONFILES" ]; then
-+ for SESSIONFILE in $SESSIONFILES; do
-+ # Test if script is executable first before sourcing it
-+ if [ -x "$SYSSESSIONDIR/$SESSIONFILE" ]; then
-+ . $SYSSESSIONDIR/$SESSIONFILE
-+ fi
-+ done
-+fi
-+
-+exit 0
-+
diff --git a/packages/gpe-dm/gpe-dm_0.50.bb b/packages/gpe-dm/gpe-dm_0.50.bb
new file mode 100644
index 0000000000..d9ac68c257
--- /dev/null
+++ b/packages/gpe-dm/gpe-dm_0.50.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPE Display Manager"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xserver-common"
+RDEPENDS_${PN} += "procps xserver-common"
+
+GPE_TARBALL_SUFFIX ?= "bz2"
+
+inherit gpe autotools update-rc.d
+
+INITSCRIPT_NAME = "gpe-dm"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/packages/gpe-edit/gpe-edit_0.40.bb b/packages/gpe-edit/gpe-edit_0.40.bb
new file mode 100644
index 0000000000..a3e9a8b71a
--- /dev/null
+++ b/packages/gpe-edit/gpe-edit_0.40.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget"
+
+GPE_TARBALL_SUFFIX ?= "bz2"
+
+inherit gpe autotools
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
index 4d68bc11a0..2c17d99bb8 100644
--- a/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
+++ b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
@@ -11,7 +11,7 @@ DEPENDS = "matchbox-wm matchbox-panel xtscal gpe-question matchbox-applet-inputm
SRC_URI += "file://matchbox-session \
file://disable-composite.xsettings"
-PR = "r8"
+PR = "r9"
#apply a patch to set the fontsize for bigdpi (200+) devices to 5
SRC_URI_append_hx4700 = " file://highdpifontfix.patch;patch=1"
diff --git a/packages/gtk-webcore/files/build_silence.patch b/packages/gtk-webcore/files/build_silence.patch
new file mode 100644
index 0000000000..bcef3954ee
--- /dev/null
+++ b/packages/gtk-webcore/files/build_silence.patch
@@ -0,0 +1,32 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 46)
++++ configure.in (working copy)
+@@ -134,9 +134,9 @@
+ AC_SUBST(LIBCURL_LIBS) #needed by the osb-nrcore.pc.in
+
+
+-CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++"
++CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++ -DLOG_DISABLED"
+
+-CPPFLAGS="$CPPFLAGS -include \"\$(top_srcdir)/WebCorePrefix.h\" $PACKAGE_CFLAGS $X_CFLAGS $JSCORE_CFLAGS $DEFINES"
++CPPFLAGS="$CPPFLAGS -include \"\$(top_srcdir)/WebCorePrefix.h\" $PACKAGE_CFLAGS $X_CFLAGS $JSCORE_CFLAGS $DEFINES -DLOG_DISABLED"
+ LDFLAGS="$LDFLAGS $PACKAGE_LIBS $X_LIBS $JSCORE_LIBS \
+ -nodefaultlibs -lgcc -lc"
+
+Index: kwiq/KWQEvent.cpp
+===================================================================
+--- kwiq/KWQEvent.cpp (revision 46)
++++ kwiq/KWQEvent.cpp (working copy)
+@@ -759,10 +759,10 @@
+ #if 0
+ if (state & GDK_MOD1_MASK)
+ qstate |= Qt::AltButton;
+-#endif
+
+ if (state & GDK_META_MASK)
+ qstate |= Qt::MetaButton;
++#endif
+
+ if (isKeypadEvent(event))
+ qstate |= Qt::Keypad;
diff --git a/packages/gtk-webcore/osb-nrcore_svn.bb b/packages/gtk-webcore/osb-nrcore_svn.bb
index fefb4e8283..b7f9d069f1 100644
--- a/packages/gtk-webcore/osb-nrcore_svn.bb
+++ b/packages/gtk-webcore/osb-nrcore_svn.bb
@@ -6,7 +6,8 @@ PV = "0.5.0+svn${SRCDATE}"
PR = "r0"
SRC_URI = "svn://gtk-webcore.svn.sourceforge.net/svnroot/gtk-webcore/trunk;module=NRCore;proto=https \
- file://gcc4-fno-threadsafe-statics-NRCore.patch;patch=1"
+ file://gcc4-fno-threadsafe-statics-NRCore.patch;patch=1 \
+ file://build_silence.patch;patch=0"
S = "${WORKDIR}/NRCore"
diff --git a/packages/libmimedir/libmimedir_svn.bb b/packages/libmimedir/libmimedir_svn.bb
new file mode 100644
index 0000000000..c640f13e8f
--- /dev/null
+++ b/packages/libmimedir/libmimedir_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "RFC2425 MIME Directory Profile library, supporting vCard and iCalendar"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "intltool-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.4.1+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/libmimedir"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "libmimedir-utils"
+
+FILES_libmimedir-utils = "${bindir}"
+
diff --git a/packages/libmrss/files/.mtn2git_empty b/packages/libmrss/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libmrss/files/.mtn2git_empty
diff --git a/packages/libmrss/files/atom-changes.patch b/packages/libmrss/files/atom-changes.patch
new file mode 100644
index 0000000000..42f74d00f2
--- /dev/null
+++ b/packages/libmrss/files/atom-changes.patch
@@ -0,0 +1,17 @@
+Make sure to always set a pubDate
+
+Index: libmrss-0.17/src/mrss_parser.c
+===================================================================
+--- libmrss-0.17.orig/src/mrss_parser.c 2007-03-22 19:40:54.000000000 +0100
++++ libmrss-0.17/src/mrss_parser.c 2007-03-22 19:44:15.000000000 +0100
+@@ -270,6 +270,10 @@
+ && data->version == MRSS_VERSION_ATOM_1_0)
+ item->pubDate =
+ __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
++ else if (!strcmp(cur->value, "updated" ) && !item->pubDate
++ && data->version == MRSS_VERSION_ATOM_1_0)
++ item->pubDate =
++ __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
+
+ /* issued -> pubDate (Atom 0.3) */
+ else if (!strcmp (cur->value, "issued") && !item->pubDate)
diff --git a/packages/libmrss/files/bump-version.patch b/packages/libmrss/files/bump-version.patch
new file mode 100644
index 0000000000..2eeb6931c8
--- /dev/null
+++ b/packages/libmrss/files/bump-version.patch
@@ -0,0 +1,16 @@
+Bump the version info, specially as I changed the struct in a binary
+incompatible way.
+
+Index: libmrss-0.17/src/Makefile.am
+===================================================================
+--- libmrss-0.17.orig/src/Makefile.am 2007-04-01 16:43:58.000000000 +0200
++++ libmrss-0.17/src/Makefile.am 2007-04-01 16:44:10.000000000 +0200
+@@ -10,7 +10,7 @@
+ mrss_options.c \
+ mrss_search.c
+
+-libmrss_la_LDFLAGS = -version-info 0:16:0
++libmrss_la_LDFLAGS = -version-info 0:17:0
+
+ EXTRA_DIST = mrss.h mrss_internal.h
+
diff --git a/packages/libmrss/files/fix-memleaks.patch b/packages/libmrss/files/fix-memleaks.patch
new file mode 100644
index 0000000000..c88570c72e
--- /dev/null
+++ b/packages/libmrss/files/fix-memleaks.patch
@@ -0,0 +1,17 @@
+Index: libmrss-0.17/src/mrss_parser.c
+===================================================================
+--- libmrss-0.17.orig/src/mrss_parser.c 2007-04-01 22:23:22.000000000 +0200
++++ libmrss-0.17/src/mrss_parser.c 2007-04-01 22:23:42.000000000 +0200
+@@ -186,10 +186,10 @@
+ cat->allocated = 1;
+ cat->category = c;
+
+- if (!(c = nxmle_find_attribute (cur, "scheme", NULL)))
++ if (c = nxmle_find_attribute (cur, "scheme", NULL))
+ cat->domain = c;
+
+- if (!(c = nxmle_find_attribute (cur, "label", NULL)))
++ if (c = nxmle_find_attribute (cur, "label", NULL))
+ cat->label = c;
+
+ if (!*category)
diff --git a/packages/libmrss/files/fix_atom_date_locale.patch b/packages/libmrss/files/fix_atom_date_locale.patch
new file mode 100644
index 0000000000..111a4859cd
--- /dev/null
+++ b/packages/libmrss/files/fix_atom_date_locale.patch
@@ -0,0 +1,121 @@
+The Atom date formating code tries to create a RFC822 date. This date
+requires to use the C locale for the date (for weekday-names and month-names).
+
+This patch uses new POSIX functionality to create a C locale and strftime_l
+to create a right RFC822 date.
+
+Index: libmrss-0.17/src/mrss.h
+===================================================================
+--- libmrss-0.17.orig/src/mrss.h 2007-02-02 12:23:49.000000000 +0100
++++ libmrss-0.17/src/mrss.h 2007-04-01 19:46:41.000000000 +0200
+@@ -364,6 +364,9 @@
+ mrss_element_t element;
+ int allocated;
+
++ /** For internal use only: */
++ void* c_locale;
++
+ /* Data: */
+
+ char *file;
+Index: libmrss-0.17/src/mrss_free.c
+===================================================================
+--- libmrss-0.17.orig/src/mrss_free.c 2007-02-02 12:47:46.000000000 +0100
++++ libmrss-0.17/src/mrss_free.c 2007-04-01 19:46:41.000000000 +0200
+@@ -22,9 +22,14 @@
+ # error Use configure; make; make install
+ #endif
+
++#define _GNU_SOURCE
++
+ #include "mrss.h"
+ #include "mrss_internal.h"
+
++#include <locale.h>
++
++
+ static void __mrss_free_channel (mrss_t * mrss);
+ static void __mrss_free_category (mrss_category_t * category);
+ static void __mrss_free_hour (mrss_hour_t * hour);
+@@ -202,6 +207,9 @@
+ __mrss_free_item ((mrss_item_t *) old);
+ }
+
++ if (mrss->c_locale)
++ freelocale (mrss->c_locale);
++
+ if (mrss->allocated)
+ free (mrss);
+ }
+Index: libmrss-0.17/src/mrss_parser.c
+===================================================================
+--- libmrss-0.17.orig/src/mrss_parser.c 2007-04-01 19:46:41.000000000 +0200
++++ libmrss-0.17/src/mrss_parser.c 2007-04-01 20:38:06.000000000 +0200
+@@ -22,9 +22,13 @@
+ # error Use configure; make; make install
+ #endif
+
++#define _GNU_SOURCE
++
+ #include "mrss.h"
+ #include "mrss_internal.h"
+
++#include <locale.h>
++
+ static void
+ __mrss_parse_tag_insert (mrss_tag_t ** where, mrss_tag_t * what)
+ {
+@@ -133,7 +137,7 @@
+ }
+
+ static char *
+-__mrss_atom_prepare_date (char *datestr)
++__mrss_atom_prepare_date (mrss_t *data, char *datestr)
+ {
+ char *ret = NULL;
+ if (datestr)
+@@ -150,8 +154,13 @@
+ stm.tm_year -= 1900;
+ char datebuf[256];
+ free (datestr);
+- strftime (datebuf, sizeof (datebuf), "%a, %d %b %Y %H:%M:%S %z",
+- &stm);
++
++ if (!data->c_locale) {
++ data->c_locale = newlocale(LC_ALL_MASK,"C",NULL);
++ }
++
++ strftime_l (datebuf, sizeof (datebuf), "%a, %d %b %Y %H:%M:%S %z",
++ &stm, data->c_locale);
+ ret = strdup (datebuf);
+ }
+ }
+@@ -269,16 +278,16 @@
+ else if (!strcmp (cur->value, "published") && !item->pubDate
+ && data->version == MRSS_VERSION_ATOM_1_0)
+ item->pubDate =
+- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
++ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
+ else if (!strcmp(cur->value, "updated" ) && !item->pubDate
+ && data->version == MRSS_VERSION_ATOM_1_0)
+ item->pubDate =
+- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
++ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
+
+ /* issued -> pubDate (Atom 0.3) */
+ else if (!strcmp (cur->value, "issued") && !item->pubDate)
+ item->pubDate =
+- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
++ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
+
+ /* id -> guid */
+ else if (!strcmp (cur->value, "id") && !item->guid
+@@ -701,7 +710,7 @@
+ /* updated -> lastBuildDate */
+ else if (!strcmp (cur->value, "updated"))
+ data->lastBuildDate =
+- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
++ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
+
+ /* author -> managingeditor */
+ else if (!strcmp (cur->value, "author"))
diff --git a/packages/libmrss/libmrss_0.17.bb b/packages/libmrss/libmrss_0.17.bb
index c2170fa09a..0d23a2b54f 100644
--- a/packages/libmrss/libmrss_0.17.bb
+++ b/packages/libmrss/libmrss_0.17.bb
@@ -1,12 +1,17 @@
DESCRIPTION = "mRSS is a C library for parsing, writing and creating RSS (0.91, 0.92, 1.0, 2.0) files or streams"
LICENSE = "LGPL"
-HOMEPAGE = "http://www2.autistici.org/bakunin//codes.php"
+HOMEPAGE = "http://www2.autistici.org/bakunin/codes.php"
DEPENDS = "libnxml curl"
+PR = "r1"
inherit autotools pkgconfig
-SRC_URI = "http://www2.autistici.org/bakunin//libmrss/libmrss-${PV}.tar.gz;md5sum=28d0e78d736748e67f25ad99456f10c3"
+SRC_URI = "http://www2.autistici.org/bakunin/libmrss/libmrss-${PV}.tar.gz \
+ file://atom-changes.patch;patch=1 \
+ file://fix_atom_date_locale.patch;patch=1 \
+ file://fix-memleaks.patch;patch=1 \
+ file://bump-version.patch;patch=1 "
do_stage() {
autotools_stage_all
diff --git a/packages/libnxml/libnxml_0.16.bb b/packages/libnxml/libnxml_0.16.bb
index c798ff3405..6f836d226d 100644
--- a/packages/libnxml/libnxml_0.16.bb
+++ b/packages/libnxml/libnxml_0.16.bb
@@ -1,4 +1,4 @@
-HOMEPAGE = "http://www2.autistici.org/bakunin//codes.php"
+HOMEPAGE = "http://www2.autistici.org/bakunin/codes.php"
DESCRIPTION = "nXML is a C library for parsing, writing and creating XML 1.0 and 1.1 files or streams. It supports utf-8, utf-16be and utf-16le, ucs-4 (1234, 4321, 2143, 2312)"
LICENSE = "LGPL"
@@ -6,7 +6,7 @@ DEPENDS = "curl"
inherit autotools pkgconfig
-SRC_URI = "http://www2.autistici.org/bakunin//libnxml/libnxml-${PV}.tar.gz;md5sum=85b6a42a9e17a23c01b2f2ed0ece0563"
+SRC_URI = "http://www2.autistici.org/bakunin/libnxml/libnxml-${PV}.tar.gz"
do_stage() {
diff --git a/packages/matchbox-common/matchbox_0.9.1.bb b/packages/matchbox-common/matchbox_0.9.1.bb
index 203c705267..cda90dfb50 100644
--- a/packages/matchbox-common/matchbox_0.9.1.bb
+++ b/packages/matchbox-common/matchbox_0.9.1.bb
@@ -3,5 +3,6 @@ LICENSE = "GPL"
RDEPENDS = "matchbox-common matchbox-wm matchbox-panel matchbox-desktop"
SECTION = "x11/wm"
PACKAGES = "${PN}"
+PR = "r1"
ALLOW_EMPTY = "1"
diff --git a/packages/matchbox-panel/matchbox-panel_0.9.3.bb b/packages/matchbox-panel/matchbox-panel_0.9.3.bb
index bed04323a7..c6b0ee305e 100644
--- a/packages/matchbox-panel/matchbox-panel_0.9.3.bb
+++ b/packages/matchbox-panel/matchbox-panel_0.9.3.bb
@@ -1,4 +1,4 @@
require matchbox-panel.inc
-PR="r2"
+PR="r3"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
file://mb-applet-battery-repaint-093.patch;patch=1"
diff --git a/packages/matchbox2/matchbox-panel-2_svn.bb b/packages/matchbox2/matchbox-panel-2_svn.bb
index d166e78a3a..be2e7f39cf 100644
--- a/packages/matchbox2/matchbox-panel-2_svn.bb
+++ b/packages/matchbox2/matchbox-panel-2_svn.bb
@@ -3,10 +3,8 @@ LICENSE = "GPL"
SECTION = "x11/panels"
DEPENDS = "gtk+"
-RCONFLICTS_${PN} = "matchbox-panel"
-
PV = "0.1+svn${SRCDATE}"
-PR = "r5"
+PR = "r6"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
S = "${WORKDIR}/${PN}"
@@ -15,6 +13,11 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--disable-startup-notification --disable-libnotify"
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-panel ${D}${bindir}/matchbox-panel-2
+}
+
do_stage() {
autotools_stage_all
}
diff --git a/packages/monotone/monotone-6_0.34.bb b/packages/monotone/monotone-6_0.34.bb
new file mode 100644
index 0000000000..0442e0232e
--- /dev/null
+++ b/packages/monotone/monotone-6_0.34.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Monotone is a distributed Source Control System"
+HOMEPAGE = "http://www.monotone.ca/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "boost"
+
+PROVIDES = "monotone"
+RPROVIDES = "monotone"
+
+S = "${WORKDIR}/monotone-${PV}"
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ --with-bundled-lua --with-bundled-sqlite"
+
+inherit autotools
+
+# Release 0.22 reveals bugs in g++ for thumb (g++ generates
+# relocations which the linker cannot represent)
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+PR = "r0"
+
+SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
+ file://txt2c-cross-post-0.22.patch;patch=1 \
+ file://uclibc.database.hh.stdarg.patch;patch=1 \
+ file://configure.ac-no-sync-with-stdio-0.31.patch;patch=1 \
+ "
+do_compile_append() {
+ touch testsuite
+}
+
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -pPR tests ${D}${tsd}/tests
+ rm ${D}/home/monotone/monotone-6/tests/diff_a_binary_file/binary
+}
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone/${PN}"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
+
diff --git a/packages/openmoko-base/files/session b/packages/openmoko-base/files/session
index 6f4fe6356e..d93225d624 100644
--- a/packages/openmoko-base/files/session
+++ b/packages/openmoko-base/files/session
@@ -8,7 +8,7 @@ matchbox-desktop --icon-size 96 \
--titlefont sans-20:bold \
--bg img-tiled:/usr/share/themes/openmoko-standard/gtk-2.0/mokopanedwindow-upper-enclosing.png &
# --bg col-gradient-vertical:#000000,#aaaaaa &
-matchbox-panel --start-applets=openmoko-mainmenu,showdesktop,systray,windowselector --end-applets=openmoko-panel-demo-simple,openmoko-panel-battery,openmoko-panel-clock,openmoko-panel-gsm &
+matchbox-panel-2 --start-applets=openmoko-mainmenu,showdesktop,systray,windowselector --end-applets=openmoko-panel-demo-simple,openmoko-panel-battery,openmoko-panel-clock,openmoko-panel-gsm &
#start some old-style panel plugins to get a keyboard and battery status
mbinputmgr &
diff --git a/packages/openmoko-base/openmoko-session_svn.bb b/packages/openmoko-base/openmoko-session_svn.bb
index c352cb7d91..a359e539d3 100644
--- a/packages/openmoko-base/openmoko-session_svn.bb
+++ b/packages/openmoko-base/openmoko-session_svn.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Matchbox session files for OpenMoko"
SECTION = "openmoko/base"
-RDEPENDS = "matchbox gconf matchbox-applet-startup-monitor gtk-theme-clearlooks"
+RDEPENDS = "matchbox-panel-2 matchbox-wm gconf matchbox-applet-startup-monitor gtk-theme-clearlooks"
PV = "0.0+svn${SRCDATE}"
PR = "r8"
diff --git a/packages/pulseaudio/pulseaudio_0.9.5.bb b/packages/pulseaudio/pulseaudio_0.9.5.bb
index 54ebb76cd9..35fd9a8342 100644
--- a/packages/pulseaudio/pulseaudio_0.9.5.bb
+++ b/packages/pulseaudio/pulseaudio_0.9.5.bb
@@ -8,9 +8,8 @@ DEPENDS = "liboil avahi libsamplerate0 libsndfile1 libtool"
# optional
DEPENDS += "alsa-lib"
-RPROVIDES = "esound esd"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://0pointer.de/lennart/projects/pulseaudio/pulseaudio-${PV}.tar.gz"