summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/distutils-base.bbclass6
-rw-r--r--packages/python/python-dbus/.mtn2git_empty0
-rw-r--r--packages/python/python-dbus/allow-older-autotools.patch27
-rw-r--r--packages/python/python-dbus_0.81.1.bb (renamed from packages/python/python-dbus_0.71.bb)7
4 files changed, 35 insertions, 5 deletions
diff --git a/classes/distutils-base.bbclass b/classes/distutils-base.bbclass
index db006b8c77..993ad7964e 100644
--- a/classes/distutils-base.bbclass
+++ b/classes/distutils-base.bbclass
@@ -7,9 +7,11 @@ def python_dir(d):
staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
PYTHON_DIR = "${@python_dir(d)}"
-FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/.debug"
+FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
+FILES_${PN}-dbg = "${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/.debug \
+ ${libdir}/${PYTHON_DIR}/site-packages/.debug"
diff --git a/packages/python/python-dbus/.mtn2git_empty b/packages/python/python-dbus/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-dbus/.mtn2git_empty
diff --git a/packages/python/python-dbus/allow-older-autotools.patch b/packages/python/python-dbus/allow-older-autotools.patch
new file mode 100644
index 0000000000..7595f70e5d
--- /dev/null
+++ b/packages/python/python-dbus/allow-older-autotools.patch
@@ -0,0 +1,27 @@
+#
+# so it looks like dbus-python really doesn't make use of any 2.59c features
+# Signed-Off: mickey@openmoko.org
+#
+Index: dbus-python-0.81.1/configure.ac
+===================================================================
+--- dbus-python-0.81.1.orig/configure.ac 2007-06-04 13:17:10.000000000 +0000
++++ dbus-python-0.81.1/configure.ac 2007-06-11 06:57:20.000000000 +0000
+@@ -1,5 +1,5 @@
+ -*- mode: m4 -*-
+-AC_PREREQ(2.59c)
++AC_PREREQ(2.59)
+
+ dnl If not 1, append datestamp to the version number
+ m4_define(dbus_python_released, 1)
+Index: dbus-python-0.81.1/Makefile.am
+===================================================================
+--- dbus-python-0.81.1.orig/Makefile.am 2007-05-09 09:44:40.000000000 +0000
++++ dbus-python-0.81.1/Makefile.am 2007-06-11 06:59:23.000000000 +0000
+@@ -38,6 +38,7 @@
+
+ TXT_RSTDOCS = doc/tutorial.txt doc/API_CHANGES.txt doc/HACKING.txt
+ RSTDOCS = README NEWS TODO
++docdir=foo
+ dist_doc_DATA = $(TXT_RSTDOCS) $(RSTDOCS)
+
+ maintainer-update-website: _maintainer-update-apidocs \
diff --git a/packages/python/python-dbus_0.71.bb b/packages/python/python-dbus_0.81.1.bb
index 2ef0ffa8dd..82b9c390ca 100644
--- a/packages/python/python-dbus_0.71.bb
+++ b/packages/python/python-dbus_0.81.1.bb
@@ -3,11 +3,12 @@ SECTION = "devel/python"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
-RDEPENDS = "dbus"
+RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
PR = "ml0"
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+ file://allow-older-autotools.patch;patch=1"
S = "${WORKDIR}/dbus-python-${PV}"
-inherit distutils
+inherit distutils-base autotools