summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/gnome-bluetooth_git.bb11
-rw-r--r--recipes/openmax/libomxil-bellagio_0.9.1.bb15
3 files changed, 26 insertions, 4 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 71a90247ad..331b97aba9 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -14226,6 +14226,10 @@ sha256=07128710a699b453dcd7b92e33f2aa8dcbbfe0a657d33040803cdaf0997e442c
md5=6d6b6a75bc8751a7421b5e739c53ef6e
sha256=07128710a699b453dcd7b92e33f2aa8dcbbfe0a657d33040803cdaf0997e442c
+[http://downloads.sourceforge.net/omxil/libomxil-bellagio-0.9.1.tar.gz]
+md5=757371e21e4f3653ce4d12d3ba0be1e0
+sha256=9a0864cd442c43e5b69072dc0617b56252bc933fce26f6bfd6d47909287a353a
+
[http://download.ofb.net/liboop/liboop-1.0.tar.bz2]
md5=88fc8decf99fd75d2af40e0a005fa0d3
sha256=4a973d28466fde0b689099192f9bcd081b129d90b3c5a9815e5ade73052cf8d2
diff --git a/recipes/gnome/gnome-bluetooth_git.bb b/recipes/gnome/gnome-bluetooth_git.bb
index 23c4ca92ac..29c98139ea 100644
--- a/recipes/gnome/gnome-bluetooth_git.bb
+++ b/recipes/gnome/gnome-bluetooth_git.bb
@@ -11,12 +11,12 @@ SRC_URI = "git://git.gnome.org/gnome-bluetooth;protocol=git \
S = "${WORKDIR}/git"
-SRCREV = "93fd8de2cc717b96ad719ab2fb5ed38b8a0fc707"
-PV = "2.27.5"
-PR = "r2"
+SRCREV = "59efa1c06153cd5bdaff64f7efca791c11c77f2f"
+PV = "2.27.8"
+PR = "r0"
PR_append = "+gitr${SRCREV}"
-DEPENDS = "obexd gconf-dbus gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
+DEPENDS = "geoclue obexd gconf-dbus gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
RRECOMMENDS_${PN} += "obexd"
RCONFLICTS_${PN} = "bluez-gnome"
@@ -26,3 +26,6 @@ do_configure_prepend() {
echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
}
+# Todo: automagic plugin splitting
+
+FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug"
diff --git a/recipes/openmax/libomxil-bellagio_0.9.1.bb b/recipes/openmax/libomxil-bellagio_0.9.1.bb
new file mode 100644
index 0000000000..2934da7d87
--- /dev/null
+++ b/recipes/openmax/libomxil-bellagio_0.9.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "OpenMAX Integration Layer (IL) is a standard API to access Multimedia Components on mobile platforms. It has been defined by the Khronos group."
+LICENSE = "LGPLv2"
+DEPENDS = "alsa-lib ffmpeg \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/omxil/${PN}-${PV}.tar.gz"
+
+inherit autotools_stage
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${libdir}/bellagio/*.so ${libdir}/bellagio/*.la"
+FILES_${PN}-dev += "${libdir}/bellagio/*.a"
+FILES_${PN}-dbg += "${libdir}/bellagio/.debug"
+