summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/gdb/gdb-cross.inc25
-rw-r--r--packages/gdb/gdb-cross_6.3.bb24
-rw-r--r--packages/gdb/gdb-cross_6.4.bb24
-rw-r--r--packages/gdb/gdb-cross_6.6.bb25
4 files changed, 30 insertions, 68 deletions
diff --git a/packages/gdb/gdb-cross.inc b/packages/gdb/gdb-cross.inc
new file mode 100644
index 0000000000..33ca380464
--- /dev/null
+++ b/packages/gdb/gdb-cross.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "gdb - GNU debugger"
+HOMEPAGE = "http://www.gnu.org/software/gdb/"
+LICENSE="GPL"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses-native"
+
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz"
+
+S = "${WORKDIR}/gdb-${PV}"
+
+inherit autotools sdk
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CXX_FOR_BUILD = "${BUILD_CXX}"
+export CPP_FOR_BUILD = "${BUILD_CPP}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
+
+EXTRA_OECONF = "--with-curses --with-readline"
diff --git a/packages/gdb/gdb-cross_6.3.bb b/packages/gdb/gdb-cross_6.3.bb
index 5dd5cf5ac5..5419872bc9 100644
--- a/packages/gdb/gdb-cross_6.3.bb
+++ b/packages/gdb/gdb-cross_6.3.bb
@@ -1,30 +1,10 @@
-require gdb.inc
-
-SECTION = "base"
-DEPENDS = "ncurses-native"
-
-inherit autotools sdk
+require gdb-cross.inc
PR = "r1"
-S = "${WORKDIR}/gdb-${PV}"
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install-makefile.patch;patch=1 \
+SRC_URI += "file://sim-install-makefile.patch;patch=1 \
file://sim-install-makefile-common.patch;patch=1"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-
-EXTRA_OECONF = "--with-curses --with-readline"
-
do_configure () {
# override this function to avoid the autoconf/automake/aclocal/autoheader
# calls for now
diff --git a/packages/gdb/gdb-cross_6.4.bb b/packages/gdb/gdb-cross_6.4.bb
index 3a108d568b..2f93e6b28e 100644
--- a/packages/gdb/gdb-cross_6.4.bb
+++ b/packages/gdb/gdb-cross_6.4.bb
@@ -1,26 +1,4 @@
-require gdb.inc
-
-SECTION = "base"
-DEPENDS = "ncurses-native"
-
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz"
-
-S = "${WORKDIR}/gdb-${PV}"
-
-inherit autotools sdk
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-
-EXTRA_OECONF = "--with-curses --with-readline"
+require gdb-cross.inc
do_configure () {
# override this function to avoid the autoconf/automake/aclocal/autoheader
diff --git a/packages/gdb/gdb-cross_6.6.bb b/packages/gdb/gdb-cross_6.6.bb
index 03d9cda12c..f32ee32a5d 100644
--- a/packages/gdb/gdb-cross_6.6.bb
+++ b/packages/gdb/gdb-cross_6.6.bb
@@ -1,29 +1,8 @@
-LICENSE = "GPL"
-DESCRIPTION = "gdb - GNU debugger"
-SECTION = "base"
-PRIORITY = "optional"
-DEPENDS = "ncurses-native"
-
-inherit autotools sdk
+require gdb-cross.inc
PR = "r1"
-S = "${WORKDIR}/gdb-${PV}"
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install-makefile.patch;patch=1"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-
-EXTRA_OECONF = "--with-curses --with-readline"
+SRC_URI += "file://sim-install-makefile.patch;patch=1"
do_configure () {
# override this function to avoid the autoconf/automake/aclocal/autoheader