summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/perl/libxml-dom-perl-native_1.44.bb6
-rw-r--r--recipes/perl/libxml-dom-perl_1.44.bb18
-rw-r--r--recipes/perl/libxml-regexp-perl-native_0.03.bb5
-rw-r--r--recipes/perl/libxml-regexp-perl_0.03.bb10
5 files changed, 47 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 2c39e11b04..49aab9136f 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1398,6 +1398,10 @@ sha256=3b732ed179dd34c17d1ba17867b60a36f20d82a3f0eca7b084fcb5396aa2b30c
md5=4dbdbe9a85c8f7f98dd0ee015a3c7b4f
sha256=3b732ed179dd34c17d1ba17867b60a36f20d82a3f0eca7b084fcb5396aa2b30c
+[http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-DOM-1.44.tar.gz]
+md5=1ec2032a06e5762984f7a332c199c205
+sha256=f6af32c74c84b3b173eca9baac521a0f9b030c9a0395fcafd4235a84d8ad0ae4
+
[http://search.cpan.org/CPAN/authors/id/P/PA/PAJAS/XML-LibXML-1.70.tar.gz]
md5=33d4294f708e20c298cfe534d1166844
sha256=53e6cf06772ba9d85055dc6e4488dbd876d2376e48ef3578fa73246ee98b3ba0
@@ -1410,6 +1414,10 @@ sha256=55386de7bf78f67ad2b9ef664a578db66ee53f512a28eb067cd2303f5e23d740
md5=1b868962b658bd87e1563ecd56498ded
sha256=9fd529867402456bd826fe0e5588d35b3a2e27e586a2fd838d1352b71c2ed73f
+[http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-RegExp-0.03.tar.gz]
+md5=5826b24e0d05714e25c2bb04e1f1c09b
+sha256=4608bd4aed51d6f31a1a77796bc42f7ddf9700fe9b33c86a6b75ccb6a9cf6abe
+
[http://www.cpan.org/modules/by-module/XML/XML-Simple-2.18.tar.gz]
md5=593aa8001e5c301cdcdb4bb3b63abc33
sha256=a54967c188cda3e20f496c83be4de3f1740eeaa83c0380712ecd969ad8766826
diff --git a/recipes/perl/libxml-dom-perl-native_1.44.bb b/recipes/perl/libxml-dom-perl-native_1.44.bb
new file mode 100644
index 0000000000..98d050d02f
--- /dev/null
+++ b/recipes/perl/libxml-dom-perl-native_1.44.bb
@@ -0,0 +1,6 @@
+SECTION = "libs"
+
+require libxml-dom-perl_${PV}.bb
+
+inherit native
+
diff --git a/recipes/perl/libxml-dom-perl_1.44.bb b/recipes/perl/libxml-dom-perl_1.44.bb
new file mode 100644
index 0000000000..82ed697a5b
--- /dev/null
+++ b/recipes/perl/libxml-dom-perl_1.44.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "XML::DOM - A perl module for building DOM Level 1 compliant document structures"
+SECTION = "libs"
+LICENSE = "unknown"
+
+RDEPENDS += "libxml-parser-perl-native libxml-regexp-perl-native \
+ libhtml-parser-perl-native libhtml-tagset-perl-native \
+ liburi-perl-native libwww-perl-native"
+
+RDEPENDS += "libxml-parser-perl libxml-regexp-perl \
+ libhtml-parser-perl libhtml-tagset-perl liburi-perl libwww-perl"
+
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-DOM-${PV}.tar.gz"
+
+S = "${WORKDIR}/XML-DOM-${PV}"
+
+inherit cpan
diff --git a/recipes/perl/libxml-regexp-perl-native_0.03.bb b/recipes/perl/libxml-regexp-perl-native_0.03.bb
new file mode 100644
index 0000000000..29fc89fe47
--- /dev/null
+++ b/recipes/perl/libxml-regexp-perl-native_0.03.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require libxml-regexp-perl_${PV}.bb
diff --git a/recipes/perl/libxml-regexp-perl_0.03.bb b/recipes/perl/libxml-regexp-perl_0.03.bb
new file mode 100644
index 0000000000..fd9cb64be5
--- /dev/null
+++ b/recipes/perl/libxml-regexp-perl_0.03.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "XML::RegExp - Regular expressions for XML tokens"
+SECTION = "libs"
+LICENSE = "unknown"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-RegExp-${PV}.tar.gz"
+
+S = "${WORKDIR}/XML-RegExp-${PV}"
+
+inherit cpan