summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.16/copypage-xscale.patch21
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.16.bb5
-rw-r--r--packages/pvrusb2-mci/pvrusb2-mci-20060326/.mtn2git_empty0
-rw-r--r--packages/pvrusb2-mci/pvrusb2-mci-20060326/Makefile.patch25
-rw-r--r--packages/pvrusb2-mci/pvrusb2-mci_20060326.bb31
5 files changed, 80 insertions, 2 deletions
diff --git a/packages/linux/ixp4xx-kernel/2.6.16/copypage-xscale.patch b/packages/linux/ixp4xx-kernel/2.6.16/copypage-xscale.patch
new file mode 100644
index 0000000000..b73d219708
--- /dev/null
+++ b/packages/linux/ixp4xx-kernel/2.6.16/copypage-xscale.patch
@@ -0,0 +1,21 @@
+*** linux-2.6.16/arch/arm/mm/copypage-xscale.c- Mon Mar 27 19:10:25 2006
+--- linux-2.6.16/arch/arm/mm/copypage-xscale.c Sun Mar 26 19:32:53 2006
+***************
+*** 15,20 ****
+--- 15,21 ----
+ */
+ #include <linux/init.h>
+ #include <linux/mm.h>
++ #include <linux/module.h>
+
+ #include <asm/page.h>
+ #include <asm/pgtable.h>
+***************
+*** 129,131 ****
+--- 130,135 ----
+ .cpu_clear_user_page = xscale_mc_clear_user_page,
+ .cpu_copy_user_page = xscale_mc_copy_user_page,
+ };
++
++ EXPORT_SYMBOL(xscale_mc_clear_user_page);
++ EXPORT_SYMBOL(xscale_mc_copy_user_page);
diff --git a/packages/linux/ixp4xx-kernel_2.6.16.bb b/packages/linux/ixp4xx-kernel_2.6.16.bb
index 7c19cc9b1d..ba9a2522f7 100644
--- a/packages/linux/ixp4xx-kernel_2.6.16.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.16.bb
@@ -8,7 +8,7 @@ PR_CONFIG = "1"
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches
# applied to the kernel.
-PR = "r0.${PR_CONFIG}"
+PR = "r1.${PR_CONFIG}"
include ixp4xx-kernel.inc
@@ -17,8 +17,9 @@ include ixp4xx-kernel.inc
# IXP4XX_PATCHES - full list of patches to apply
IXP4XX_PATCHES = ""
-IXP4XX_PATCHES += "file://patch-2.6.16-rc6-ide1;patch=1"
+IXP4XX_PATCHES += "file://patch-2.6.16-rc4-ide2;patch=1"
IXP4XX_PATCHES += "file://leds-class.patch;patch=1"
+IXP4XX_PATCHES += "file://copypage-xscale.patch;patch=1"
# IXP4XX_PATCHES += "file://06-remove-extraversion.patch;patch=1"
IXP4XX_PATCHES += "file://10-ixp4xx-fix-irq.patch;patch=1"
IXP4XX_PATCHES += "file://11-mtdpart-redboot-config-byteswap.patch;patch=1"
diff --git a/packages/pvrusb2-mci/pvrusb2-mci-20060326/.mtn2git_empty b/packages/pvrusb2-mci/pvrusb2-mci-20060326/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pvrusb2-mci/pvrusb2-mci-20060326/.mtn2git_empty
diff --git a/packages/pvrusb2-mci/pvrusb2-mci-20060326/Makefile.patch b/packages/pvrusb2-mci/pvrusb2-mci-20060326/Makefile.patch
new file mode 100644
index 0000000000..29b1267177
--- /dev/null
+++ b/packages/pvrusb2-mci/pvrusb2-mci-20060326/Makefile.patch
@@ -0,0 +1,25 @@
+*** driver/Makefile- Tue Feb 28 21:05:41 2006
+--- driver/Makefile Tue Feb 28 21:07:15 2006
+***************
+*** 45,54 ****
+ M:=$(shell pwd)
+
+ modules modules_install clean:
+! $(MAKE) INSTALL_MOD_DIR=$(INSTALL_MOD_DIR) -C $(KDIR) M=$(M) CONFIG_VIDEO_PVRUSB2=m $@
+
+ install:
+! $(MAKE) INSTALL_MOD_DIR=$(INSTALL_MOD_DIR) -C $(KDIR) M=$(M) CONFIG_VIDEO_PVRUSB2=m modules_install
+
+ else
+
+--- 45,54 ----
+ M:=$(shell pwd)
+
+ modules modules_install clean:
+! $(MAKE) INSTALL_MOD_DIR=$(INSTALL_MOD_DIR) -C $(KDIR) CFLAGS="$(CFLAGS)" M=$(M) CONFIG_VIDEO_PVRUSB2=m $@
+
+ install:
+! $(MAKE) INSTALL_MOD_DIR=$(INSTALL_MOD_DIR) -C $(KDIR) CFLAGS="$(CFLAGS)" M=$(M) CONFIG_VIDEO_PVRUSB2=m modules_install
+
+ else
+
diff --git a/packages/pvrusb2-mci/pvrusb2-mci_20060326.bb b/packages/pvrusb2-mci/pvrusb2-mci_20060326.bb
new file mode 100644
index 0000000000..98b5765064
--- /dev/null
+++ b/packages/pvrusb2-mci/pvrusb2-mci_20060326.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Driver for the Hauppauge WinTV PVR USB2"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "eFfeM <fransmeulenbroeks at yahoo dot com>"
+LICENSE = "GPL"
+PR = "r0"
+RRECOMMENDS = "kernel-module-tveeprom kernel-module-tuner kernel-module-msp3400 kernel-module-saa7115 kernel-module-tda9887"
+
+SRC_URI = "http://www.isely.net/downloads/pvrusb2-mci-${PV}.tar.bz2 \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/pvrusb2-mci-${PV}/driver"
+
+inherit module
+
+CFLAGS = "'-I${KERNEL_SOURCE}/include' \
+ '-I${KERNEL_SOURCE}/drivers/media/video' \
+ '-D__LINUX_ARM_ARCH__=5'"
+
+EXTRA_OEMAKE = "'V=1' 'CFLAGS=${CFLAGS}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}' \
+ 'KDIR=${STAGING_KERNEL_DIR}'"
+
+export TARGET_LDFLAGS = "-L${STAGING_DIR}/${TARGET_SYS}/lib \
+ -rpath-link ${STAGING_DIR}/${TARGET_SYS}/lib"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}