summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/openmoko.conf13
-rw-r--r--packages/alsa/alsa-lib_1.0.13.bb2
-rw-r--r--packages/alsa/alsa-plugins_1.0.14.bb20
-rw-r--r--packages/gstreamer/gst-meta-base_0.10.bb7
-rw-r--r--packages/gstreamer/gst-plugin-pulse_0.9.4.bb28
5 files changed, 61 insertions, 9 deletions
diff --git a/conf/distro/openmoko.conf b/conf/distro/openmoko.conf
index c438da25d9..e4a1518ed0 100644
--- a/conf/distro/openmoko.conf
+++ b/conf/distro/openmoko.conf
@@ -12,7 +12,7 @@ require conf/distro/include/openmoko-srcdate-now.inc
#
DISTRO = "openmoko"
DISTRO_NAME = "OpenMoko"
-DISTRO_VERSION = ".dev-snapshot-${DATE}"
+DISTRO_VERSION = "P1-August-Snapshot-${DATE}"
#DISTRO_TYPE = "release"
DISTRO_TYPE = "debug"
@@ -23,7 +23,10 @@ CVS_TARBALL_STASH = "http://downloads.openmoko.org/sources/"
PREMIRRORS = "(ftp|http)://.*/.*/ http://downloads.openmoko.org/sources/"
FEED_URIS = "\
- all##http://buildhost.openmoko.org/tmp/deploy/ipk/all \
- armv4t##http://buildhost.openmoko.org/tmp/deploy/ipk/armv4t \
- fic-gta01##http://buildhost.openmoko.org/tmp/deploy/ipk/fic-gta01"
-
+ snapshot-all##http://buildhost.openmoko.org/snapshots/2007.08/ipk/all \
+ snapshot-armv4t##http://buildhost.openmoko.org/snapshots/2007.08/ipk/armv4t \
+ snapshot-fic-gta01##http://buildhost.openmoko.org/snapshots/2007.08/ipk/fic-gta01 \
+ \
+ updates-all##http://buildhost.openmoko.org/OM2007.2/tmp/deploy/glibc/ipk/all \
+ updates-armv4t##http://buildhost.openmoko.org/OM2007.2/tmp/deploy/glibc/ipk/armv4t \
+ updates-fic-gta01##http://buildhost.openmoko.org/OM2007.2/tmp/deploy/glibc/fic-gta01 "
diff --git a/packages/alsa/alsa-lib_1.0.13.bb b/packages/alsa/alsa-lib_1.0.13.bb
index 78df6dfe02..860ef11f18 100644
--- a/packages/alsa/alsa-lib_1.0.13.bb
+++ b/packages/alsa/alsa-lib_1.0.13.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Alsa sound library"
HOMEPAGE = "http://www.alsa-project.org"
SECTION = "libs/multimedia"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
# configure.in sets -D__arm__ on the command line for any arm system
# (not just those with the ARM instruction set), this should be removed,
diff --git a/packages/alsa/alsa-plugins_1.0.14.bb b/packages/alsa/alsa-plugins_1.0.14.bb
new file mode 100644
index 0000000000..b17a3265e8
--- /dev/null
+++ b/packages/alsa/alsa-plugins_1.0.14.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ALSA Plugins"
+HOMEPAGE = "http://www.alsa-project.org"
+SECTION = "multimedia/alsa/plugins"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib pulseaudio"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/plugins/alsa-plugins-${PV}.tar.bz2"
+
+inherit autotools
+
+PACKAGES_DYNAMIC = "libasound-module*"
+
+python populate_packages_prepend() {
+ plugindir = bb.data.expand('${libdir}/alsa-lib/', d)
+ do_split_packages(d, plugindir, '^libasound_module_(.*)\.so$', 'libasound-module-%s', 'Alsa plugin for %s', extra_depends='' )
+}
+
+FILES_${PN}-dev += "${libdir}/alsa-lib/libasound*.a ${libdir}/alsa-lib/libasound*.la"
+FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"
diff --git a/packages/gstreamer/gst-meta-base_0.10.bb b/packages/gstreamer/gst-meta-base_0.10.bb
index 182790bdea..fbf36b94b0 100644
--- a/packages/gstreamer/gst-meta-base_0.10.bb
+++ b/packages/gstreamer/gst-meta-base_0.10.bb
@@ -1,8 +1,8 @@
-# Copyright (C) 2006,2007 OpenedHand LTD
+# Based on its sibling on Poky which is copyright (C) 2006,2007 OpenedHand LTD
DESCRIPTION = "Gstreamer package groups"
DEPENDS = "gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-plugins-ugly"
-PR = "r4"
+PR = "r5"
PACKAGES = "\
gst-meta-base \
@@ -32,7 +32,8 @@ RDEPENDS_gst-meta-audio = "\
gst-meta-base \
gst-plugin-ivorbis \
gst-plugin-ogg \
- gst-plugin-mad"
+ gst-plugin-mad \
+ gst-plugin-id3demux"
RDEPENDS_gst-meta-debug = "\
diff --git a/packages/gstreamer/gst-plugin-pulse_0.9.4.bb b/packages/gstreamer/gst-plugin-pulse_0.9.4.bb
new file mode 100644
index 0000000000..f88cb66ff4
--- /dev/null
+++ b/packages/gstreamer/gst-plugin-pulse_0.9.4.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
+HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
+LICENSE = "GPL"
+DEPENDS = "gstreamer pulseaudio"
+PR = "r1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz"
+S = "${WORKDIR}/gst-pulse-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-lynx"
+GST_LIBV = 0.10
+
+do_install() {
+ install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
+ install -m 0755 src/.libs/libgstpulse.so ${D}${libdir}/gstreamer-${GST_LIBV}
+}
+
+export GST_MODDIR=${libdir}/gstreamer-0.10
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/libgstpulse.so"
+FILES_${PN}-dev = "\
+ ${libdir}/gstreamer-0.10/libgstpulse.a \
+ ${libdir}/gstreamer-0.10/libgstpulse.la \
+ ${libdir}/gstreamer-0.10/libgstpulse.so*"
+FILES_${PN}-dbg = "${libdir}/gstreamer-0.10/.debug"
+