summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--packages/subversion/subversion_1.4.5.bb33
-rw-r--r--packages/wesnoth/.mtn2git_empty0
-rw-r--r--packages/wesnoth/wesnoth_svn.bb19
-rw-r--r--packages/zaurusd/zaurusd_svn.bb6
5 files changed, 56 insertions, 3 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index df8ebd2a74..df4be2d2e0 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -123,6 +123,7 @@ SRCREV_pn-tmut ?= "60"
SRCREV_pn-webkit-gtk ?= "27222"
SRCREV_pn-webkit-qt ?= "27222"
SRCREV_pn-webkit-qtopia ?= "27222"
+SRCREV_pn-wesnoth ?= "22021"
SRCREV_pn-xoo ?= "1623"
SRCREV_pn-mplayer ?= "24587"
SRCREV_pn-networkmanager ?= "2887"
diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..1daf45bd0c
--- /dev/null
+++ b/packages/subversion/subversion_1.4.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/packages/wesnoth/.mtn2git_empty b/packages/wesnoth/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wesnoth/.mtn2git_empty
diff --git a/packages/wesnoth/wesnoth_svn.bb b/packages/wesnoth/wesnoth_svn.bb
new file mode 100644
index 0000000000..430abe7d0f
--- /dev/null
+++ b/packages/wesnoth/wesnoth_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "fantasy turn-based strategy game"
+PV = "0.01+svnr${SRCREV}"
+PR = "r1"
+SECTION = "games"
+LICENSE = "GPL"
+DEPENDS += "libsdl-image libsdl-mixer libsdl-net"
+SRC_URI = "svn://svn.gna.org/svn/wesnoth;module=trunk;proto=http"
+
+EXTRA_OECONF += " --enable-tinygui --disable-python --enable-lite --enable-lowmem"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+addtask autogen after do_patch before do_configure
+
+do_autogen() {
+ cd ${WORKDIR}/trunk/ && ./autogen.sh --host=armv4t-angstrom-linux-gnueabi
+}
diff --git a/packages/zaurusd/zaurusd_svn.bb b/packages/zaurusd/zaurusd_svn.bb
index f2d1f640b1..8f559fbca0 100644
--- a/packages/zaurusd/zaurusd_svn.bb
+++ b/packages/zaurusd/zaurusd_svn.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Daemon to handle device specifc features."
SECTION = "base"
LICENSE = "GPL"
-DEPENDS = "tslib gpe-conf"
-RDEPENDS = "procps gpe-conf"
+DEPENDS = "tslib"
+RDEPENDS = "procps"
PV = "0.0+svn${SRCDATE}"
-PR = "r12"
+PR = "r13"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
file://zaurus-hinge.in \