summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/kernel.bbclass2
-rw-r--r--packages/linux/linux-openmoko-devel_svn+2.6.23.1.bb68
-rw-r--r--packages/linux/linux-openmoko-devel_svn+2.6.24-rc6.bb68
-rw-r--r--packages/linux/linux-rp-2.6.23+2.6.24-rc8/defconfig-collie8
-rw-r--r--packages/linux/linux-rp_2.6.23+2.6.24-rc8.bb2
-rw-r--r--packages/meta/external-toolchain.bb2
-rw-r--r--packages/prelink/prelink-20061027/.mtn2git_empty (renamed from packages/prelink/prelink-20060712/.mtn2git_empty)0
-rw-r--r--packages/prelink/prelink-20061027/arm_eabi.patch (renamed from packages/prelink/prelink-20060712/arm_eabi.patch)87
-rw-r--r--packages/prelink/prelink-20061027/prelink.conf (renamed from packages/prelink/prelink-20060712/prelink.conf)0
-rw-r--r--packages/prelink/prelink-20061027/prelink.cron.daily (renamed from packages/prelink/prelink-20060712/prelink.cron.daily)0
-rw-r--r--packages/prelink/prelink-20061027/prelink.default (renamed from packages/prelink/prelink-20060712/prelink.default)0
-rw-r--r--packages/prelink/prelink_20061027.bb (renamed from packages/prelink/prelink_20060712.bb)4
-rw-r--r--packages/qt4/qt_packaging.inc67
-rw-r--r--packages/tasks/task-openmoko-toolchain-host.bb13
14 files changed, 107 insertions, 214 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index f896492364..8724ad2cf1 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -231,6 +231,8 @@ module_autoload_ipsec = "ipsec"
module_autoload_ircomm-tty = "ircomm-tty"
module_autoload_rfcomm = "rfcomm"
module_autoload_sa1100-rtc = "sa1100-rtc"
+# sa1100-rtc was renamed in 2.6.23 onwards
+module_autoload_rtc-sa1100 = "rtc-sa1100"
# alias defaults (alphabetically sorted)
module_conf_af_packet = "alias net-pf-17 af_packet"
diff --git a/packages/linux/linux-openmoko-devel_svn+2.6.23.1.bb b/packages/linux/linux-openmoko-devel_svn+2.6.23.1.bb
deleted file mode 100644
index 5cca31d74b..0000000000
--- a/packages/linux/linux-openmoko-devel_svn+2.6.23.1.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-require linux.inc
-require linux-openmoko.inc
-
-DESCRIPTION = "Linux 2.6.x (development) kernel for FIC SmartPhones shipping w/ OpenMoko"
-VANILLA_VERSION = "2.6.23"
-#KERNEL_VERSION = "2.6.23-rc9"
-KERNEL_RELEASE = "2.6.23.1"
-
-# If you use a rc, you will need to use this:
-#PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}-moko11+svnr${SRCREV}"
-
-KERNEL_VERSION = "${KERNEL_RELEASE}"
-PV = "${KERNEL_RELEASE}+svnr${SRCREV}"
-PR = "r3"
-
-KERNEL_IMAGETYPE = "uImage"
-UBOOT_ENTRYPOINT = "30008000"
-
-##############################################################
-# source and patches
-#
-SRCREV_FORMAT = "patches"
-SRCREV = "3140"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_VERSION}.bz2;patch=1 \
- svn://svn.openmoko.org/branches/src/target/kernel/2.6.23.x;module=patches;proto=http;name=patches \
- file://squashfs-2.6.23.patch;patch=1 \
- file://fix-EVIOCGRAB-semantics-2.6.22.5.patch;patch=1 \
-# file://printascii-2.6.23.patch;patch=1 \
- file://hack-gta02-cpu.patch;patch=1 \
- file://fix-gta01-flowcontrol2-2.6.23.patch;patch=1 \
- file://defconfig-2.6.23.1 \
- file://logo_linux_clut224.ppm"
-S = "${WORKDIR}/linux-${VANILLA_VERSION}"
-
-##############################################################
-# kernel image resides on a seperate flash partition (for now)
-#
-FILES_kernel-image = ""
-ALLOW_EMPTY = "1"
-
-COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = 'fic-gta01|fic-gta02'
-
-CMDLINE = "unused -- bootloader passes ATAG list"
-
-###############################################################
-# module configs specific to this kernel
-#
-
-# usb
-module_autoload_ohci-hcd = "ohci-hcd"
-module_autoload_hci_usb = "hci_usb"
-module_autoload_g_ether = "g_ether"
-# audio
-module_autoload_snd-soc-neo1973-wm8753 = "snd-soc-neo1973-wm8753"
-# sd/mmc
-module_autoload_s3cmci = "s3cmci"
-
-do_prepatch() {
- mv ${WORKDIR}/patches ${S}/patches && cd ${S} && quilt push -av
- mv patches patches.openmoko
- mv .pc .pc.old
- mv ${WORKDIR}/defconfig-${KERNEL_VERSION} ${WORKDIR}/defconfig
-}
-
-addtask prepatch after do_unpack before do_patch
diff --git a/packages/linux/linux-openmoko-devel_svn+2.6.24-rc6.bb b/packages/linux/linux-openmoko-devel_svn+2.6.24-rc6.bb
deleted file mode 100644
index 733cd3fb3b..0000000000
--- a/packages/linux/linux-openmoko-devel_svn+2.6.24-rc6.bb
+++ /dev/null
@@ -1,68 +0,0 @@
-require linux.inc
-require linux-openmoko.inc
-
-DESCRIPTION = "Linux 2.6.x (development) kernel for FIC SmartPhones shipping w/ OpenMoko"
-VANILLA_VERSION = "2.6.23"
-KERNEL_RELEASE = "2.6.24-rc6"
-
-KERNEL_VERSION = "${KERNEL_RELEASE}"
-
-# If you use a rc, you will need to use this:
-PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}+svnr${SRCREV}"
-#PV = "${KERNEL_RELEASE}+svnr${SRCREV}"
-PR = "r2"
-
-KERNEL_IMAGETYPE = "uImage"
-UBOOT_ENTRYPOINT = "30008000"
-
-##############################################################
-# source and patches
-#
-SRCREV_FORMAT = "patches"
-SRCREV = "3741"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-${KERNEL_VERSION}.bz2 \
- svn://svn.openmoko.org/branches/src/target/kernel/2.6.24.x;module=patches;proto=http;name=patches \
-# file://squashfs-2.6.23.patch;patch=1 \
-# file://fix-EVIOCGRAB-semantics-2.6.22.5.patch;patch=1 \
-# file://printascii-2.6.23.patch;patch=1 \
-# file://hack-gta02-cpu.patch;patch=1 \
-# file://fix-gta01-flowcontrol2-2.6.23.patch;patch=1 \
- file://defconfig-${KERNEL_VERSION} \
- file://logo_linux_clut224.ppm"
-S = "${WORKDIR}/linux-${VANILLA_VERSION}"
-
-##############################################################
-# kernel image resides on a seperate flash partition (for now)
-#
-FILES_kernel-image = ""
-ALLOW_EMPTY = "1"
-
-COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = 'fic-gta01|fic-gta02'
-
-CMDLINE = "unused -- bootloader passes ATAG list"
-
-###############################################################
-# module configs specific to this kernel
-#
-
-# usb
-module_autoload_ohci-hcd = "ohci-hcd"
-module_autoload_hci_usb = "hci_usb"
-module_autoload_g_ether = "g_ether"
-# audio
-module_autoload_snd-soc-neo1973-wm8753 = "snd-soc-neo1973-wm8753"
-# sd/mmc
-module_autoload_s3cmci = "s3cmci"
-
-do_prepatch() {
- cd ${S} && patch -p1 < ${WORKDIR}/patch-${KERNEL_VERSION}
- mv ${WORKDIR}/patches ${S}/patches && cd ${S} && quilt push -av
- mv patches patches.openmoko
- mv .pc .pc.old
- mv ${WORKDIR}/defconfig-${KERNEL_VERSION} ${WORKDIR}/defconfig
-}
-
-addtask prepatch after do_unpack before do_patch
diff --git a/packages/linux/linux-rp-2.6.23+2.6.24-rc8/defconfig-collie b/packages/linux/linux-rp-2.6.23+2.6.24-rc8/defconfig-collie
index 06b4d15ddb..07258b44ed 100644
--- a/packages/linux/linux-rp-2.6.23+2.6.24-rc8/defconfig-collie
+++ b/packages/linux/linux-rp-2.6.23+2.6.24-rc8/defconfig-collie
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.24-rc8
-# Sun Jan 20 18:52:49 2008
+# Mon Jan 21 21:35:18 2008
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1279,9 +1279,9 @@ CONFIG_MSDOS_PARTITION=y
# CONFIG_KARMA_PARTITION is not set
# CONFIG_EFI_PARTITION is not set
# CONFIG_SYSV68_PARTITION is not set
-CONFIG_NLS=y
+CONFIG_NLS=m
CONFIG_NLS_DEFAULT="cp437"
-CONFIG_NLS_CODEPAGE_437=y
+CONFIG_NLS_CODEPAGE_437=m
CONFIG_NLS_CODEPAGE_737=m
CONFIG_NLS_CODEPAGE_775=m
CONFIG_NLS_CODEPAGE_850=m
@@ -1305,7 +1305,7 @@ CONFIG_NLS_ISO8859_8=m
CONFIG_NLS_CODEPAGE_1250=m
CONFIG_NLS_CODEPAGE_1251=m
CONFIG_NLS_ASCII=m
-CONFIG_NLS_ISO8859_1=y
+CONFIG_NLS_ISO8859_1=m
CONFIG_NLS_ISO8859_2=m
CONFIG_NLS_ISO8859_3=m
CONFIG_NLS_ISO8859_4=m
diff --git a/packages/linux/linux-rp_2.6.23+2.6.24-rc8.bb b/packages/linux/linux-rp_2.6.23+2.6.24-rc8.bb
index 7c41e54c20..ec06f202f3 100644
--- a/packages/linux/linux-rp_2.6.23+2.6.24-rc8.bb
+++ b/packages/linux/linux-rp_2.6.23+2.6.24-rc8.bb
@@ -1,6 +1,6 @@
require linux-rp.inc
-PR = "r1"
+PR = "r2"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_collie = "1"
diff --git a/packages/meta/external-toolchain.bb b/packages/meta/external-toolchain.bb
index 47d9a93a15..69f16b10df 100644
--- a/packages/meta/external-toolchain.bb
+++ b/packages/meta/external-toolchain.bb
@@ -15,7 +15,7 @@ PROVIDES = "\
virtual/linux-libc-headers \
"
-RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
+#RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
PACKAGES_DYNAMIC = "glibc-gconv-*"
PR = "r1"
diff --git a/packages/prelink/prelink-20060712/.mtn2git_empty b/packages/prelink/prelink-20061027/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/prelink/prelink-20060712/.mtn2git_empty
+++ b/packages/prelink/prelink-20061027/.mtn2git_empty
diff --git a/packages/prelink/prelink-20060712/arm_eabi.patch b/packages/prelink/prelink-20061027/arm_eabi.patch
index b234af9b3f..dbce9d2895 100644
--- a/packages/prelink/prelink-20060712/arm_eabi.patch
+++ b/packages/prelink/prelink-20061027/arm_eabi.patch
@@ -1,16 +1,22 @@
-Index: prelink-0.0.20050901/src/arch-arm.c
+---
+ src/arch-arm.c | 177 +++++++++++++++++++++++++++++++++++++++++++++++++++++++--
+ 1 file changed, 172 insertions(+), 5 deletions(-)
+
+Index: prelink-0.0.20061027/src/arch-arm.c
===================================================================
---- prelink-0.0.20050901.orig/src/arch-arm.c 2004-09-30 17:07:57.000000000 +0100
-+++ prelink-0.0.20050901/src/arch-arm.c 2006-04-07 14:41:25.000000000 +0100
-@@ -145,6 +145,24 @@
+--- prelink-0.0.20061027.orig/src/arch-arm.c 2006-08-13 16:18:17.000000000 +0100
++++ prelink-0.0.20061027/src/arch-arm.c 2007-09-04 12:29:06.000000000 +0100
+@@ -145,6 +145,26 @@ arm_prelink_rel (struct prelink_info *in
error (0, 0, "%s: R_ARM_PC24 relocs with non-zero addend should not be present in prelinked REL sections",
dso->filename);
return 1;
-+ case R_ARM_TLS_DTPOFF32:
-+ write_le32 (dso, rel->r_offset, value);
++ /* DTPOFF32, DTPMOD32 and TPOFF32 is impossible to predict unless prelink
++ sets the rules. Also for DTPOFF32/TPOFF32 there is REL->RELA problem. */
++ case R_ARM_TLS_DTPOFF32:
++ if (dso->ehdr.e_type == ET_EXEC)
++ error (0, 0, "%s: R_ARM_TLS_DTPOFF32 relocs should not be present in prelinked ET_EXEC REL sections",
++ dso->filename);
+ break;
-+ /* DTPMOD32 and TPOFF32 is impossible to predict unless prelink
-+ sets the rules. Also for TPOFF{32,} there is REL->RELA problem. */
+ case R_ARM_TLS_DTPMOD32:
+ if (dso->ehdr.e_type == ET_EXEC)
+ {
@@ -27,14 +33,15 @@ Index: prelink-0.0.20050901/src/arch-arm.c
case R_ARM_COPY:
if (dso->ehdr.e_type == ET_EXEC)
/* COPY relocs are handled specially in generic code. */
-@@ -195,6 +213,24 @@
+@@ -195,6 +215,25 @@ arm_prelink_rela (struct prelink_info *i
write_le32 (dso, rela->r_offset,
(read_ule32 (dso, rela->r_offset) & 0xff000000) | val);
break;
+ case R_ARM_TLS_DTPOFF32:
-+ write_le32 (dso, rela->r_offset, value + rela->r_addend);
++ if (dso->ehdr.e_type == ET_EXEC)
++ write_le32 (dso, rela->r_offset, value + rela->r_addend);
+ break;
-+ /* DTPMOD32 and TPOFF32 is impossible to predict unless prelink
++ /* DTPMOD32 and TPOFF32 are impossible to predict unless prelink
+ sets the rules. */
+ case R_ARM_TLS_DTPMOD32:
+ if (dso->ehdr.e_type == ET_EXEC)
@@ -47,12 +54,12 @@ Index: prelink-0.0.20050901/src/arch-arm.c
+ case R_ARM_TLS_TPOFF32:
+ if (dso->ehdr.e_type == ET_EXEC && info->resolvetls)
+ write_le32 (dso, rela->r_offset,
-+ -(value + rela->r_addend - info->resolvetls->offset));
++ value + rela->r_addend + info->resolvetls->offset);
+ break;
case R_ARM_COPY:
if (dso->ehdr.e_type == ET_EXEC)
/* COPY relocs are handled specially in generic code. */
-@@ -315,6 +351,7 @@
+@@ -315,6 +354,7 @@ arm_prelink_conflict_rel (DSO *dso, stru
{
GElf_Addr value;
struct prelink_conflict *conflict;
@@ -60,7 +67,7 @@ Index: prelink-0.0.20050901/src/arch-arm.c
GElf_Rela *ret;
if (GELF_R_TYPE (rel->r_info) == R_ARM_RELATIVE
-@@ -324,8 +361,31 @@
+@@ -324,8 +364,32 @@ arm_prelink_conflict_rel (DSO *dso, stru
conflict = prelink_conflict (info, GELF_R_SYM (rel->r_info),
GELF_R_TYPE (rel->r_info));
if (conflict == NULL)
@@ -71,8 +78,9 @@ Index: prelink-0.0.20050901/src/arch-arm.c
+ return 0;
+ switch (GELF_R_TYPE (rel->r_info))
+ {
-+ /* Even local DTPMOD and TPOFF relocs need conflicts. */
++ /* Even local DTPMOD and {D,}TPOFF relocs need conflicts. */
+ case R_ARM_TLS_DTPMOD32:
++ case R_ARM_TLS_DTPOFF32:
+ case R_ARM_TLS_TPOFF32:
+ break;
+ default:
@@ -94,7 +102,7 @@ Index: prelink-0.0.20050901/src/arch-arm.c
ret = prelink_conflict_add_rela (info);
if (ret == NULL)
return 1;
-@@ -342,6 +402,33 @@
+@@ -342,6 +406,33 @@ arm_prelink_conflict_rel (DSO *dso, stru
error (0, 0, "%s: R_ARM_%s relocs should not be present in prelinked REL sections",
dso->filename, GELF_R_TYPE (rel->r_info) == R_ARM_ABS32 ? "ABS32" : "PC24");
return 1;
@@ -117,18 +125,18 @@ Index: prelink-0.0.20050901/src/arch-arm.c
+ ret->r_addend = tls->modid;
+ break;
+ case R_ARM_TLS_DTPOFF32:
-+ ret->r_addend = value;
++ ret->r_addend = value + read_ule32 (dso, rel->r_offset);
+ break;
+ case R_ARM_TLS_TPOFF32:
-+ ret->r_addend = -(value + read_ule32 (dso, rel->r_offset)
-+ - tls->offset);
++ ret->r_addend = value + read_ule32 (dso, rel->r_offset)
++ + tls->offset;
+ break;
+ }
+ break;
case R_ARM_COPY:
error (0, 0, "R_ARM_COPY should not be present in shared libraries");
return 1;
-@@ -359,6 +446,7 @@
+@@ -359,6 +450,7 @@ arm_prelink_conflict_rela (DSO *dso, str
{
GElf_Addr value;
struct prelink_conflict *conflict;
@@ -136,7 +144,7 @@ Index: prelink-0.0.20050901/src/arch-arm.c
GElf_Rela *ret;
Elf32_Sword val;
-@@ -369,8 +457,31 @@
+@@ -369,8 +461,32 @@ arm_prelink_conflict_rela (DSO *dso, str
conflict = prelink_conflict (info, GELF_R_SYM (rela->r_info),
GELF_R_TYPE (rela->r_info));
if (conflict == NULL)
@@ -147,8 +155,9 @@ Index: prelink-0.0.20050901/src/arch-arm.c
+ return 0;
+ switch (GELF_R_TYPE (rela->r_info))
+ {
-+ /* Even local DTPMOD and TPOFF relocs need conflicts. */
++ /* Even local DTPMOD and {D,}TPOFF relocs need conflicts. */
+ case R_ARM_TLS_DTPMOD32:
++ case R_ARM_TLS_DTPOFF32:
+ case R_ARM_TLS_TPOFF32:
+ break;
+ default:
@@ -170,7 +179,7 @@ Index: prelink-0.0.20050901/src/arch-arm.c
ret = prelink_conflict_add_rela (info);
if (ret == NULL)
return 1;
-@@ -398,6 +509,32 @@
+@@ -398,6 +514,32 @@ arm_prelink_conflict_rela (DSO *dso, str
case R_ARM_COPY:
error (0, 0, "R_ARM_COPY should not be present in shared libraries");
return 1;
@@ -193,78 +202,80 @@ Index: prelink-0.0.20050901/src/arch-arm.c
+ ret->r_addend = tls->modid;
+ break;
+ case R_ARM_TLS_DTPOFF32:
-+ ret->r_addend += value;
++ ret->r_addend = value + rela->r_addend;
+ break;
+ case R_ARM_TLS_TPOFF32:
-+ ret->r_addend = -(value + rela->r_addend - tls->offset);
++ ret->r_addend = value + rela->r_addend + tls->offset;
+ break;
+ }
+ break;
default:
error (0, 0, "%s: Unknown arm relocation type %d", dso->filename,
(int) GELF_R_TYPE (rela->r_info));
-@@ -418,6 +555,7 @@
+@@ -418,6 +560,8 @@ arm_rel_to_rela (DSO *dso, GElf_Rel *rel
abort ();
case R_ARM_RELATIVE:
case R_ARM_ABS32:
+ case R_ARM_TLS_TPOFF32:
++ case R_ARM_TLS_DTPOFF32:
rela->r_addend = (Elf32_Sword) read_ule32 (dso, rel->r_offset);
break;
case R_ARM_PC24:
-@@ -426,6 +564,8 @@
+@@ -426,6 +570,7 @@ arm_rel_to_rela (DSO *dso, GElf_Rel *rel
break;
case R_ARM_COPY:
case R_ARM_GLOB_DAT:
-+ case R_ARM_TLS_DTPOFF32:
+ case R_ARM_TLS_DTPMOD32:
rela->r_addend = 0;
break;
}
-@@ -445,6 +585,7 @@
+@@ -445,6 +590,8 @@ arm_rela_to_rel (DSO *dso, GElf_Rela *re
abort ();
case R_ARM_RELATIVE:
case R_ARM_ABS32:
+ case R_ARM_TLS_TPOFF32:
++ case R_ARM_TLS_DTPOFF32:
write_le32 (dso, rela->r_offset, rela->r_addend);
break;
case R_ARM_PC24:
-@@ -453,6 +594,8 @@
+@@ -453,6 +600,7 @@ arm_rela_to_rel (DSO *dso, GElf_Rela *re
| ((rela->r_addend >> 2) & 0xffffff));
break;
case R_ARM_GLOB_DAT:
+ case R_ARM_TLS_DTPMOD32:
-+ case R_ARM_TLS_DTPOFF32:
write_le32 (dso, rela->r_offset, 0);
break;
}
-@@ -488,6 +631,13 @@
+@@ -488,6 +636,15 @@ arm_need_rel_to_rela (DSO *dso, int firs
/* FALLTHROUGH */
case R_ARM_PC24:
return 1;
++ case R_ARM_TLS_DTPOFF32:
+ case R_ARM_TLS_TPOFF32:
-+ /* In shared libraries TPOFF is changed always into
++ /* In shared libraries {D,}TPOFF32 is changed always into
+ conflicts, for executables we need to preserve
+ original addend. */
-+ if (dso->ehdr.e_type == ET_EXEC)
++ if (dso->ehdr.e_type == ET_EXEC) {
+ return 1;
++ }
+ break;
}
}
}
-@@ -612,6 +762,12 @@
+@@ -612,6 +769,12 @@ arm_undo_prelink_rel (DSO *dso, GElf_Rel
return 0;
error (0, 0, "%s: R_ARM_COPY reloc in shared library?", dso->filename);
return 1;
+ case R_ARM_TLS_DTPMOD32:
-+ case R_ARM_TLS_DTPOFF32:
+ write_le32 (dso, rel->r_offset, 0);
+ break;
++ case R_ARM_TLS_DTPOFF32:
+ case R_ARM_TLS_TPOFF32:
+ break;
default:
error (0, 0, "%s: Unknown arm relocation type %d", dso->filename,
(int) GELF_R_TYPE (rel->r_info));
-@@ -634,6 +790,10 @@
+@@ -634,6 +797,10 @@ arm_reloc_class (int reloc_type)
{
case R_ARM_COPY: return RTYPE_CLASS_COPY;
case R_ARM_JUMP_SLOT: return RTYPE_CLASS_PLT;
@@ -275,7 +286,7 @@ Index: prelink-0.0.20050901/src/arch-arm.c
default: return RTYPE_CLASS_VALID;
}
}
-@@ -646,7 +806,7 @@
+@@ -646,7 +813,7 @@ PL_ARCH = {
.R_JMP_SLOT = R_ARM_JUMP_SLOT,
.R_COPY = R_ARM_COPY,
.R_RELATIVE = R_ARM_RELATIVE,
diff --git a/packages/prelink/prelink-20060712/prelink.conf b/packages/prelink/prelink-20061027/prelink.conf
index c5a4f4adc3..c5a4f4adc3 100644
--- a/packages/prelink/prelink-20060712/prelink.conf
+++ b/packages/prelink/prelink-20061027/prelink.conf
diff --git a/packages/prelink/prelink-20060712/prelink.cron.daily b/packages/prelink/prelink-20061027/prelink.cron.daily
index 0b3c07322c..0b3c07322c 100644
--- a/packages/prelink/prelink-20060712/prelink.cron.daily
+++ b/packages/prelink/prelink-20061027/prelink.cron.daily
diff --git a/packages/prelink/prelink-20060712/prelink.default b/packages/prelink/prelink-20061027/prelink.default
index 901258ed2a..901258ed2a 100644
--- a/packages/prelink/prelink-20060712/prelink.default
+++ b/packages/prelink/prelink-20061027/prelink.default
diff --git a/packages/prelink/prelink_20060712.bb b/packages/prelink/prelink_20061027.bb
index fcf990b7a0..e93f1f2515 100644
--- a/packages/prelink/prelink_20060712.bb
+++ b/packages/prelink/prelink_20061027.bb
@@ -4,7 +4,7 @@ DESCRIPTION = " The prelink package contains a utility which modifies ELF shared
and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
LICENSE = "GPL"
-PR = "r2"
+PR = "r5"
SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
file://prelink.conf \
@@ -19,7 +19,7 @@ S = "${WORKDIR}/prelink-0.0.${PV}"
EXTRA_OECONF = "--disable-64bit"
-inherit autotools
+inherit autotools
do_install_append () {
install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
diff --git a/packages/qt4/qt_packaging.inc b/packages/qt4/qt_packaging.inc
index 63d314c6c5..ba2a037f59 100644
--- a/packages/qt4/qt_packaging.inc
+++ b/packages/qt4/qt_packaging.inc
@@ -8,13 +8,6 @@ NONDEV_PACKAGES += "${QT_BASE_LIB}core4 ${QT_BASE_LIB}gui4 ${QT_BASE_LIB}network
${QT_BASE_NAME}-demos ${QT_BASE_NAME}-examples \
${QT_BASE_NAME}-linguist \
${QT_BASE_NAME}-pixeltool ${QT_BASE_NAME}-dbus \
- ${QT_BASE_NAME}-plugins-accessible \
- ${QT_BASE_NAME}-plugins-codecs \
- ${QT_BASE_NAME}-plugins-designer \
- ${QT_BASE_NAME}-plugins-imageformats \
- ${QT_BASE_NAME}-plugins-sqldrivers \
- ${QT_BASE_NAME}-plugins-inputmethods \
- ${QT_BASE_NAME}-plugins-iconengines \
${QT_BASE_NAME}-fonts "
DEV_PACKAGES += "${QT_BASE_LIB}core4-dev \
@@ -46,7 +39,7 @@ DBG_PACKAGES += "${QT_BASE_LIB}core4-dbg \
${QT_BASE_LIB}assistantclient4-dbg \
${QT_BASE_LIB}script4-dbg \
${QT_BASE_LIB}dbus4-dbg \
- ${QT_BASE_LIB}opengl4-dbg "
+ ${QT_BASE_LIB}opengl4-dbg"
PACKAGES += "${DEV_PACKAGES} ${NONDEV_PACKAGES} ${DBG_PACKAGES}"
@@ -54,7 +47,7 @@ PACKAGES += "${DEV_PACKAGES} ${NONDEV_PACKAGES} ${DBG_PACKAGES}"
ALLOW_EMPTY_${PN} = "1"
FILES_${PN} = ""
FILES_${PN}-dev = " ${includedir}/${QT_DIR_NAME}/Qt/*"
-FILES_${PN}-dbg = "${bindir}/*/.debug ${libdir}/${QT_DIR_NAME}/plugins/*/.debug/*.so"
+FILES_${PN}-dbg = "${bindir}/*/.debug "
RDEPENDS_${PN} = "${NONDEV_PACKAGES}"
RDEPENDS_${PN}-dev = "${DEV_PACKAGES}"
RDEPENDS_${PN}-dbg = "${DBG_PACKAGES}"
@@ -112,14 +105,6 @@ FILES_${QT_BASE_LIB}opengl4-dbg = "${libdir}/.debug/libQtOpenGL*"
FILES_${QT_BASE_LIB}uitools4-dev = "${libdir}/libQtUiTools* ${includedir}/${QT_DIR_NAME}/QtUiTools* ${libdir}/pkgconfig/QtUiTools${QT_LIBINFIX}.pc"
-FILES_${QT_BASE_NAME}-plugins-accessible = "${libdir}/${QT_DIR_NAME}/plugins/accessible/*.so"
-FILES_${QT_BASE_NAME}-plugins-codecs = "${libdir}/${QT_DIR_NAME}/plugins/codecs/*.so"
-FILES_${QT_BASE_NAME}-plugins-designer = "${libdir}/${QT_DIR_NAME}/plugins/designer/*.so"
-FILES_${QT_BASE_NAME}-plugins-imageformats = "${libdir}/${QT_DIR_NAME}/plugins/imageformats/*.so"
-FILES_${QT_BASE_NAME}-plugins-sqldrivers = "${libdir}/${QT_DIR_NAME}/plugins/sqldrivers/*.so"
-FILES_${QT_BASE_NAME}-plugins-inputmethods = "${libdir}/${QT_DIR_NAME}/plugins/inputmethods/*.so"
-FILES_${QT_BASE_NAME}-plugins-iconengines = "${libdir}/${QT_DIR_NAME}/plugins/iconengines/*.so"
-
FILES_${QT_BASE_NAME}-assistant = "${bindir}/*assistant*"
FILES_${QT_BASE_NAME}-designer = "${bindir}/*designer*"
FILES_${QT_BASE_NAME}-linguist = "${bindir}/*linguist* ${bindir}/lrelease ${bindir}/lupdate ${bindir}/qm2ts"
@@ -133,8 +118,52 @@ FILES_${QT_BASE_NAME}-demos = "${bindir}/qtdemo ${bindir}/${QT_DI
FILES_${QT_BASE_NAME}-fonts = "${libdir}/fonts"
python populate_packages_prepend() {
- translationdir = bb.data.expand('${datadir}/${QT_DIR_NAME}/translations/', d)
- do_split_packages(d, translationdir, '^qt_(.*)\.qm$', '${QT_DIR_NAME}-translation-%s', '{PN} translation for %s', extra_depends='' )
+ translation_dir = bb.data.expand('${datadir}/${QT_DIR_NAME}/translations/', d)
+ translation_name = bb.data.expand('${QT_BASE_NAME}-translation-%s', d)
+ do_split_packages(d, translation_dir, '^qt_(.*)\.qm$', translation_name, '{PN} translation for %s', extra_depends='' )
+
+ phrasebook_dir = bb.data.expand('${datadir}/${QT_DIR_NAME}/phrasebooks/', d)
+ phrasebook_name = bb.data.expand('${QT_BASE_NAME}-phrasebook-%s', d)
+ do_split_packages(d, phrasebook_dir, '^(.*)\.qph$', phrasebook_name, '{PN} phrasebook for %s', extra_depends='' )
+
+ # Package all the plugins and their -dbg version and create a meta package
+ import os
+ def qtopia_split(path, name, glob):
+ """
+ Split the package into a normal and -dbg package and then add the
+ new packages to the meta package.
+ """
+ plugin_dir = bb.data.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/' % path, d)
+ if not os.path.exists("%s%s" % (bb.data.expand('${D}',d), plugin_dir)):
+ bb.note("The path does not exist:", bb.data.expand('${D}', d), plugin_dir)
+ return
+
+ plugin_name = bb.data.expand('${QT_BASE_NAME}-plugin-%s-%%s' % name, d)
+ dev_packages = []
+ dev_hook = lambda file,pkg,b,c,d:dev_packages.append((file,pkg))
+ do_split_packages(d, plugin_dir, glob, plugin_name, '{PN} %s for %%s' % name, extra_depends='', hook=dev_hook)
+ # Create a -dbg package as well
+ plugin_dir_dbg = bb.data.expand('${libdir}/${QT_DIR_NAME}/plugins/%s/.debug' % path, d)
+ packages = bb.data.getVar('PACKAGES',d)
+ for (file,package) in dev_packages:
+ packages = "%s %s-dbg" % (packages, package)
+ file_name = os.path.join(plugin_dir_dbg, os.path.basename(file))
+ bb.data.setVar("FILES_%s-dbg" % package, file_name, d)
+ bb.data.setVar("DESCRIPTION_%s-dbg" % package, "{PN} %s for %s" % (name, package), d)
+
+ bb.data.setVar('PACKAGES', packages, d)
+
+ qtopia_split('accessible', 'accessible', '^libq(.*)\.so$')
+ qtopia_split('codecs', 'codec', '^libq(.*)\.so$')
+ qtopia_split('decorations', 'decoration', '^libqdecoration(.*)\.so$')
+ qtopia_split('designer', 'designer', '^lib(.*)\.so$')
+ qtopia_split('gfxdrivers', 'gfxdriver', '^libqgfx(.*)\.so$')
+ qtopia_split('mousedrivers','mousedriver', '^libq(.*)mousedriver\.so$')
+ qtopia_split('iconengines', 'iconengine', '^libq(.*)\.so$')
+ qtopia_split('imageformats','imageformat', '^libq(.*)\.so$')
+ qtopia_split('inputmethods','inputmethod', '^libq(.*)\.so$')
+ qtopia_split('sqldrivers', 'sqldriver', '^libq(.*)\.so$')
+ qtopia_split('styles', 'style', '^libq(.*)\.so$')
}
diff --git a/packages/tasks/task-openmoko-toolchain-host.bb b/packages/tasks/task-openmoko-toolchain-host.bb
index 31ac3bb746..788152c6ca 100644
--- a/packages/tasks/task-openmoko-toolchain-host.bb
+++ b/packages/tasks/task-openmoko-toolchain-host.bb
@@ -11,16 +11,3 @@ PACKAGES = "${PN}"
RDEPENDS_${PN} += "\
openmoko-sample2-src \
"
-require task-sdk-host.bb
-
-DESCRIPTION = "Packages for a standalone OpenMoko SDK or external toolchain"
-LICENSE = "MIT"
-ALLOW_EMPTY = "1"
-
-PR = "r0"
-
-PACKAGES = "${PN}"
-
-RDEPENDS_${PN} += "\
- openmoko-sample2-src \
-"