summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/efl1/ecore.inc24
-rw-r--r--recipes/efl1/edje_svn.bb7
-rw-r--r--recipes/efl1/embryo_svn.bb11
-rw-r--r--recipes/mono/mono-2.4.2.3/0001-remove-docs-dir-from-build.patch30
-rw-r--r--recipes/mono/mono-2.4.2.3/configure.patch44
-rw-r--r--recipes/mono/mono-2.4.2.3/mini-arm.patch11
-rw-r--r--recipes/mono/mono-mcs-intermediate_2.4.2.3.bb17
-rw-r--r--recipes/mono/mono-native_2.4.2.3.bb20
-rw-r--r--recipes/mono/mono_2.4.2.3.bb85
-rw-r--r--recipes/mono/mono_2.4.2.3.inc21
-rw-r--r--recipes/mono/mono_svn.bb4
-rw-r--r--recipes/tasks/task-beagleboard-demo.bb6
14 files changed, 276 insertions, 10 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index fb2e7f2aa1..c37effb7c8 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -17158,6 +17158,10 @@ sha256=44fc0eddf56c0abe861190051fceec6e223122c5835967459c69fbf98ee52067
md5=a311545a0003f1a599297d57e4e27916
sha256=4cf6094f64f3446e83b968cbee3f0ed5d579b635644dd8cbd51bbbe184446600
+[http://ftp.novell.com/pub/mono/sources/mono/mono-2.4.2.3.tar.bz2]
+md5=696f25afc8453cd0d1c78de6e905dcf2
+sha256=1bab0d4e2906c88736ff5e242f2905f4c3535ccfc05bb5c427b72adf0e9236ae
+
[http://venge.net/monotone/downloads/monotone-0.20.tar.gz]
md5=3bdf4da35ff576a401483815952f4045
sha256=56a5c5afd838f90146205ee4769b83988c6bafc85826c0fbcad982f1e0333d93
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index e8d8c80b3f..586bbc172a 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -266,7 +266,7 @@ SRCREV_pn-zhone ?= "f38cc52fbf11f7fe945797a6b8ade29ed479d924"
# Enlightenment Foundation Libraries
# Caution: This is not alphabetically, but (roughly) dependency-sorted.
# Please leave it like that.
-EFL_SRCREV ?= "41038"
+EFL_SRCREV ?= "41533"
SRCREV_pn-edb-native ?= "${EFL_SRCREV}"
SRCREV_pn-edb ?= "${EFL_SRCREV}"
SRCREV_pn-eina-native ?= "${EFL_SRCREV}"
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index 1e639fc342..facd7a231a 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -27,6 +27,27 @@ PACKAGES =+ "\
${PN}-x \
${PN}-input \
"
+# Some upgrade path tweaking
+AUTO_LIBNAME_PKGS = ""
+
+RREPLACES_${PN} = "libecore-ver-pre-svn-00-0 libecore-ver-pre-svn-01-0"
+REPLACES_${PN}-tests = "libecore-ver-pre-svn-01-tests"
+RREPLACES_${PN}-con = "libecore-ver-pre-svn-01-con libecore-con-ver-pre-svn-01-0"
+RREPLACES_${PN}-config = "libecore-config-ver-pre-svn-01-0"
+RREPLACES_${PN}-desktop = "libecore-desktop-ver-pre-svn-01-0"
+RREPLACES_${PN}-directfb = "libecore-directfb-ver-pre-svn-01-0"
+RREPLACES_${PN}-sdl = "libecore-sdl-ver-pre-svn-01-0"
+RREPLACES_${PN}-evas = "libecore-evas-ver-pre-svn-01-0"
+RREPLACES_${PN}-fb = "libecore-fb-ver-pre-svn-01-0"
+RREPLACES_${PN}-file = "libecore-file-ver-pre-svn-01-0"
+RREPLACES_${PN}-imf-evas = "libecore-imf-evas-ver-pre-svn-01-0"
+RREPLACES_${PN}-imf = "libecore-imf-ver-pre-svn-01-0"
+RREPLACES_${PN}-ipc = "libecore-ipc-ver-pre-svn-01-0"
+RREPLACES_${PN}-job = "libecore-job-ver-pre-svn-01-0"
+RREPLACES_${PN}-txt = "libecore-txt-ver-pre-svn-01-0"
+RREPLACES_${PN}-x = "libecore-x-ver-pre-svn-01-0"
+RREPLACES_${PN}-input = "libecore-input-ver-pre-svn-01-0"
+
FILES_${PN} = "${libdir}/libecore*.so.*"
FILES_${PN}-con = "${libdir}/libecore_con*.so.*"
FILES_${PN}-config = "${libdir}/libecore_config*.so.*"
@@ -43,3 +64,6 @@ FILES_${PN}-job = "${libdir}/libecore_job*.so.*"
FILES_${PN}-txt = "${libdir}/libecore_txt*.so.*"
FILES_${PN}-x = "${libdir}/libecore_x*.so.*"
FILES_${PN}-input = "${libdir}/libecore_input*.so.*"
+
+
+
diff --git a/recipes/efl1/edje_svn.bb b/recipes/efl1/edje_svn.bb
index 2509c859c7..7f94b08256 100644
--- a/recipes/efl1/edje_svn.bb
+++ b/recipes/efl1/edje_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
DEPENDS = "eet evas ecore embryo edje-native"
LICENSE = "MIT BSD"
PV = "0.9.92.060+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
inherit efl
@@ -20,6 +20,11 @@ RRECOMMENDS_${PN}-utils = "\
"
DEBIAN_NOAUTONAME_${PN}-utils = "1"
+# Some upgrade path tweaking
+AUTO_LIBNAME_PKGS = ""
+
+RREPLACES_${PN} = "libedje-ver-pre-svn-00-0 libedje-ver-pre-svn-01-0"
+
FILES_${PN}-utils = "\
${bindir}/edje_* \
${datadir}/edje/include/edje.inc \
diff --git a/recipes/efl1/embryo_svn.bb b/recipes/efl1/embryo_svn.bb
index aeceb5abe4..222d85a7cb 100644
--- a/recipes/efl1/embryo_svn.bb
+++ b/recipes/efl1/embryo_svn.bb
@@ -1,9 +1,14 @@
DESCRIPTION = "The Enlightenment C-like scripting language for Edje"
LICENSE = "MIT BSD"
PV = "0.9.9.060+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
inherit efl
-# HACK alert: When compiling for VFP embryo emits bugs -- maybe gcc bug
-#FULL_OPTIMIZATION_arm =+ "-O0"
+# Some upgrade path tweaking
+AUTO_LIBNAME_PKGS = ""
+
+RREPLACES_${PN} = "libembryo-ver-pre-svn-00-0 libembryo-ver-pre-svn-01-0"
+
+RREPLACES_${PN}-tests = "libembryo-ver-pre-svn-00-tests libembryo-ver-pre-svn-01-tests"
+
diff --git a/recipes/mono/mono-2.4.2.3/0001-remove-docs-dir-from-build.patch b/recipes/mono/mono-2.4.2.3/0001-remove-docs-dir-from-build.patch
new file mode 100644
index 0000000000..4e276e3f0c
--- /dev/null
+++ b/recipes/mono/mono-2.4.2.3/0001-remove-docs-dir-from-build.patch
@@ -0,0 +1,30 @@
+From 2ca04d7b2af1f1d690d918da047b03de768f1a8b Mon Sep 17 00:00:00 2001
+From: Cliff Brake <cbrake@bec-systems.com>
+Date: Fri, 31 Jul 2009 17:48:47 -0400
+Subject: [PATCH] remove docs dir from build
+
+---
+ Makefile.am | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 083bb82..386ed91 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,11 +1,11 @@
+ AUTOMAKE_OPTIONS = foreign
+ ACLOCAL_AMFLAGS = -I .
+
+-SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc docs
++SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc
+
+ # Keep in sync with SUBDIRS
+ ## 'tools' is not normally built
+-DIST_SUBDIRS = po libgc $(eglib_dir) mono ikvm-native support data runtime scripts man samples web tools msvc docs
++DIST_SUBDIRS = po libgc $(eglib_dir) mono ikvm-native support data runtime scripts man samples web tools msvc
+
+ EXTRA_DIST= nls.m4 po.m4 progtest.m4 mono-uninstalled.pc.in build-mingw32.sh LICENSE mkinstalldirs
+
+--
+1.6.0.4
+
diff --git a/recipes/mono/mono-2.4.2.3/configure.patch b/recipes/mono/mono-2.4.2.3/configure.patch
new file mode 100644
index 0000000000..7ca874ab07
--- /dev/null
+++ b/recipes/mono/mono-2.4.2.3/configure.patch
@@ -0,0 +1,44 @@
+Index: mono-2.4.2.1/configure.in
+===================================================================
+--- mono-2.4.2.1.orig/configure.in 2008-11-13 18:22:29.000000000 -0500
++++ mono-2.4.2.1/configure.in 2008-12-10 16:03:11.000000000 -0500
+@@ -1155,6 +1155,8 @@
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1257,6 +1259,9 @@
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
+@@ -1746,6 +1751,7 @@
+
+ jit_wanted=false
+ interp_wanted=false
++echo "CLIFF: checking host = $host"
+ case "$host" in
+ # mips-sgi-irix5.* | mips-sgi-irix6.*)
+ # TARGET=MIPS;
+@@ -1882,10 +1888,12 @@
+ jit_wanted=true
+ ;;
+ arm*-linux*)
++ echo "CLIFF: found arm linux"
+ TARGET=ARM;
+ arch_target=arm;
+ ACCESS_UNALIGNED="no"
+ JIT_SUPPORTED=yes
++ CPPFLAGS="$CPPFLAGS -DARM_FPU_VFP=1"
+ jit_wanted=true
+ ;;
+ s390-*-linux*)
diff --git a/recipes/mono/mono-2.4.2.3/mini-arm.patch b/recipes/mono/mono-2.4.2.3/mini-arm.patch
new file mode 100644
index 0000000000..d517a5a276
--- /dev/null
+++ b/recipes/mono/mono-2.4.2.3/mini-arm.patch
@@ -0,0 +1,11 @@
+--- mono-2.4.2.1/mono/mini/mini-arm.h 2009-06-23 09:41:00.000000000 -0600
++++ mono-2.4.2.1/mono/mini/mini-arm.h 2009-06-23 09:40:27.000000000 -0600
+@@ -9,7 +9,7 @@
+ #endif
+
+ #ifdef ARM_FPU_VFP
+-#error "VFP support is not complete, try mono SVN for that."
++//#error "VFP support is not complete, try mono SVN for that."
+ #endif
+
+ #if defined(__ARM_EABI__)
diff --git a/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb b/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
new file mode 100644
index 0000000000..258f812602
--- /dev/null
+++ b/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
@@ -0,0 +1,17 @@
+# This is a straw-man recipe for step 1 in the two-step build of
+# mono. Because it's impossible to build the mcs directory
+# in cross-compile mode, this recipe will do a native build,
+# then tar the resulting install tree for usage by the mono
+# package in step 2.
+# See http://www.mono-project.com/Mono:ARM
+
+require mono_2.4.2.3.inc
+require mono-mcs-intermediate.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += ""
+
+PR = "${INC_PR}.1"
+
+
diff --git a/recipes/mono/mono-native_2.4.2.3.bb b/recipes/mono/mono-native_2.4.2.3.bb
new file mode 100644
index 0000000000..44ac053e99
--- /dev/null
+++ b/recipes/mono/mono-native_2.4.2.3.bb
@@ -0,0 +1,20 @@
+require mono_2.4.2.3.inc
+DEPENDS = "glib-2.0-native perl-native"
+
+PR = "${INC_PR}.1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += ""
+
+inherit native
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure
diff --git a/recipes/mono/mono_2.4.2.3.bb b/recipes/mono/mono_2.4.2.3.bb
new file mode 100644
index 0000000000..e1f1968cdb
--- /dev/null
+++ b/recipes/mono/mono_2.4.2.3.bb
@@ -0,0 +1,85 @@
+require mono_2.4.2.3.inc
+
+DEPENDS = "mono-native mono-mcs-intermediate glib-2.0 perl-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "${INC_PR}.1"
+
+# mono makes use of non-thumb-compatible inline asm.
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI += "file://configure.patch;patch=1\
+ file://mini-arm.patch;patch=1\
+ file://0001-remove-docs-dir-from-build.patch;patch=1"
+
+# Per http://www.mono-project.com/Mono:ARM
+EXTRA_OECONF += " --disable-mcs-build "
+# Instead, get the mcs tree from a different build (see mono-mcs-intermediate)
+
+do_install_prepend() {
+ install -d ${D}
+ pushd ${D}
+ tar -xzf ${STAGING_DATADIR_NATIVE}/mono-mcs/mono-mcs-${PV}.tar.gz
+ popd
+}
+
+do_install_append() {
+ # mono-mcs-intermediate builds and installs jay (a Yacc for Java and C#),
+ # however, jay is not being cross-compiled and thus only
+ # available for the buildhost architecture, so remove it
+ # entirely
+ pushd ${D}
+ rm -rf ./usr/share/man/man1/jay.1 ./usr/share/jay \
+ ./usr/share/jay/README.jay \
+ ./usr/bin/jay
+ popd
+
+ # Not packaged with the default rules and apparently
+ # not used for anything
+ rm -rf ${D}${datadir}/mono-1.0/mono/cil/cil-opcodes.xml
+}
+
+inherit mono
+
+# Import file definitions from Debian
+require mono_2.x-files.inc
+
+# Add some packages
+PACKAGES_append = "mono-doc mono mono-runtime"
+
+#FILES_mono-doc_append = " /usr/share/libgc-mono/ "
+
+FILES_mono = ""
+ALLOW_EMPTY_mono = "1"
+RDEPENDS_mono = "mono-common mono-jit"
+
+FILES_mono-runtime = ""
+ALLOW_EMPTY_mono-runtime = "1"
+RDEPENDS_mono-runtime = "mono-jit mono-gac"
+
+RDEPENDS_mono-jit = "mono-common"
+
+FILES_libmono-dev =+ " /usr/lib/libmono.la /usr/lib/libmono-profiler-cov.la /usr/lib/libmono-profiler-aot.la \
+ /usr/lib/libMonoPosixHelper.la /usr/lib/libMonoSupportW.la"
+FILES_libmono-dbg =+ " /usr/lib/.debug/libmono*.so.* /usr/lib/.debug/libikvm-native.so \
+ /usr/lib/.debug/libMonoPosixHelper.so /usr/lib/.debug/libMonoSupportW.so"
+
+# Packages not included in Debian
+PACKAGES_prepend = "libnunit2.2-cil-dbg libnunit2.2-cil-dev libnunit2.2-cil \
+ libmono-cecil0.5-cil-dbg libmono-cecil0.5-cil-dev libmono-cecil0.5-cil \
+ libmono-db2-1.0-cil-dbg libmono-db2-1.0-cil-dev libmono-db2-1.0-cil"
+
+FILES_libnunit2.2-cil = "/usr/lib/mono/gac/nunit.*/2.2.* /usr/lib/mono/1.0/nunit.*.dll"
+FILES_libnunit2.2-cil-dev = "/usr/lib/pkgconfig/mono-nunit.pc"
+FILES_libnunit2.2-cil-dbg = "/usr/lib/mono/gac/nunit*/2.2.*/nunit.*.dll.mdb"
+
+FILES_libmono-cecil0.5-cil = "/usr/lib/mono/gac/Mono.Cecil/0.5.*"
+FILES_libmono-cecil0.5-cil-dbg = "/usr/lib/mono/gac/Mono.Cecil/0.5.0.1__0738eb9f132ed756/Mono.Cecil.dll.mdb"
+
+FILES_libmono-db2-1.0-cil = "/usr/lib/mono/gac/IBM.Data.DB2/1.0* /usr/lib/mono/1.0/IBM.Data.DB2.dll"
+FILES_libmono-db2-1.0-cil-dbg = "/usr/lib/mono/gac/IBM.Data.DB2/1.0*/IBM.Data.DB2.dll.mdb"
+
+# Move .pc files
+FILES_libmono-cairo1.0-cil-dev = "/usr/lib/pkgconfig/mono-cairo.pc"
+PACKAGES =+ " libmono-cairo1.0-cil-dev "
diff --git a/recipes/mono/mono_2.4.2.3.inc b/recipes/mono/mono_2.4.2.3.inc
new file mode 100644
index 0000000000..21e596090c
--- /dev/null
+++ b/recipes/mono/mono_2.4.2.3.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "Mono Programming Language"
+SECTION = "devel/mono"
+LICENSE = "GPL LGPL X11"
+
+SRC_URI = "http://ftp.novell.com/pub/mono/sources/mono/mono-2.4.2.3.tar.bz2"
+
+INC_PR = "r3"
+
+S = "${WORKDIR}/mono-2.4.2.3"
+
+do_fix_dolt_libtool() {
+ # look for libtool prefixed with HOST_SYS
+ sed -e "s/slash\}libtool/slash\}${HOST_SYS}-libtool/" -i acinclude.m4
+ echo No acinclude!
+}
+
+inherit autotools
+EXTRA_OECONF_arm = "--without-tls"
+EXTRA_OECONF_mipsel = "--without-tls"
+
+addtask fix_dolt_libtool after do_patch before do_configure
diff --git a/recipes/mono/mono_svn.bb b/recipes/mono/mono_svn.bb
index a5ba966796..311d2a38dd 100644
--- a/recipes/mono/mono_svn.bb
+++ b/recipes/mono/mono_svn.bb
@@ -5,7 +5,7 @@ DEPENDS = "mono-native mono-mcs-intermediate glib-2.0 perl-native"
PR = "r0"
DEFAULT_PREFERENCE = "-1"
-SRC_URI += "file://configure-svnr87352.patch;patch=1"
+SRC_URI += ""
# Per http://www.mono-project.com/Mono:ARM
EXTRA_OECONF += " --disable-mcs-build "
@@ -37,7 +37,7 @@ do_install_append() {
inherit mono
# Import file definitions from Debian
-require mono_1.2.5.1-files.inc
+require mono_2.x-files.inc
# Add some packages
PACKAGES_append = " mono-doc mono mono-runtime"
diff --git a/recipes/tasks/task-beagleboard-demo.bb b/recipes/tasks/task-beagleboard-demo.bb
index 0f24dc9a23..95b42ae34b 100644
--- a/recipes/tasks/task-beagleboard-demo.bb
+++ b/recipes/tasks/task-beagleboard-demo.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Task for Beagleboard-demo-image"
-PR = "r10"
+PR = "r12"
inherit task
@@ -15,10 +15,10 @@ RDEPENDS_${PN} = "\
angstrom-zeroconf-audio \
angstrom-led-config \
gpe-scap \
- mime-support e-wm ${ECONFIG} exhibit \
+ mime-support e-wm ${ECONFIG} \
xterm xmms \
firefox midori \
- swfdec-mozilla \
+ gnash gnash-browser-plugin \
hicolor-icon-theme gnome-icon-theme \
jaaa nmap iperf gnuplot \
abiword \