summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--packages/libogg/libtheora_1.0.bb18
2 files changed, 22 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 48e32e1bb0..1a924c1b28 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -12682,6 +12682,10 @@ sha256=413ac7973fb4a353d98079b4ace1adaa8dcf8ce858113544c1ddb45660441b91
md5=490ca1a0c614d4466394b72d43bf7370
sha256=e0d230be855125163579743418203c6f6be2f10f98c4f065735c1dc9ed115878
+[http://downloads.xiph.org/releases/theora/libtheora-1.0.tar.bz2]
+md5=c963937053f45a7878954bed37ceb182
+sha256=3ae9df56e8fc75ffe26e63a13cae2ce79d079416175fb0baffe0e2de8dc91a6d
+
[http://downloads.xiph.org/releases/theora/libtheora-1.0alpha7.tar.gz]
md5=55ee3c6db3e0927e7918309891a8f52b
sha256=f5c7730ded0273a8615b12b46a32b800bbcb9e861e3a18aa92b1c062981a2fef
diff --git a/packages/libogg/libtheora_1.0.bb b/packages/libogg/libtheora_1.0.bb
new file mode 100644
index 0000000000..55d3e83beb
--- /dev/null
+++ b/packages/libogg/libtheora_1.0.bb
@@ -0,0 +1,18 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2"
+
+inherit autotools lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+