summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/sdl.bbclass5
-rw-r--r--packages/abuse/abuse_0.7.0.bb3
-rw-r--r--packages/vectoroids/vectoroids_1.1.0.bb36
3 files changed, 20 insertions, 24 deletions
diff --git a/classes/sdl.bbclass b/classes/sdl.bbclass
index d458a144c7..f6774be62e 100644
--- a/classes/sdl.bbclass
+++ b/classes/sdl.bbclass
@@ -13,11 +13,12 @@ sdl_do_sdl_install() {
install -d ${D}${palmtopdir}/pics
install -d ${D}${palmtopdir}/apps/Games
ln -sf ${bindir}/${APPNAME} ${D}${palmtopdir}/bin/${APPNAME}
- install -m 0644 ${APPIMAGE} ${D}${palmtopdir}/pics/${APPIMAGE}
+ install -m 0644 ${APPIMAGE} ${D}${palmtopdir}/pics/${PN}.png
if [ -e "${APPDESKTOP}" ]
then
- install -m 0644 ${APPDESKTOP} ${D}${palmtopdir}/Games/${APPDESKTOP}
+ echo ${APPDESKTOP} present, installing to palmtopdir...
+ install -m 0644 ${APPDESKTOP} ${D}${palmtopdir}/apps/Games/${PN}.desktop
else
echo ${APPDESKTOP} not present, creating one on-the-fly...
cat >${D}${palmtopdir}/apps/Games/${PN}.desktop <<EOF
diff --git a/packages/abuse/abuse_0.7.0.bb b/packages/abuse/abuse_0.7.0.bb
index c918564627..17280718b8 100644
--- a/packages/abuse/abuse_0.7.0.bb
+++ b/packages/abuse/abuse_0.7.0.bb
@@ -1,7 +1,6 @@
-DESCRIPTION = "Abuse-SDL is a port of Abuse by Crack Dot Com to Linux using the Simple DirectMedia Layer library."
+DESCRIPTION = "Abuse-SDL is a port of Abuse by Crack Dot Com to Linux - SDL edition."
SECTION = "games"
LICENSE = "GPL"
-DEPENDS = "virtual/libsdl libsdl-mixer libsdl-image"
APPNAME = "abuse.sdl"
SRC_URI = "http://www.labyrinth.net.au/~trandor/abuse/files/abuse_sdl-${PV}.tar.bz2"
diff --git a/packages/vectoroids/vectoroids_1.1.0.bb b/packages/vectoroids/vectoroids_1.1.0.bb
index a283b023ce..cd8580d896 100644
--- a/packages/vectoroids/vectoroids_1.1.0.bb
+++ b/packages/vectoroids/vectoroids_1.1.0.bb
@@ -1,35 +1,31 @@
-DESCRIPTION = "Clone of the classic arcade game Asteroids for Qtopia/Opie - based on SDL"
+DESCRIPTION = "Clone of the classic arcade game Asteroids - SDL edition."
SECTION = "opie/games"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-DEPENDS = "virtual/libqpe libsdl-qpe libsdl-image libsdl-mixer"
-PR = "r1"
+PR = "r2"
+
+APPIMAGE = "data/images/icon.png"
+APPNAME = "vectoroids-${PV}"
SRC_URI = "ftp://ftp.billsgames.com/unix/x/vectoroids/src/vectoroids-${PV}.tar.gz"
-inherit palmtop
+inherit qmake sdl
-EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/SDL LIBS+=-lSDL LIBS+=-lSDL_mixer \
- LIBS+=-lSDLmain LIBS+=-lSDL_image LIBS+=-lpthread LIBS+=-lqpe CONFIG+=qte"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/SDL CONFIG-=qt \
+ LIBS+=-lSDL \
+ LIBS+=-lSDL_mixer \
+ LIBS+=-lSDL_image \
+ LIBS+=-lpthread \
+ DEFINES+=DATA_PREFIX=\\"\"${datadir}/vectoroids/\\"\""
do_configure_prepend() {
qmake -project vectoroids.pro
}
do_install() {
- install -d ${D}${palmtopdir}/apps/Games \
- ${D}${palmtopdir}/pics \
- ${D}${palmtopdir}/share/vectoroids \
- ${D}${palmtopdir}/bin
- install -m 0755 vectoroids-${PV} ${D}${palmtopdir}/bin/vectoroids
- install -m 0644 data/images/icon.png ${D}${palmtopdir}/pics/vectoroids.png
- cp -pPR data/* ${D}${palmtopdir}/share/vectoroids
-
- echo "[Desktop Entry]" >${D}${palmtopdir}/apps/Games/vectoroids.desktop
- echo "Comment=Asteroids game" >>${D}${palmtopdir}/apps/Games/vectoroids.desktop
- echo "Exec=vectoroids" >>${D}${palmtopdir}/apps/Games/vectoroids.desktop
- echo "Icon=vectoroids" >>${D}${palmtopdir}/apps/Games/vectoroids.desktop
- echo "Type=Application" >>${D}${palmtopdir}/apps/Games/vectoroids.desktop
- echo "Name=Vectoroids" >>${D}${palmtopdir}/apps/Games/vectoroids.desktop
+ install -d ${D}${bindir}
+ install -m 0755 ${APPNAME} ${D}${bindir}
+ install -d ${D}${datadir}/vectoroids/
+ cp -pPR data/* ${D}${datadir}/vectoroids/
}