summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes/abiword/abiword_2.8.1.bb15
-rwxr-xr-xrecipes/abiword/files/autogen-common.sh28
-rw-r--r--recipes/abiword/files/nodolt.patch12
-rw-r--r--recipes/gnome/goffice/nodolt.patch12
-rw-r--r--recipes/gnome/goffice_0.7.14.bb3
-rw-r--r--recipes/libgmime/files/nodolt.patch12
-rw-r--r--recipes/libgmime/gmime_2.4.10.bb3
-rw-r--r--recipes/libwmf/libwmf-native_0.2.8.4.bb4
-rw-r--r--recipes/libwmf/libwmf_0.2.8.4.bb12
-rw-r--r--recipes/xorg-driver/xf86-video-intel/nodolt.patch12
-rw-r--r--recipes/xorg-driver/xf86-video-intel_2.9.1.bb2
11 files changed, 110 insertions, 5 deletions
diff --git a/recipes/abiword/abiword_2.8.1.bb b/recipes/abiword/abiword_2.8.1.bb
index 8f9bbee2ee..34a03479c8 100644
--- a/recipes/abiword/abiword_2.8.1.bb
+++ b/recipes/abiword/abiword_2.8.1.bb
@@ -1,8 +1,10 @@
require abiword-2.5.inc
-PR = "r2"
+PR = "r3"
-SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://autogen-common.sh \
+ file://nodolt.patch;patch=1"
do_configure() {
autotools_do_configure
@@ -13,8 +15,9 @@ EXTRA_OECONF = " --disable-static \
--enable-collab-backend-xmpp \
--enable-collab-backend-tcp \
--enable-collab-backend-service \
+ --with-libwmf-config=${STAGING_DIR} \
"
-
+DEPENDS += " libwmf-native "
RCONFLICTS = "abiword-embedded"
FILES_${PN} += "${libdir}/libabiword-*.so ${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/certs ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
@@ -23,6 +26,12 @@ FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profil
PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
+do_configure_prepend () {
+ install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
+ cd ${S}
+ ./autogen-common.sh
+}
+
python populate_packages_prepend () {
abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
diff --git a/recipes/abiword/files/autogen-common.sh b/recipes/abiword/files/autogen-common.sh
new file mode 100755
index 0000000000..c1f10e1a4d
--- /dev/null
+++ b/recipes/abiword/files/autogen-common.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# find plugins Makefile templates
+find plugins -name Makefile.am | sed 's|.am$||g' > plugin-makefiles.m4
+
+# create plugin list
+(cd plugins && find . -maxdepth 1 -type d | grep -v '^\.$' | grep -v '\./\.' | sed 's|\./||g' | xargs echo) > plugin-list.m4
+
+# create conditionals for builtin plugins
+(for plugin in `cat plugin-list.m4`; do
+ u=`echo $plugin | tr '[:lower:]' '[:upper:]'`
+ echo 'AM_CONDITIONAL(['$u'_BUILTIN], test "$enable_'$plugin'_builtin" == "yes")'
+done) > plugin-builtin.m4
+
+# create plugin configuration
+find plugins -name plugin.m4 | xargs cat > plugin-configure.m4
+#to debug if plugin configuration code misbehaves (instead of the above line):
+#rm plugin-configure.m4
+#for f in $(find plugins -name plugin.m4); do
+# echo "AC_MSG_RESULT([plugin: $f])" >> plugin-configure.m4
+# cat $f >> plugin-configure.m4
+#done
+
+# find extra m4 files provided by plugins and symlink them
+for f in ` find ./plugins -name '*.m4' | grep -v 'plugin\.m4'`; do
+ ln -sf $f
+done
+
diff --git a/recipes/abiword/files/nodolt.patch b/recipes/abiword/files/nodolt.patch
new file mode 100644
index 0000000000..1546720804
--- /dev/null
+++ b/recipes/abiword/files/nodolt.patch
@@ -0,0 +1,12 @@
+Index: abiword-2.8.1/configure.in
+===================================================================
+--- abiword-2.8.1.orig/configure.in
++++ abiword-2.8.1/configure.in
+@@ -132,7 +132,6 @@ AC_PROG_INSTALL
+ #AC_DISABLE_STATIC
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+-DOLT
+ AC_PROG_LN_S
+
+ AC_MSG_CHECKING([for platform and toolkit])
diff --git a/recipes/gnome/goffice/nodolt.patch b/recipes/gnome/goffice/nodolt.patch
new file mode 100644
index 0000000000..ea1777a996
--- /dev/null
+++ b/recipes/gnome/goffice/nodolt.patch
@@ -0,0 +1,12 @@
+Index: goffice-0.7.14/configure.in
+===================================================================
+--- goffice-0.7.14.orig/configure.in
++++ goffice-0.7.14/configure.in
+@@ -71,7 +71,6 @@ AC_PROG_YACC
+ AM_PROG_LEX
+ AC_PROG_LN_S
+ AM_PROG_LIBTOOL
+-DOLT
+ AC_STDC_HEADERS
+ AC_SYS_LARGEFILE
+
diff --git a/recipes/gnome/goffice_0.7.14.bb b/recipes/gnome/goffice_0.7.14.bb
index beb23231db..828e6a270a 100644
--- a/recipes/gnome/goffice_0.7.14.bb
+++ b/recipes/gnome/goffice_0.7.14.bb
@@ -7,7 +7,8 @@ DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2
inherit gnome pkgconfig
-SRC_URI += "file://c99math.patch;patch=1"
+SRC_URI += " file://c99math.patch;patch=1 \
+ file://nodolt.patch;patch=1 "
do_stage() {
autotools_stage_all
diff --git a/recipes/libgmime/files/nodolt.patch b/recipes/libgmime/files/nodolt.patch
new file mode 100644
index 0000000000..e4d5259c7b
--- /dev/null
+++ b/recipes/libgmime/files/nodolt.patch
@@ -0,0 +1,12 @@
+Index: gmime-2.4.10/configure.in
+===================================================================
+--- gmime-2.4.10.orig/configure.in
++++ gmime-2.4.10/configure.in
+@@ -80,7 +80,6 @@ AC_PATH_PROG(TAR, tar, /bin/tar)
+
+ AC_EXEEXT
+ AC_PROG_LIBTOOL
+-DOLT
+
+ AM_MAINTAINER_MODE
+
diff --git a/recipes/libgmime/gmime_2.4.10.bb b/recipes/libgmime/gmime_2.4.10.bb
index d455f3339e..cddaac902e 100644
--- a/recipes/libgmime/gmime_2.4.10.bb
+++ b/recipes/libgmime/gmime_2.4.10.bb
@@ -7,7 +7,8 @@ DEPENDS = "glib-2.0 zlib"
inherit gnome autotools_stage lib_package binconfig
SRC_URI += " \
- file://iconv-detect.h"
+ file://iconv-detect.h \
+ file://nodolt.patch;patch=1"
EXTRA_OECONF += "--disable-mono"
diff --git a/recipes/libwmf/libwmf-native_0.2.8.4.bb b/recipes/libwmf/libwmf-native_0.2.8.4.bb
new file mode 100644
index 0000000000..a33461fcdb
--- /dev/null
+++ b/recipes/libwmf/libwmf-native_0.2.8.4.bb
@@ -0,0 +1,4 @@
+require libwmf_0.2.8.4.bb
+inherit native
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/libwmf/${PV}/libwmf-${PV}.tar.gz;name=tarball"
diff --git a/recipes/libwmf/libwmf_0.2.8.4.bb b/recipes/libwmf/libwmf_0.2.8.4.bb
new file mode 100644
index 0000000000..fc02940eb3
--- /dev/null
+++ b/recipes/libwmf/libwmf_0.2.8.4.bb
@@ -0,0 +1,12 @@
+inherit autotools_stage
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/${PN}/${PV}/${P}.tar.gz;name=tarball"
+SRC_URI[tarball.md5sum] = "d1177739bf1ceb07f57421f0cee191e0"
+SRC_URI[tarball.sha256sum] = "5b345c69220545d003ad52bfd035d5d6f4f075e65204114a9e875e84895a7cf8"
+
+DESCRIPTION = "Library for converting WMF files"
+HOMEPAGE = "http://wvware.sourceforge.net/libwmf.html"
+LICENSE = "GPL-2"
+
+SECTION = "libs"
+
diff --git a/recipes/xorg-driver/xf86-video-intel/nodolt.patch b/recipes/xorg-driver/xf86-video-intel/nodolt.patch
new file mode 100644
index 0000000000..c5c0e7b1a2
--- /dev/null
+++ b/recipes/xorg-driver/xf86-video-intel/nodolt.patch
@@ -0,0 +1,12 @@
+Index: xf86-video-intel-2.9.1/configure.ac
+===================================================================
+--- xf86-video-intel-2.9.1.orig/configure.ac
++++ xf86-video-intel-2.9.1/configure.ac
+@@ -42,7 +42,6 @@ AC_CONFIG_FILES([
+ # Checks for programs.
+ AC_DISABLE_STATIC
+ AC_PROG_LIBTOOL
+-DOLT
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+
diff --git a/recipes/xorg-driver/xf86-video-intel_2.9.1.bb b/recipes/xorg-driver/xf86-video-intel_2.9.1.bb
index eed1fcb600..a8faf54643 100644
--- a/recipes/xorg-driver/xf86-video-intel_2.9.1.bb
+++ b/recipes/xorg-driver/xf86-video-intel_2.9.1.bb
@@ -3,3 +3,5 @@ require xorg-driver-video.inc
DESCRIPTION = "X.Org X server -- Intel i8xx, i9xx display driver"
DEPENDS += " virtual/libx11 libxvmc drm xf86driproto"
PE = "1"
+
+SRC_URI += " file://nodolt.patch;patch=1 "