summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--nonworking/ltrace/ltrace_0.3.35.oe (renamed from nonworking/ltrace/ltrace_0.3.34.oe)0
-rw-r--r--pcmcia-cs/files/network.conf0
-rw-r--r--pcmcia-cs/pcmcia-cs_3.2.8.oe78
-rw-r--r--qte/qte-2.3.7/qpe.patch100
-rw-r--r--qte/qte_2.3.7.oe2
5 files changed, 179 insertions, 1 deletions
diff --git a/nonworking/ltrace/ltrace_0.3.34.oe b/nonworking/ltrace/ltrace_0.3.35.oe
index e69de29bb2..e69de29bb2 100644
--- a/nonworking/ltrace/ltrace_0.3.34.oe
+++ b/nonworking/ltrace/ltrace_0.3.35.oe
diff --git a/pcmcia-cs/files/network.conf b/pcmcia-cs/files/network.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/pcmcia-cs/files/network.conf
diff --git a/pcmcia-cs/pcmcia-cs_3.2.8.oe b/pcmcia-cs/pcmcia-cs_3.2.8.oe
index e69de29bb2..433092e8da 100644
--- a/pcmcia-cs/pcmcia-cs_3.2.8.oe
+++ b/pcmcia-cs/pcmcia-cs_3.2.8.oe
@@ -0,0 +1,78 @@
+DESCRIPTION = "Utilities and system configuration files for the Linux PCMCIA card services"
+SECTION = "base"
+PRIORITY = "required"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
+ file://busybox.patch;patch=1 \
+ file://network.patch;patch=1 \
+ file://ide.opts \
+ file://wireless.opts \
+ file://network.conf"
+S = "${WORKDIR}/pcmcia-cs-${PV}"
+
+INITSCRIPT_NAME = "pcmcia"
+INITSCRIPT_PARAMS = "defaults"
+
+inherit update-rc.d
+
+export KERNEL_SOURCE = ${@base_read_file('${STAGING_DIR}/${HOST_SYS}/kernel/kernel-source')}
+
+sbindir = "/sbin"
+
+do_configure() {
+ touch .prereq.ok
+ touch config.out
+ cat >config.mk <<EOF
+UCC=${CC}
+UFLAGS=${CFLAGS} -I${S}/include
+HAS_WORDEXP=y
+SYSV_INIT=y
+RC_DIR=/etc
+CONFIG_PNP_BIOS=n
+ARCH=${ARCH}
+CONFIG_CARDBUS=n
+CONFIG_PCMCIA=y
+CONFIG_INET=y
+CONFIG_SCSI=y
+DO_IDE=y
+EOF
+ cat >include/pcmcia/autoconf.h <<EOF
+#define HAS_WORDEXP 1
+EOF
+}
+
+do_compile() {
+ oe_runmake all HAS_XPM= FLIBS="" XMANDIR=""
+}
+
+INSTALL_ETC = "ftl ide ieee1394 memory network parport scsi serial wireless"
+INSTALL_ETC_DATA = "config config.opts ftl.opts ieee1394.opts memory.opts network.opts parport.opts scsi.opts serial.opts shared"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ for f in cardmgr/cardctl cardmgr/cardmgr cardmgr/ide_info cardmgr/ifport cardmgr/ifuser cardmgr/pcinitrd flash/ftl_check flash/ftl_format
+ do
+ install -m 0755 $f ${D}/${sbindir}/
+ done
+ install -d ${D}/${sysconfdir}/init.d \
+ ${D}/${sysconfdir}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia/cis
+ install -m 0644 ${WORKDIR}/network.conf ${D}/${sysconfdir}/pcmcia/
+ for i in ${INSTALL_ETC}; do
+ install etc/${i} ${D}/${sysconfdir}/pcmcia/
+ done
+ for i in ${INSTALL_ETC_DATA}; do
+ install -m 0644 etc/${i} ${D}/${sysconfdir}/pcmcia/
+ done
+ install -m 0644 ${WORKDIR}/ide.opts ${D}/${sysconfdir}/pcmcia/
+ install -m 0644 ${WORKDIR}/wireless.opts ${D}/${sysconfdir}/pcmcia/
+ for i in etc/cis/*; do
+ install -m 0644 $i ${D}/${sysconfdir}/pcmcia/cis/
+ done
+ install -m 0755 etc/rc.pcmcia ${D}/${sysconfdir}/init.d/pcmcia
+}
+
+FILES_${PN} = "${sbindir} ${sysconfdir}"
diff --git a/qte/qte-2.3.7/qpe.patch b/qte/qte-2.3.7/qpe.patch
index e69de29bb2..4aa92180de 100644
--- a/qte/qte-2.3.7/qpe.patch
+++ b/qte/qte-2.3.7/qpe.patch
@@ -0,0 +1,100 @@
+--- /dev/null
++++ qt-2.3.6/src/tools/qconfig-qpe.h
+@@ -0,0 +1,97 @@
++/**********************************************************************
++** Copyright (C) 2000 Trolltech AS. All rights reserved.
++**
++** This file is part of Qtopia Environment.
++**
++** This file may be distributed and/or modified under the terms of the
++** GNU General Public License version 2 as published by the Free Software
++** Foundation and appearing in the file LICENSE.GPL included in the
++** packaging of this file.
++**
++** This file is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING THE
++** WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
++**
++** See http://www.trolltech.com/gpl/ for GPL licensing information.
++**
++** Contact info@trolltech.com if any conditions of this licensing are
++** not clear to you.
++**
++**********************************************************************/
++#ifndef QT_H
++#endif // QT_H
++
++// Empty leaves all features enabled. See doc/html/features.html for choices.
++
++// Note that disabling some features will produce a libqt that is not
++// compatible with other libqt builds. Such modifications are only
++// supported on Qt/Embedded where reducing the library size is important
++// and where the application-suite is often a fixed set.
++
++#ifndef QT_DLL
++#define QT_DLL // Internal
++#endif
++
++#define QT_NO_QWS_CURSOR
++#define QT_NO_QWS_MOUSE_AUTO
++#ifndef QT_NO_CODECS
++#define QT_NO_CODECS
++#endif
++#define QT_NO_UNICODETABLES
++//#define QT_NO_IMAGEIO_BMP
++#define QT_NO_IMAGEIO_PPM
++//#define QT_NO_ASYNC_IO
++//#define QT_NO_ASYNC_IMAGE_IO
++#define QT_NO_FREETYPE
++#define QT_NO_BDF
++//#define QT_NO_FONTDATABASE
++#define QT_NO_DRAGANDDROP
++//#define QT_NO_CLIPBOARD
++#define QT_NO_PROPERTIES
++#define QT_NO_NETWORKPROTOCOL
++
++#define QT_NO_IMAGE_TEXT
++
++//#define QT_NO_TOOLTIP
++#define QT_NO_COLORNAMES
++#define QT_NO_TRANSFORMATIONS
++#define QT_NO_TRANSLATION_BUILDER
++#define QT_NO_COMPLEXTEXT
++#define QT_NO_PRINTER
++#define QT_NO_PICTURE
++//#define QT_NO_ICONVIEW
++#define QT_NO_DIAL
++#define QT_NO_SIZEGRIP
++#define QT_NO_WORKSPACE
++//#define QT_NO_TABLE
++//#define QT_NO_ACTION
++//#define QT_NO_SETTINGS
++#define QT_NO_STYLE_POCKETPC
++#ifndef QT_NO_STYLE_AQUA
++# define QT_NO_STYLE_AQUA
++#endif
++#define QT_NO_STYLE_MOTIF
++#define QT_NO_STYLE_PLATINUM
++#define QT_NO_FILEDIALOG
++#define QT_NO_FONTDIALOG
++#define QT_NO_PRINTDIALOG
++#define QT_NO_COLORDIALOG
++#define QT_NO_INPUTDIALOG
++//#define QT_NO_MESSAGEBOX
++#define QT_NO_PROGRESSDIALOG
++//#define QT_NO_TABDIALOG
++#define QT_NO_WIZARD
++#define QT_NO_EFFECTS
++//#define QT_NO_COMPONENT
++#define QT_NO_DOM
++#define QT_NO_SEMIMODAL
++//#define QT_NO_PROGRESSBAR
++#define QT_NO_SPLITTER
++
++//#define QT_NO_QWS_SAVEFONTS
++//#define QT_NO_QWS_PROPERTIES
++
++#define QT_NO_QWS_BEOS_WM_STYLE
++#define QT_NO_QWS_KDE2_WM_STYLE
++#define QT_NO_QWS_KDE_WM_STYLE
++#define QT_NO_QWS_WINDOWS_WM_STYLE
++
diff --git a/qte/qte_2.3.7.oe b/qte/qte_2.3.7.oe
index 03d3431bcc..fd5ed9c771 100644
--- a/qte/qte_2.3.7.oe
+++ b/qte/qte_2.3.7.oe
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL/QPL"
DEPENDS = "zlib libpng jpeg tslib uicmoc-native"
PROVIDES = "virtual/qte virtual/libqte2"
-PR = "r12"
+PR = "r13"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}.tar.gz \
file://qpe.patch;patch=1 \