summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/insane-srcrevs.inc2
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--packages/opie-ttf-support/files/02qtttffont-update6
-rw-r--r--packages/opie-ttf-support/opie-ttf-support_1.1.bb19
-rw-r--r--packages/opkg/.mtn2git_empty0
-rw-r--r--packages/opkg/opkg-native_svn.bb8
-rw-r--r--packages/opkg/opkg_svn.bb26
7 files changed, 50 insertions, 13 deletions
diff --git a/conf/distro/include/insane-srcrevs.inc b/conf/distro/include/insane-srcrevs.inc
index e039a144d3..0f7e82ef43 100644
--- a/conf/distro/include/insane-srcrevs.inc
+++ b/conf/distro/include/insane-srcrevs.inc
@@ -81,6 +81,8 @@ SRCREV_pn-openmoko-today2-folders ?= "${AUTOREV}"
SRCREV_pn-openmoko-worldclock2 ?= "${AUTOREV}"
SRCREV_pn-openocd ?= "${AUTOREV}"
SRCREV_pn-openocd-native ?= "${AUTOREV}"
+SRCREV_pn-opkg ?= "${AUTOREV}"
+SRCREV_pn-opkg-native ?= "${AUTOREV}"
SRCREV_pn-psplash ?= "${AUTOREV}"
SRCREV_pn-settings-daemon ?= "${AUTOREV}"
SRCREV_pn-sjf2410-linux-native ?= "${AUTOREV}"
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index ce8555bf1c..f46c954636 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -118,6 +118,8 @@ SRCREV_pn-openmoko-toolchain-scripts ?= "3767"
SRCREV_pn-openmoko-worldclock2 ?= "3365"
SRCREV_pn-openocd ?= "206"
SRCREV_pn-openocd-native ?= "206"
+SRCREV_pn-opkg ?= "4019"
+SRCREV_pn-opkg-native ?= "4019"
SRCREV_pn-oprofileui ?= "160"
SRCREV_pn-psplash ?= "249"
SRCREV_pn-python-formencode = "3148"
diff --git a/packages/opie-ttf-support/files/02qtttffont-update b/packages/opie-ttf-support/files/02qtttffont-update
new file mode 100644
index 0000000000..8f8058faea
--- /dev/null
+++ b/packages/opie-ttf-support/files/02qtttffont-update
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Author: Rolf Leggewie
+
+mkdir -p @@PALMTOPDIR@@/lib/fonts
+
+@@SBINDIR@@/update-qtttffontdir @@DATADIR@@/fonts/truetype > @@PALMTOPDIR@@/lib/fonts/fontdir
diff --git a/packages/opie-ttf-support/opie-ttf-support_1.1.bb b/packages/opie-ttf-support/opie-ttf-support_1.1.bb
index c6ed53ffbd..18ce7ac0c9 100644
--- a/packages/opie-ttf-support/opie-ttf-support_1.1.bb
+++ b/packages/opie-ttf-support/opie-ttf-support_1.1.bb
@@ -1,9 +1,10 @@
DESCRIPTION = "Meta-package for Opie TTF support"
SECTION = "opie/fonts"
DEPENDS = "freetype"
-PR = "r4"
+PR = "r5"
-SRC_URI = "file://update-qtttffontdir.c"
+SRC_URI = "file://update-qtttffontdir.c \
+ file://02qtttffont-update"
S = "${WORKDIR}"
do_compile() {
@@ -11,23 +12,15 @@ do_compile() {
}
do_install() {
-
- echo "
-#!/bin/sh
-# Author: Rolf Leggewie
-
-${sbindir}/update-qtttffontdir ${datadir}/fonts/truetype > ${palmtopdir}/lib/fonts/fontdir
-" > ${WORKDIR}/02qtttffont-update
-
install -d ${D}${sbindir}
install -d ${D}${sysconfdir}/update-fonts-common.d/
install -m 0755 update-qtttffontdir ${D}${sbindir}
install -m 0755 02qtttffont-update ${D}${sysconfdir}/update-fonts-common.d/
+ sed -i 's!@@SBINDIR@@!${sbindir}!g' ${D}${sysconfdir}/update-fonts-common.d/02qtttffont-update
+ sed -i 's!@@PALMTOPDIR@@!${palmtopdir}!g' ${D}${sysconfdir}/update-fonts-common.d/02qtttffont-update
+ sed -i 's!@@DATADIR@@!${datadir}!g' ${D}${sysconfdir}/update-fonts-common.d/02qtttffont-update
}
pkg_postinst() {
- if ! [ -d ${palmtopdir}/lib/fonts ]; then
- mkdir -p ${palmtopdir}/lib/fonts
- fi
${sysconfdir}/update-fonts-common.d/02qtttffont-update
}
diff --git a/packages/opkg/.mtn2git_empty b/packages/opkg/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/opkg/.mtn2git_empty
diff --git a/packages/opkg/opkg-native_svn.bb b/packages/opkg/opkg-native_svn.bb
new file mode 100644
index 0000000000..2215a5798c
--- /dev/null
+++ b/packages/opkg/opkg-native_svn.bb
@@ -0,0 +1,8 @@
+require opkg_svn.bb
+
+target_libdir := "${libdir}"
+
+inherit native
+
+EXTRA_OECONF += "--with-opkglibdir=${target_libdir}/opkg -disable-gpg"
+
diff --git a/packages/opkg/opkg_svn.bb b/packages/opkg/opkg_svn.bb
new file mode 100644
index 0000000000..51c83f8968
--- /dev/null
+++ b/packages/opkg/opkg_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Open Package Manager"
+DESCRIPTION_libipkg = "Open Package Manager Library"
+SECTION = "base"
+LICENSE = "GPL"
+DEPENDS = "curl gpgme"
+PV = "0.0+svnr${SRCREV}"
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http"
+
+S = "${WORKDIR}/opkg"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -so libopkg ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libopkg/
+ for f in *.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/libopkg/
+ done
+}
+
+PACKAGES =+ "libopkg-dev libopkg"
+
+FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
+FILES_libopkg = "${libdir}/*.so.*"
+