summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/h2200.conf24
-rw-r--r--conf/machine/h4000.conf22
-rw-r--r--conf/machine/include/LAB-settings.conf8
-rw-r--r--packages/granule/.mtn2git_empty0
-rw-r--r--packages/granule/granule_1.2.2.bb12
-rw-r--r--packages/granule/libassa_3.4.2.bb17
6 files changed, 56 insertions, 27 deletions
diff --git a/conf/machine/h2200.conf b/conf/machine/h2200.conf
index 1ead1aa919..a074eec4e9 100644
--- a/conf/machine/h2200.conf
+++ b/conf/machine/h2200.conf
@@ -3,30 +3,26 @@
#@DESCRIPTION: Machine configuration for the HP iPAQ h22xx
+# Hardware-based properties
TARGET_ARCH = "arm"
IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+include conf/machine/include/tune-xscale.conf
+ROOT_FLASH_SIZE = "32"
+GUI_MACHINE_CLASS = "smallscreen"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia bluetooth irda usbgadget"
+# Software/package selection
+PCMCIA_MANAGER = "pcmciautils"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
-EXTRA_IMAGECMD_jffs2 = "--pad --eraseblock=0x4000"
-
-ROOT_FLASH_SIZE = "32"
-PCMCIA_MANAGER = "pcmciautils"
-
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia bluetooth irda usbgadget"
-
MACHINE_EXTRA_RDEPENDS = "mtd-utils h2200-bootloader kernel"
+EXTRA_IMAGECMD_jffs2 = "--pad --eraseblock=0x4000"
-#autoload on boot:
+# Modules autoload and other boot properties
module_autoload_snd-pcm-oss = "snd-pcm-oss"
SERIAL_CONSOLE = "115200 ttyS0 vt100"
USE_VT = "0"
-GUI_MACHINE_CLASS = "smallscreen"
-
-include conf/machine/include/tune-xscale.conf
-
-# LAB can only resolve relative symlinks
-ROOTFS_POSTPROCESS_COMMAND += "make_zimage_symlink_relative; "
+include conf/machine/include/LAB-settings.conf
diff --git a/conf/machine/h4000.conf b/conf/machine/h4000.conf
index a9adfe4486..cff0a94392 100644
--- a/conf/machine/h4000.conf
+++ b/conf/machine/h4000.conf
@@ -2,28 +2,24 @@
#@NAME: HP iPAQ h4xxx
#@DESCRIPTION: Machine configuration for the HP iPAQ h4xxx
-
+# Hardware-based properties
TARGET_ARCH = "arm"
IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+include conf/machine/include/tune-xscale.conf
+ROOT_FLASH_SIZE = "32"
+GUI_MACHINE_CLASS = "smallscreen"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda bluetooth wifi usbgadget"
+# Software/package selection
+PCMCIA_MANAGER = "pcmciautils"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
-ROOT_FLASH_SIZE = "32"
-PCMCIA_MANAGER = "pcmciautils"
-
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda bluetooth wifi usbgadget"
-
-#autoload on boot:
+# Modules autoload and other boot properties
module_autoload_snd-pcm-oss = "snd-pcm-oss"
module_autoload_g_ether = "g_ether"
SERIAL_CONSOLE = "115200 ttyS0 vt100"
USE_VT = "0"
-GUI_MACHINE_CLASS = "smallscreen"
-
-include conf/machine/include/tune-xscale.conf
-
-# LAB can only resolve relative symlinks
-ROOTFS_POSTPROCESS_COMMAND += "make_zimage_symlink_relative; "
+include conf/machine/include/LAB-settings.conf
diff --git a/conf/machine/include/LAB-settings.conf b/conf/machine/include/LAB-settings.conf
new file mode 100644
index 0000000000..576846fbdf
--- /dev/null
+++ b/conf/machine/include/LAB-settings.conf
@@ -0,0 +1,8 @@
+#
+# Settings for LAB (Linux As Bootloader) support.
+# Machines which support (or want to support) LAB,
+# include this.
+#
+
+# LAB can only resolve relative symlinks
+ROOTFS_POSTPROCESS_COMMAND += "make_zimage_symlink_relative; "
diff --git a/packages/granule/.mtn2git_empty b/packages/granule/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/granule/.mtn2git_empty
diff --git a/packages/granule/granule_1.2.2.bb b/packages/granule/granule_1.2.2.bb
new file mode 100644
index 0000000000..b92dfa6b73
--- /dev/null
+++ b/packages/granule/granule_1.2.2.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Generic memory training with flash cards. Automatic scheduling algorithm."
+AUTHOR = "Vladislav Grinchenko <vlg@users.sourceforge.net>"
+HOMEPAGE = "http://granule.sf.net"
+# SECTION
+# PRIORITY
+LICENSE = "GPLv2"
+DEPENDS = "glib-2.0-native intltool-native gtkmm libxml2 libassa"
+PR = "preview0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/packages/granule/libassa_3.4.2.bb b/packages/granule/libassa_3.4.2.bb
new file mode 100644
index 0000000000..675c964697
--- /dev/null
+++ b/packages/granule/libassa_3.4.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "object-oriented C++ networking library based on Adaptive Communication Patterns."
+AUTHOR = "Vladislav Grinchenko <vlg@users.sourceforge.net>"
+HOMEPAGE = "http://libassa.sf.net"
+#SECTION = ?
+#PRIORITY = ?
+LICENSE = "LGPL"
+#DEPENDS = ""
+PR = "r0"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}-2.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}