summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.16/92-nslu2-mac.patch2
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.16.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/packages/linux/ixp4xx-kernel/2.6.16/92-nslu2-mac.patch b/packages/linux/ixp4xx-kernel/2.6.16/92-nslu2-mac.patch
index 31c5f04ebe..1dd8e0eb61 100644
--- a/packages/linux/ixp4xx-kernel/2.6.16/92-nslu2-mac.patch
+++ b/packages/linux/ixp4xx-kernel/2.6.16/92-nslu2-mac.patch
@@ -24,7 +24,7 @@
+static struct sockaddr mac;
+
+static void nslu2_flash_add(struct mtd_info *mtd) {
-+ if (strcmp(mtd->name, "RedBoot config") == 0) {
++ if (strcmp(mtd->name, "RedBoot") == 0) {
+ size_t retlen;
+ int err;
+ /* the mac addr is at a known offset */
diff --git a/packages/linux/ixp4xx-kernel_2.6.16.bb b/packages/linux/ixp4xx-kernel_2.6.16.bb
index 66d1c38e42..854b86d047 100644
--- a/packages/linux/ixp4xx-kernel_2.6.16.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.16.bb
@@ -8,7 +8,7 @@ PR_CONFIG = "1"
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches
# applied to the kernel.
-PR = "r3.${PR_CONFIG}"
+PR = "r4.${PR_CONFIG}"
include ixp4xx-kernel.inc