summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes/shr/e-wm-menu-shr_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-menu-shr_git.bb b/recipes/shr/e-wm-menu-shr_git.bb
new file mode 100644
index 0000000000..94529e335a
--- /dev/null
+++ b/recipes/shr/e-wm-menu-shr_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "illume SHR applications.menu config"
+SECTION = "e/utils"
+LICENSE = "MIT BSD"
+PV = "1.1-${EFL_SRCREV}-gitr${SRCREV}"
+
+RPROVIDES_${PN} = "e-wm-menu"
+RCONFLICTS_${PN} = "e-wm-menu"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+FILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
+
+do_install() {
+ install -d ${D}${sysconfdir}/xdg/menus
+ install -m 0755 ${S}/applications.menu ${D}${sysconfdir}/xdg/menus/applications.menu
+}