summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/distutils.bbclass6
-rw-r--r--packages/python/python-cython-native_0.9.6.9.bb9
-rw-r--r--packages/python/python-cython_0.9.6.9.bb13
-rw-r--r--packages/python/python-ecore_cvs.bb6
-rw-r--r--packages/python/python-efl.bb7
-rw-r--r--packages/python/python-efl.inc10
-rw-r--r--packages/python/python-epsilon_cvs.bb4
7 files changed, 46 insertions, 9 deletions
diff --git a/classes/distutils.bbclass b/classes/distutils.bbclass
index 8af10a0c8a..18aee09a26 100644
--- a/classes/distutils.bbclass
+++ b/classes/distutils.bbclass
@@ -13,13 +13,15 @@ distutils_do_compile() {
}
distutils_stage_headers() {
+ install -d ${STAGING_DIR_HOST}${layout_prefix}/lib/${PYTHON_DIR}/site-packages
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python setup.py install_headers ${DISTUTILS_STAGE_HEADERS_ARGS} || \
oefatal "python setup.py install_headers execution failed."
}
distutils_stage_all() {
- install -d ${STAGING_DIR_HOST}${layout_prefix}/${PYTHON_DIR}/site-packages
+ install -d ${STAGING_DIR_HOST}${layout_prefix}/lib/${PYTHON_DIR}/site-packages
+ # is this missing a lib below?
PYTHONPATH=${STAGING_DIR_HOST}${layout_prefix}/${PYTHON_DIR}/site-packages \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_STAGE_ALL_ARGS} || \
@@ -49,7 +51,7 @@ distutils_do_install() {
done
fi
- rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/easy-install.pth
+ rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/easy-install.pth
}
EXPORT_FUNCTIONS do_compile do_install
diff --git a/packages/python/python-cython-native_0.9.6.9.bb b/packages/python/python-cython-native_0.9.6.9.bb
new file mode 100644
index 0000000000..cb7743e1bf
--- /dev/null
+++ b/packages/python/python-cython-native_0.9.6.9.bb
@@ -0,0 +1,9 @@
+require python-cython_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}
diff --git a/packages/python/python-cython_0.9.6.9.bb b/packages/python/python-cython_0.9.6.9.bb
new file mode 100644
index 0000000000..a513104108
--- /dev/null
+++ b/packages/python/python-cython_0.9.6.9.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "cython"
+PR = "ml0"
+
+SRC_URI = "http://www.cython.org/${SRCNAME}-${PV}.zip"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
diff --git a/packages/python/python-ecore_cvs.bb b/packages/python/python-ecore_cvs.bb
index 73c9f1d0b6..8f4db6382e 100644
--- a/packages/python/python-ecore_cvs.bb
+++ b/packages/python/python-ecore_cvs.bb
@@ -1,5 +1,9 @@
require python-efl.inc
DEPENDS += "ecore"
-PR = "r1"
+PR = "r2"
+
+do_stage() {
+ distutils_stage_all
+}
diff --git a/packages/python/python-efl.bb b/packages/python/python-efl.bb
new file mode 100644
index 0000000000..c667ceff11
--- /dev/null
+++ b/packages/python/python-efl.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Python Bindings to the Enlightenment Foundation Libraries"
+LICENSE = "MIT"
+SECTION = "devel/python"
+DEPENDS = "python-evas python-ecore python-emotion python-edje python-epsilon"
+
+ALLOW_EMPTY = "1"
+
diff --git a/packages/python/python-efl.inc b/packages/python/python-efl.inc
index aa12b979f8..727c718bd2 100644
--- a/packages/python/python-efl.inc
+++ b/packages/python/python-efl.inc
@@ -2,17 +2,15 @@ DESCRIPTION = "${PN} bindings"
LICENSE = "BSD"
AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
HOMEPAGE = "http://www.enlightenment.org"
-DEPENDS = "python-pyrex-native python-numeric"
+# somewhere is a bug. cython should be self-contained, but somehow this
+# does not compile unless pyrex has been built
+DEPENDS = "python-cython-native python-pyrex-native python-numeric"
PV = "0.1.1+cvs${SRCDATE}"
-inherit distutils
+inherit setuptools
SRC_URI = "${E_CVS};module=e17/proto/python-efl/${PN}"
S = "${WORKDIR}/${PN}"
-do_install_append() {
- rm ${D}${libdir}/${PYTHON_DIR}/site-packages/site.*
-}
-
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
diff --git a/packages/python/python-epsilon_cvs.bb b/packages/python/python-epsilon_cvs.bb
new file mode 100644
index 0000000000..81ebfcb0c7
--- /dev/null
+++ b/packages/python/python-epsilon_cvs.bb
@@ -0,0 +1,4 @@
+require python-efl.inc
+DEPENDS += "epsilon python-ecore"
+
+PR = "r0"