summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/base.bbclass2
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.16/defconfig14
-rw-r--r--packages/strace/strace-4.5.14/.mtn2git_empty0
-rw-r--r--packages/strace/strace-4.5.14/arm-eabi.patch65
-rw-r--r--packages/strace/strace_4.5.14.bb12
5 files changed, 85 insertions, 8 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 21feaab6e6..340e5d91f8 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -196,7 +196,7 @@ oe_libinstall() {
# stop libtool using the final directory name for libraries
# in staging:
__runcmd rm -f $destpath/$libname.la
- __runcmd sed -e 's/^installed=yes$/installed=no/' $dotlai >$destpath/$libname.la
+ __runcmd sed -e 's/^installed=yes$/installed=no/' -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${STAGING_LIBDIR}/\1,' $dotlai >$destpath/$libname.la
else
__runcmd install -m 0644 $dotlai $destpath/$libname.la
fi
diff --git a/packages/linux/ixp4xx-kernel/2.6.16/defconfig b/packages/linux/ixp4xx-kernel/2.6.16/defconfig
index 383b23c5e7..8548ed54b0 100644
--- a/packages/linux/ixp4xx-kernel/2.6.16/defconfig
+++ b/packages/linux/ixp4xx-kernel/2.6.16/defconfig
@@ -593,13 +593,13 @@ CONFIG_ATA_OVER_ETH=m
# SCSI device support
#
# CONFIG_RAID_ATTRS is not set
-CONFIG_SCSI=y
+CONFIG_SCSI=m
CONFIG_SCSI_PROC_FS=y
#
# SCSI support type (disk, tape, CD-ROM)
#
-CONFIG_BLK_DEV_SD=y
+CONFIG_BLK_DEV_SD=m
CONFIG_CHR_DEV_ST=m
# CONFIG_CHR_DEV_OSST is not set
CONFIG_BLK_DEV_SR=m
@@ -1302,14 +1302,14 @@ CONFIG_USB_DEVICEFS=y
#
# USB Host Controller Drivers
#
-CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_HCD=m
CONFIG_USB_EHCI_SPLIT_ISO=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
# CONFIG_USB_ISP116X_HCD is not set
-CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_HCD=m
# CONFIG_USB_OHCI_BIG_ENDIAN is not set
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
-CONFIG_USB_UHCI_HCD=y
+CONFIG_USB_UHCI_HCD=m
# CONFIG_USB_SL811_HCD is not set
#
@@ -1326,7 +1326,7 @@ CONFIG_USB_PRINTER=m
#
# may also be needed; see USB_STORAGE Help for more information
#
-CONFIG_USB_STORAGE=y
+CONFIG_USB_STORAGE=m
# CONFIG_USB_STORAGE_DEBUG is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_FREECOM is not set
@@ -1457,7 +1457,7 @@ CONFIG_USB_EZUSB=y
# CONFIG_USB_AUERSWALD is not set
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_LEGOTOWER is not set
-CONFIG_USB_LCD=m
+# CONFIG_USB_LCD is not set
# CONFIG_USB_LED is not set
# CONFIG_USB_CYTHERM is not set
# CONFIG_USB_PHIDGETKIT is not set
diff --git a/packages/strace/strace-4.5.14/.mtn2git_empty b/packages/strace/strace-4.5.14/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/strace/strace-4.5.14/.mtn2git_empty
diff --git a/packages/strace/strace-4.5.14/arm-eabi.patch b/packages/strace/strace-4.5.14/arm-eabi.patch
new file mode 100644
index 0000000000..53e27f8ce8
--- /dev/null
+++ b/packages/strace/strace-4.5.14/arm-eabi.patch
@@ -0,0 +1,65 @@
+2006-03-30 Daniel Jacobowitz <dan@codesourcery.com>
+
+ * process.c (change_syscall): Add ARM support.
+ * syscall.c (get_scno): Handle ARM EABI.
+
+Index: strace/process.c
+===================================================================
+--- strace.orig/process.c 2006-03-30 17:36:14.000000000 -0500
++++ strace/process.c 2006-03-30 17:44:16.000000000 -0500
+@@ -694,6 +694,16 @@ int new;
+ 0x100000 | new) < 0)
+ return -1;
+ return 0;
++#elif defined(ARM)
++ /* Some kernels support this, some (pre-2.6.16 or so) don't. */
++# ifndef PTRACE_SET_SYSCALL
++# define PTRACE_SET_SYSCALL 23
++# endif
++
++ if (ptrace (PTRACE_SET_SYSCALL, tcp->pid, 0, new) != 0)
++ return -1;
++
++ return 0;
+ #else
+ #warning Do not know how to handle change_syscall for this architecture
+ #endif /* architecture */
+Index: strace/syscall.c
+===================================================================
+--- strace.orig/syscall.c 2006-03-30 17:36:14.000000000 -0500
++++ strace/syscall.c 2006-03-30 17:44:16.000000000 -0500
+@@ -1108,16 +1108,25 @@ struct tcb *tcp;
+ return 0;
+ }
+
+- if ((scno & 0x0ff00000) != 0x0f900000) {
+- fprintf(stderr, "syscall: unknown syscall trap 0x%08lx\n",
+- scno);
+- return -1;
+- }
++ /* Handle the EABI syscall convention. We do not
++ bother converting structures between the two
++ ABIs, but basic functionality should work even
++ if strace and the traced program have different
++ ABIs. */
++ if (scno == 0xef000000) {
++ scno = regs.ARM_r7;
++ } else {
++ if ((scno & 0x0ff00000) != 0x0f900000) {
++ fprintf(stderr, "syscall: unknown syscall trap 0x%08lx\n",
++ scno);
++ return -1;
++ }
+
+- /*
+- * Fixup the syscall number
+- */
+- scno &= 0x000fffff;
++ /*
++ * Fixup the syscall number
++ */
++ scno &= 0x000fffff;
++ }
+ }
+
+ if (tcp->flags & TCB_INSYSCALL) {
diff --git a/packages/strace/strace_4.5.14.bb b/packages/strace/strace_4.5.14.bb
new file mode 100644
index 0000000000..cc15d962ae
--- /dev/null
+++ b/packages/strace/strace_4.5.14.bb
@@ -0,0 +1,12 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+PR = "r0"
+
+DESCRIPTION = "strace is a system call tracing tool."
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+ file://arm-eabi.patch;patch=1"
+
+inherit autotools
+
+export INCLUDES = "-I. -I./linux"