summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/angstrom-package-deb.inc3
-rw-r--r--conf/distro/include/angstrom-package-ipk.inc4
-rw-r--r--packages/apt/apt-0.7.2/.mtn2git_empty0
-rw-r--r--packages/apt/apt-0.7.2/noconfigure.patch35
-rw-r--r--packages/apt/apt-0.7.2/nodoc.patch15
-rw-r--r--packages/apt/apt-0.7.3/noconfigure.patch35
-rw-r--r--packages/apt/apt-0.7.3/nodoc.patch15
-rw-r--r--packages/apt/apt-native.inc8
-rw-r--r--packages/apt/apt-native_0.7.2.bb1
-rw-r--r--packages/apt/apt-native_0.7.3.bb5
-rw-r--r--packages/apt/apt-package.inc15
-rw-r--r--packages/apt/apt.inc14
-rw-r--r--packages/apt/apt_0.7.2.bb9
-rw-r--r--packages/apt/apt_0.7.3.bb4
-rw-r--r--packages/apt/files/apt.conf1
-rw-r--r--packages/apt/files/db_linking_hack.patch27
-rw-r--r--packages/bluez/bluez-libs_3.17.bb1
-rw-r--r--packages/bluez/bluez-utils_3.17.bb116
-rw-r--r--packages/dpkg/dpkg-native_1.13.25.bb14
-rw-r--r--packages/dpkg/dpkg_1.13.25.bb11
-rw-r--r--packages/dpkg/files/autofoo.patch48
-rw-r--r--packages/dpkg/files/nochroot.patch18
-rw-r--r--packages/efl1/imlib2_1.4.0.002.bb7
-rw-r--r--packages/intltool/intltool_0.35.2.bb4
-rw-r--r--packages/intltool/intltool_0.35.5.bb4
-rw-r--r--packages/openmoko2/openmoko-firststart2_svn.bb9
-rw-r--r--packages/openmoko2/openmoko-theme-standard2_svn.bb4
27 files changed, 399 insertions, 28 deletions
diff --git a/conf/distro/include/angstrom-package-deb.inc b/conf/distro/include/angstrom-package-deb.inc
index c7a460d7d1..42223dc963 100644
--- a/conf/distro/include/angstrom-package-deb.inc
+++ b/conf/distro/include/angstrom-package-deb.inc
@@ -1 +1,4 @@
INHERIT += "package_deb"
+
+PREFERRED_PROVIDER_virtual/update-alternatives-native = "update-alternatives-dpkg-native"
+PREFERRED_PROVIDER_virtual/update-alternatives = "update-alternatives-dpkg"
diff --git a/conf/distro/include/angstrom-package-ipk.inc b/conf/distro/include/angstrom-package-ipk.inc
index b3f4ff64d6..a33a4ad2b4 100644
--- a/conf/distro/include/angstrom-package-ipk.inc
+++ b/conf/distro/include/angstrom-package-ipk.inc
@@ -1 +1,5 @@
INHERIT += "package_ipk"
+
+PREFERRED_PROVIDER_virtual/update-alternatives-native = "update-alternatives-cworth-native"
+PREFERRED_PROVIDER_virtual/update-alternatives = "update-alternatives-cworth"
+
diff --git a/packages/apt/apt-0.7.2/.mtn2git_empty b/packages/apt/apt-0.7.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apt/apt-0.7.2/.mtn2git_empty
diff --git a/packages/apt/apt-0.7.2/noconfigure.patch b/packages/apt/apt-0.7.2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/packages/apt/apt-0.7.2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/packages/apt/apt-0.7.2/nodoc.patch b/packages/apt/apt-0.7.2/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/packages/apt/apt-0.7.2/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
diff --git a/packages/apt/apt-0.7.3/noconfigure.patch b/packages/apt/apt-0.7.3/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/packages/apt/apt-0.7.3/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/packages/apt/apt-0.7.3/nodoc.patch b/packages/apt/apt-0.7.3/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/packages/apt/apt-0.7.3/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
diff --git a/packages/apt/apt-native.inc b/packages/apt/apt-native.inc
index b615693e64..75cd8f47cd 100644
--- a/packages/apt/apt-native.inc
+++ b/packages/apt/apt-native.inc
@@ -1,11 +1,13 @@
require apt.inc
inherit native
-DEPENDS += "dpkg-native curl-native"
+DEPENDS += "dpkg-native curl-native db-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
PACKAGES = ""
USE_NLS = "no"
+SRC_URI += "file://db_linking_hack.patch;patch=1"
+
python do_stage () {
bb.build.exec_func('do_stage_base', d)
bb.build.exec_func('do_stage_config', d)
@@ -22,7 +24,7 @@ python do_stage_config () {
outdir = os.path.join(bb.data.getVar('sysconfdir', d, 1), 'apt')
if not os.path.exists(outdir):
os.makedirs(outdir)
- outpath = os.path.join(outdir, 'apt.conf')
+ outpath = os.path.join(outdir, 'apt.conf.sample')
outfile = file(outpath, 'w')
outfile.write(data)
@@ -35,7 +37,7 @@ do_stage_base () {
install -m 0755 bin/apt-get ${bindir}/
install -m 0755 bin/apt-config ${bindir}/
install -m 0755 bin/apt-cache ${bindir}/
-
+ install -m 0755 bin/apt-ftparchive ${bindir}/
install -m 0755 bin/apt-sortpkgs ${bindir}/
install -m 0755 bin/apt-extracttemplates ${bindir}/
diff --git a/packages/apt/apt-native_0.7.2.bb b/packages/apt/apt-native_0.7.2.bb
index 43f73889f7..3342618aa9 100644
--- a/packages/apt/apt-native_0.7.2.bb
+++ b/packages/apt/apt-native_0.7.2.bb
@@ -1,4 +1,5 @@
require apt-native.inc
+PR = "r1"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1"
diff --git a/packages/apt/apt-native_0.7.3.bb b/packages/apt/apt-native_0.7.3.bb
new file mode 100644
index 0000000000..6db567f987
--- /dev/null
+++ b/packages/apt/apt-native_0.7.3.bb
@@ -0,0 +1,5 @@
+require apt-native.inc
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1 \
+ file://noconfigure.patch;patch=1"
diff --git a/packages/apt/apt-package.inc b/packages/apt/apt-package.inc
index 5a5d56930e..43f54cadab 100644
--- a/packages/apt/apt-package.inc
+++ b/packages/apt/apt-package.inc
@@ -77,18 +77,11 @@ do_install () {
install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
- install -d ${D}${libdir}
eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
- eval `cat apt-pkg/makefile | grep ^MAJOR | sed -e's, = ,=,'`
- eval `cat apt-pkg/makefile | grep ^MINOR | sed -e's, = ,=,'`
- install bin/libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
- ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg$GLIBC_VER-6.so.$MAJOR
- ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg.so
- eval `cat apt-inst/makefile | grep ^MAJOR | sed -e's, = ,=,'`
- eval `cat apt-inst/makefile | grep ^MINOR | sed -e's, = ,=,'`
- install bin/libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
- ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst$GLIBC_VER-6.so.$MAJOR
- ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst.so
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${D}${libdir}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${D}${libdir}/libapt-inst.so
install -d ${D}${libdir}/apt/methods
install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
diff --git a/packages/apt/apt.inc b/packages/apt/apt.inc
index 2644866c5b..92507be188 100644
--- a/packages/apt/apt.inc
+++ b/packages/apt/apt.inc
@@ -1,6 +1,8 @@
DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
+DEPENDS = "curl db"
+RDEPENDS = "dpkg"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
file://environment.patch;patch=1"
@@ -10,10 +12,14 @@ inherit autotools gettext
EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
-# Apt wants to know the glibc version by running a binary file, which will fail, so we have to tell configure which version to use
-# Since I don't know the impliations of setting a wrong value I only provide one for angstrom, which uses glibc 2.5 (which claims to be 2.4)
+# Apt wants to know the glibc version by running a binary file, which will
+# fail, so we have to tell configure which version to use Since I don't know
+# the impliations of setting a wrong value I only provide one for angstrom,
+# which uses glibc 2.5 (which claims to be 2.4)
# Koen - 20070327
EXTRA_OECONF_append_angstrom = " ac_cv_glibc_ver=libc6.4"
-FILES_${PN}-dbg += "${libdir}/apt/methods/.debug"
-
+# under Debian it is set to libc6.3 as they use glibc 2.3
+# They also provide glibc 2.5 in 'experimental' and it works with APT built
+# for 2.3 so we set it in same way
+EXTRA_OECONF_append = " ac_cv_glibc_ver=libc6.3"
diff --git a/packages/apt/apt_0.7.2.bb b/packages/apt/apt_0.7.2.bb
new file mode 100644
index 0000000000..2a7f963d2f
--- /dev/null
+++ b/packages/apt/apt_0.7.2.bb
@@ -0,0 +1,9 @@
+require apt.inc
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
diff --git a/packages/apt/apt_0.7.3.bb b/packages/apt/apt_0.7.3.bb
index 24023f2a58..c4cf06544b 100644
--- a/packages/apt/apt_0.7.3.bb
+++ b/packages/apt/apt_0.7.3.bb
@@ -1,4 +1,5 @@
require apt.inc
+PR = "r1"
SRC_URI += "file://nodoc.patch;patch=1"
@@ -6,6 +7,3 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
-
-PR = "r1"
-
diff --git a/packages/apt/files/apt.conf b/packages/apt/files/apt.conf
index 6fd653dfcd..9e90616465 100644
--- a/packages/apt/files/apt.conf
+++ b/packages/apt/files/apt.conf
@@ -29,6 +29,7 @@ Dir "${STAGING_DIR}/"
APT
{
+ Install-Recommends "true";
Immediate-Configure "false";
Architecture "i586";
Get
diff --git a/packages/apt/files/db_linking_hack.patch b/packages/apt/files/db_linking_hack.patch
new file mode 100644
index 0000000000..3c8368b1ed
--- /dev/null
+++ b/packages/apt/files/db_linking_hack.patch
@@ -0,0 +1,27 @@
+Index: apt-0.7.3/configure.in
+===================================================================
+--- apt-0.7.3.orig/configure.in 2007-07-01 10:38:45.000000000 +0000
++++ apt-0.7.3/configure.in 2007-08-21 13:39:26.000000000 +0000
+@@ -67,8 +67,20 @@
+ [AC_DEFINE(HAVE_BDB)
+ BDBLIB="-ldb"
+ AC_MSG_RESULT(yes)],
+- [BDBLIB=""
+- AC_MSG_RESULT(no)]
++
++ LIBS="$LIBS -lpthread"
++ [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread)
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [#include <db.h>],
++ [int r, s, t; db_version(&r, &s, &t);]
++ )],
++ [AC_DEFINE(HAVE_BDB)
++ BDBLIB="-ldb -lpthread"
++ AC_MSG_RESULT(yes)],
++ [BDBLIB=""
++ AC_MSG_RESULT(no)]
++ )]
+ )]
+ )
+
diff --git a/packages/bluez/bluez-libs_3.17.bb b/packages/bluez/bluez-libs_3.17.bb
new file mode 100644
index 0000000000..6ddf62a4fb
--- /dev/null
+++ b/packages/bluez/bluez-libs_3.17.bb
@@ -0,0 +1 @@
+require bluez-libs.inc
diff --git a/packages/bluez/bluez-utils_3.17.bb b/packages/bluez/bluez-utils_3.17.bb
new file mode 100644
index 0000000000..b8dbfbca7c
--- /dev/null
+++ b/packages/bluez/bluez-utils_3.17.bb
@@ -0,0 +1,116 @@
+require bluez-utils.inc
+
+DEPENDS += "glib-2.0"
+
+# ti patch doesn't apply, people using it should rediff it and send it upstream
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
+ file://hcid.conf \
+# file://hciattach-ti-bts.patch;patch=1 \
+ "
+PR = "r0"
+
+EXTRA_OECONF = " \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-alsa \
+ --enable-cups \
+ --enable-glib \
+ --disable-sdpd \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --enable-echo \
+ --enable-configfile \
+ --enable-initscripts \
+ --enable-test \
+ "
+
+# The config options are explained below:
+
+# --enable-obex enable OBEX support
+# --enable-alsa enable ALSA support, not needed for nokia770, nokia800 and fic-gtao1
+# --enable-cups install CUPS backend support
+# --enable-bccmd install BCCMD interface utility
+# --enable-avctrl install Audio/Video control utility
+# --enable-hid2hci install HID mode switching utility
+# --enable-dfutool install DFU firmware upgrade utility
+
+# --enable-glib For systems that use and install GLib anyway
+# --disable-sdpd The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server
+
+#Following services can be enabled so far:
+# --enable-network
+# --enable-serial
+# --enable-input
+# --enable-audio
+# --enable-echo
+
+#There is no need to modify any init script. They will be started
+#automatically or on demand. Only /etc/bluetooth/*.service files should
+#be patched to change name or the autostart value.
+# --enable-configfile
+# --enable-initscripts
+
+#For even smaller -doc packages
+# --disable-manpages
+# --disable-pcmciarules
+
+#I haven't seen any embedded device with HID proxy support. So simply
+#disable it:
+# --disable-hid2hci
+
+
+PACKAGES =+ "${PN}-compat ${PN}-alsa"
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default/bluetooth \
+ "
+
+CONFFILES_${PN}-compat = " \
+ ${sysconfdir}/bluetooth/rfcomm.conf \
+ "
+
+FILES_${PN} = " \
+ ${base_sbindir}/hcid \
+ ${libdir}/bluetooth \
+ ${sysconfdir}/init.d/bluetooth \
+ ${sysconfdir}/bluetooth/*.service \
+ ${sysconfdir}/bluetooth/hcid.conf \
+ ${sysconfdir}/default \
+ ${sysconfdir}/dbus-1 \
+ ${base_sbindir}/hciattach \
+ "
+
+FILES_${PN}-dbg += " \
+ ${libdir}/bluetooth/.debug \
+ ${libdir}/cups/backend/.debug \
+ ${libdir}/alsa-lib/.debug \
+ "
+
+FILES_${PN}-compat = " \
+ ${base_bindir}/sdptool \
+ ${base_bindir}/dund \
+ ${base_bindir}/rctest \
+ ${base_bindir}/ciptool \
+ ${base_bindir}/l2test \
+ ${base_bindir}/rfcomm \
+ ${base_bindir}/hcitool \
+ ${base_bindir}/pand \
+ ${base_bindir}/hidd \
+ ${base_bindir}/l2ping \
+ ${base_sbindir}/hciconfig \
+ ${base_sbindir}/bccmd \
+ ${base_sbindir}/hciemu \
+ ${base_sbindir}/hid2hci \
+ ${base_bindir}/passkey-agent \
+ ${sysconfdir}/bluetooth/rfcomm.conf \
+ "
+
+FILES_${PN}-alsa = "${libdir}/alsa-lib/libasound*"
+
+FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
+RDEPENDS_bluez-cups-backend = "cups"
+
+
diff --git a/packages/dpkg/dpkg-native_1.13.25.bb b/packages/dpkg/dpkg-native_1.13.25.bb
new file mode 100644
index 0000000000..0d60e0bddb
--- /dev/null
+++ b/packages/dpkg/dpkg-native_1.13.25.bb
@@ -0,0 +1,14 @@
+require dpkg.inc
+PR = "r0"
+DEPENDS += "zlib-native"
+SRC_URI += "file://noman.patch;patch=1"
+
+inherit native
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-selinux \
+ --without-sgml-doc"
diff --git a/packages/dpkg/dpkg_1.13.25.bb b/packages/dpkg/dpkg_1.13.25.bb
new file mode 100644
index 0000000000..deccb32827
--- /dev/null
+++ b/packages/dpkg/dpkg_1.13.25.bb
@@ -0,0 +1,11 @@
+require dpkg.inc
+PR = "r0"
+DEPENDS += "ncurses zlib bzip2"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc"
diff --git a/packages/dpkg/files/autofoo.patch b/packages/dpkg/files/autofoo.patch
new file mode 100644
index 0000000000..691121e418
--- /dev/null
+++ b/packages/dpkg/files/autofoo.patch
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- dpkg-1.10.23/configure.in~autofoo
++++ dpkg-1.10.23/configure.in
+@@ -227,21 +227,36 @@
+ # OpenBSD passes AC_TRY_COMPILE for va_copy even though
+ # it doesn't seem to exist, which is odd. We need to use
+ # AC_TRY_RUN.
++#
++# If crosscompiling, use AC_TRY_COMPILE. -CL
+ AC_TRY_RUN([
+ #include <stdarg.h>
+ main(){
+ va_list v1,v2;
+ va_copy(v1, v2);
+ exit(0);}
+-], [AC_MSG_RESULT(yes)
+-AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])],[AC_MSG_RESULT(no)
+-AC_MSG_CHECKING([for va_list assignment copy])
++], [dpkg_cv_va_copy=yes], [dpkg_cv_va_copy=no],
+ AC_TRY_COMPILE([
+ #include <stdarg.h>
++main(){
++va_list v1,v2;
++va_copy(v1, v2);
++exit(0);}
++], [dpkg_cv_va_copy=yes], [dpkg_vc_va_copy=no]))
++
++if test "$dpkg_cv_va_copy" = "yes"; then
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])
++else
++ AC_MSG_RESULT(no)
++ AC_MSG_CHECKING([for va_list assignment copy])
++ AC_TRY_COMPILE([
++#include <stdarg.h>
+ ],[
+ va_list v1,v2;
+ v1 = v2;
+-], AC_MSG_RESULT(yes),AC_MSG_ERROR(no))])
++], AC_MSG_RESULT(yes), AC_MSG_ERROR(no))
++fi
+
+ DPKG_C_GCC_ATTRIBUTE([,,],supported,[int x],[,,],ATTRIB,[Define if function attributes a la GCC 2.5 and higher are available.],
+ DPKG_C_GCC_ATTRIBUTE(noreturn,noreturn,[int x],noreturn,NORETURN,[Define if nonreturning functions a la GCC 2.5 and higher are available.])
diff --git a/packages/dpkg/files/nochroot.patch b/packages/dpkg/files/nochroot.patch
new file mode 100644
index 0000000000..3a8beaebbf
--- /dev/null
+++ b/packages/dpkg/files/nochroot.patch
@@ -0,0 +1,18 @@
+---
+ src/help.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- dpkg-1.13.22.orig/src/help.c
++++ dpkg-1.13.22/src/help.c
+@@ -175,9 +175,11 @@ static const char* preexecscript(const c
+ */
+ size_t instdirl;
+
++#if 0
+ if (*instdir) {
+ if (chroot(instdir)) ohshite(_("failed to chroot to `%.250s'"),instdir);
+ }
++#endif
+ if (f_debug & dbg_scripts) {
+ fprintf(stderr,"D0%05o: fork/exec %s (",dbg_scripts,path);
+ while (*++argv) fprintf(stderr," %s",*argv);
diff --git a/packages/efl1/imlib2_1.4.0.002.bb b/packages/efl1/imlib2_1.4.0.002.bb
index a50eca9623..a275143d3a 100644
--- a/packages/efl1/imlib2_1.4.0.002.bb
+++ b/packages/efl1/imlib2_1.4.0.002.bb
@@ -2,10 +2,15 @@ DESCRIPTION = "A graphic library for file loading, saving, rendering, and manipu
LICENSE = "BSD"
# can also depend on tiff34, ungif or gif, z, bz2, id3tag
DEPENDS = "freetype libpng jpeg"
-PR = "r0"
+PR = "r1"
inherit efl_library
+# TODO: Use more fine granular version
+#OE_LT_RPATH_ALLOW=":${libdir}/imlib2/loaders:${libdir}/imlib2/filters:"
+OE_LT_RPATH_ALLOW = "any"
+OE_LT_RPATH_ALLOW[export]="1"
+
PACKAGES =+ "imlib2-loaders-dbg imlib2-filters-dbg imlib2-loaders imlib2-filters"
FILES_${PN} = "${libdir}/lib*.so.* ${libdir}/imlib2/*/*.so"
FILES_${PN}-dbg = "${libdir}/.debug/ ${bindir}/.debug/"
diff --git a/packages/intltool/intltool_0.35.2.bb b/packages/intltool/intltool_0.35.2.bb
index 6626ed54fe..5e2f94eb43 100644
--- a/packages/intltool/intltool_0.35.2.bb
+++ b/packages/intltool/intltool_0.35.2.bb
@@ -1,8 +1,8 @@
require intltool.inc
DEPENDS = "libxml-parser-perl-native"
-#RDEPENDS = "libxml-parser-perl"
+RDEPENDS = "perl-module-text-wrap perl-module-re"
-PR = "r0"
+PR = "r1"
RRECOMMENDS = "perl-modules"
diff --git a/packages/intltool/intltool_0.35.5.bb b/packages/intltool/intltool_0.35.5.bb
index e13e376f12..fc713172f9 100644
--- a/packages/intltool/intltool_0.35.5.bb
+++ b/packages/intltool/intltool_0.35.5.bb
@@ -1,9 +1,9 @@
require intltool.inc
DEPENDS = "libxml-parser-perl-native"
-#RDEPENDS = "libxml-parser-perl"
+RDEPENDS = "perl-module-text-wrap perl-module-re"
-PR = "r0"
+PR = "r1"
RRECOMMENDS = "perl-modules"
diff --git a/packages/openmoko2/openmoko-firststart2_svn.bb b/packages/openmoko2/openmoko-firststart2_svn.bb
new file mode 100644
index 0000000000..5b24d17d5e
--- /dev/null
+++ b/packages/openmoko2/openmoko-firststart2_svn.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "The OpenMoko First Start Wizard"
+SECTION = "openmoko/apps"
+DEPENDS += "libmokoui2 libglade"
+PV = "0.1.0+svn${SVNREV}"
+PR = "r0"
+
+inherit openmoko2
+
+FILES_${PN} += "${datadir}"
diff --git a/packages/openmoko2/openmoko-theme-standard2_svn.bb b/packages/openmoko2/openmoko-theme-standard2_svn.bb
index bbeba4420f..b006f6d6dc 100644
--- a/packages/openmoko2/openmoko-theme-standard2_svn.bb
+++ b/packages/openmoko2/openmoko-theme-standard2_svn.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "Standard Gtk+ theme for the OpenMoko distribution"
SECTION = "openmoko/base"
RCONFLICTS = "openmoko-theme-standard"
-PV = "0.1.0+svnr${SRCDATE}"
-PR = "r2"
+PV = "0.1.0+${SVNREV}"
+PR = "r3"
inherit openmoko2