summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/native.conf1
-rw-r--r--packages/mc/mc_4.6.0.bb3
2 files changed, 3 insertions, 1 deletions
diff --git a/conf/machine/native.conf b/conf/machine/native.conf
index 8caa6b9f1e..92c3072c8c 100644
--- a/conf/machine/native.conf
+++ b/conf/machine/native.conf
@@ -9,4 +9,5 @@ VENDOR = "-oe"
PREFERRED_PROVIDER_virtual/kernel = "native-kernel"
ASSUME_PROVIDED += "virtual/gcc-initial virtual/gcc virtual/g++"
ASSUME_PROVIDED += "binutils-cross"
+ASSUME_PROVIDED += "virtual/libiconv virtual/libintl virtual/libc"
diff --git a/packages/mc/mc_4.6.0.bb b/packages/mc/mc_4.6.0.bb
index 6636c6747d..74d5d8d191 100644
--- a/packages/mc/mc_4.6.0.bb
+++ b/packages/mc/mc_4.6.0.bb
@@ -6,13 +6,14 @@ SECTION = "console/utils"
PRIORITY = "optional"
DEPENDS = "ncurses glib-2.0"
RDEPENDS = "ncurses-terminfo"
+PR ="r1"
SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
inherit autotools
EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
---without-nfs --without-gpm-mouse"
+--without-nfs --without-gpm-mouse --with-screen=ncurses"
do_configure() {
gnu-configize