summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--classes/tinderclient.bbclass2
-rw-r--r--packages/fbset/.mtn2git_empty0
-rw-r--r--packages/fbset/fbset_2.1.bb46
-rw-r--r--packages/fbset/files/.mtn2git_empty0
-rw-r--r--packages/fbset/files/makefile.patch11
5 files changed, 58 insertions, 1 deletions
diff --git a/classes/tinderclient.bbclass b/classes/tinderclient.bbclass
index fdd16d9113..6e10d0f34b 100644
--- a/classes/tinderclient.bbclass
+++ b/classes/tinderclient.bbclass
@@ -293,7 +293,7 @@ def tinder_do_tinder_report(event):
elif name == "PkgSucceeded":
log += "<--- TINDERBOX Package %s done (SUCCESS)\n" % data.getVar('P', event.data, True)
elif name == "PkgFailed":
- build.exec_task('do_clean', event.data)
+ build.exec_task('do_clean', event.data)
log += "<--- TINDERBOX Package %s failed (FAILURE)\n" % data.getVar('P', event.data, True)
status = 200
elif name == "BuildCompleted":
diff --git a/packages/fbset/.mtn2git_empty b/packages/fbset/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fbset/.mtn2git_empty
diff --git a/packages/fbset/fbset_2.1.bb b/packages/fbset/fbset_2.1.bb
new file mode 100644
index 0000000000..476ded8857
--- /dev/null
+++ b/packages/fbset/fbset_2.1.bb
@@ -0,0 +1,46 @@
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
+#
+# Filename: fbset_2.1.bb
+# Date: 28-May-06
+
+DESCRIPTION = "The fbset console tool"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = ""
+LICENSE = "GPL"
+
+######################################################################################
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
+ file://makefile.patch;patch=1"
+
+######################################################################################
+
+PR = "r0"
+PARALLEL_MAKE=""
+
+######################################################################################
+
+inherit autotools
+
+######################################################################################
+
+do_install() {
+ install -d ${D}/usr/sbin ${D}/usr/share/man/man8 ${D}/usr/share/man/man5
+
+ install -m 0755 ${WORKDIR}/${P}/fbset ${D}/usr/sbin/fbset.real
+
+ install -m 0644 ${WORKDIR}/${P}/*.5 ${D}/usr/share/man/man5
+ install -m 0644 ${WORKDIR}/${P}/*.8 ${D}/usr/share/man/man8
+}
+
+######################################################################################
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /usr/sbin/fbset fbset /usr/sbin/fbset.real 55
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove fbset /usr/sbin/fbset.real
+}
diff --git a/packages/fbset/files/.mtn2git_empty b/packages/fbset/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fbset/files/.mtn2git_empty
diff --git a/packages/fbset/files/makefile.patch b/packages/fbset/files/makefile.patch
new file mode 100644
index 0000000000..eda2af5aa1
--- /dev/null
+++ b/packages/fbset/files/makefile.patch
@@ -0,0 +1,11 @@
+--- fbset-2.1/Makefile.orig 2006-05-27 21:05:20.228048544 +0200
++++ fbset-2.1/Makefile 2006-05-27 21:05:37.266458312 +0200
+@@ -2,7 +2,7 @@
+ # Linux Frame Buffer Device Configuration
+ #
+
+-CC = gcc -Wall -O2 -I.
++CC = arm-linux-gcc -Wall -O2 -I.
+ BISON = bison -d
+ FLEX = flex
+ INSTALL = install