summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/xqt2/files/fix_seqfault_qtscreen.patch13
-rw-r--r--packages/xqt2/xqt2_20060509.bb5
2 files changed, 16 insertions, 2 deletions
diff --git a/packages/xqt2/files/fix_seqfault_qtscreen.patch b/packages/xqt2/files/fix_seqfault_qtscreen.patch
new file mode 100644
index 0000000000..43b97f4bdb
--- /dev/null
+++ b/packages/xqt2/files/fix_seqfault_qtscreen.patch
@@ -0,0 +1,13 @@
+--- xc/../xqt2.vanilla/xfree86/xqt-driver/qtscreen.cc 2009-02-08 15:47:33.000000000 +0100
++++ xc/../xqt2/xfree86/xqt-driver/qtscreen.cc 2009-02-08 15:52:09.000000000 +0100
+@@ -406,7 +406,9 @@
+ //
+ void qtScreen::keyPressEvent(QKeyEvent *ev)
+ {
+- static QTextCodec *codec = QTextCodec::codecForName("eucJP");
++ //static QTextCodec *codec = QTextCodec::codecForName("eucJP");
++ //Better to choose the locale - even better provide a command line switch!
++ static QTextCodec *codec = QTextCodec::codecForLocale();
+
+ #ifdef QWS
+ QCString euc;
diff --git a/packages/xqt2/xqt2_20060509.bb b/packages/xqt2/xqt2_20060509.bb
index 731385adb4..7b56c37f37 100644
--- a/packages/xqt2/xqt2_20060509.bb
+++ b/packages/xqt2/xqt2_20060509.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
SECTION = "opie/applications"
APPTYPE = "binary"
APPNAME = "Xqt"
-PR = "r3"
+PR = "r4"
inherit palmtop
@@ -22,7 +22,8 @@ SRC_URI = "cvs://anonymous@cvs.sourceforge.jp/cvsroot/xqt;module=xqt2;method=pse
file://fephack.patch;patch=1 \
file://xchar2b.patch;patch=1 \
file://xqt-make.patch;patch=1 \
- file://fix_qtscreen_HACK.patch;patch=1 "
+ file://fix_qtscreen_HACK.patch;patch=1 \
+ file://fix_seqfault_qtscreen.patch;patch=1 "
S = "${WORKDIR}/xc"
QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'