summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--packages/gpephone/connect_0.1.bb4
-rw-r--r--packages/gpephone/gpe-session-scripts-phone_0.67.bb2
-rw-r--r--packages/keylaunch/files/makefile-fix.patch14
-rw-r--r--packages/pcmciautils/pcmciautils-014/makefile_fix.patch73
4 files changed, 85 insertions, 8 deletions
diff --git a/packages/gpephone/connect_0.1.bb b/packages/gpephone/connect_0.1.bb
index c5ce0a0d54..a3171eef97 100644
--- a/packages/gpephone/connect_0.1.bb
+++ b/packages/gpephone/connect_0.1.bb
@@ -17,6 +17,6 @@ do_compile() {
do_install() {
install -d ${D}/${prefix}/bin
- install -m755 connect ${D}/${prefix}/bin
- install -m755 disconnect ${D}/${prefix}/bin
+ install -m 755 connect ${D}/${prefix}/bin
+ install -m 755 disconnect ${D}/${prefix}/bin
}
diff --git a/packages/gpephone/gpe-session-scripts-phone_0.67.bb b/packages/gpephone/gpe-session-scripts-phone_0.67.bb
index 24d4a27e80..00031ac546 100644
--- a/packages/gpephone/gpe-session-scripts-phone_0.67.bb
+++ b/packages/gpephone/gpe-session-scripts-phone_0.67.bb
@@ -34,7 +34,7 @@ do_install_append() {
mv ${D}/usr/bin/gpe-logout ${D}/usr/bin/gpe-logout.matchbox
install -d ${D}${sysconfdir}/X11
- install -m755 ${WORKDIR}/phonesession ${D}${sysconfdir}/X11/phonesession
+ install -m 755 ${WORKDIR}/phonesession ${D}${sysconfdir}/X11/phonesession
}
do_install_append_x86() {
diff --git a/packages/keylaunch/files/makefile-fix.patch b/packages/keylaunch/files/makefile-fix.patch
index 30275001df..d9c57e05ac 100644
--- a/packages/keylaunch/files/makefile-fix.patch
+++ b/packages/keylaunch/files/makefile-fix.patch
@@ -1,11 +1,15 @@
---- /tmp/Makefile 2006-07-26 09:31:43.000000000 +0200
-+++ keylaunch-2.0.10/Makefile 2006-07-26 09:32:23.464411000 +0200
-@@ -31,7 +31,7 @@
+--- keylaunch-2.0.10/Makefile.orig 2007-05-25 18:13:39.000000000 +0200
++++ keylaunch-2.0.10/Makefile 2007-05-25 18:15:47.000000000 +0200
+@@ -31,8 +31,10 @@
$(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
install-program: all
- install -sD $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
-+ install -s -D $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
- install -D -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
+- install -D -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -s $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ install -d $(DESTDIR)/etc
++ install -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
install -d $(DESTDIR)/etc/X11/Xsession.d
install 90$(PROG) $(DESTDIR)/etc/X11/Xsession.d/90$(PROG)
+ install -d $(DESTDIR)/etc/X11/Xinit.d
diff --git a/packages/pcmciautils/pcmciautils-014/makefile_fix.patch b/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
index fed5d37bf8..f5bb64b9bd 100644
--- a/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
+++ b/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
@@ -13,3 +13,76 @@ Index: pcmciautils-014/Makefile
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+--- pcmciautils-014/Makefile~ 2007-05-25 19:40:39.000000000 +0200
++++ pcmciautils-014/Makefile 2007-05-25 19:40:39.000000000 +0200
+@@ -258,28 +258,29 @@
+
+ install-hotplug:
+ $(INSTALL) -d $(DESTDIR)$(hotplugdir)
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
++ $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
++ $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
+
+ uninstall-hotplug:
+ - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
+
+ install-socket-hotplug:
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
+- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
++ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
++ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+
+ uninstall-socket-hotplug:
+ - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+ install-socket-tools:
+- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
++ $(INSTALL) -d $(DESTDIR)$(sbindir)
++ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+
+ uninstall-socket-tools:
+ - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+
+ install-tools:
+ $(INSTALL) -d $(DESTDIR)$(sbindir)
+- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
+- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
++ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
++ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
+ $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
+
+ uninstall-tools:
+@@ -289,18 +290,20 @@
+
+ install-config:
+ $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
+- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
++ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
+
+ uninstall-config:
+ # - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
+
+ install-udev:
+- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
++ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
++ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+
+ uninstall-udev:
+ - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+
+ install-man:
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+ $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+ $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+
+--- pcmciautils-014/Makefile~ 2007-05-25 19:43:01.000000000 +0200
++++ pcmciautils-014/Makefile 2007-05-25 19:43:01.000000000 +0200
+@@ -304,7 +304,7 @@
+
+ install-man:
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
++ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+ $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+
+ uninstall-man: